Seguridad y Redes

Tips & Video Tutoriales, Wifislax, VMware, GNS3, VirtualBox, CCNA, Cisco Routers & Switches, [ Programming ]

Interface Loopback + Cisco SDM (Security Device Manager) en GNS3

Este vídeo muestra como instalar una interface Loopback en Windows 7 y después realizar una conexión con un router simulado en GNS3. Tambien se muestra como configurar el router para poder acceder desde el Security Device Manager (SDM).

SDM (Security Device Manager) es una herramienta de configuración basada en el explorador web que simplifica la configuración y las funciones de seguridad de un router a través de asistentes de forma facil y rápida sin conocimientos de la interfaz de linea de comandos (CLI).

Comandos

Configurar una IP al Router y verifica el estado.
R1# configure terminal
R1(config)# interface FastEthernet0/0
R1(config-if)# ip address 192.168.1.6 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# exit
R1# show ip interface brief
Habilitamos el HTTP en el Router y creamos un usuario con sus respectivos privilegios
R1# configure terminal
R1(config)# ip http server
R1(config)# ip http secure-server
R1(config)# username delfirosales password cisco123
R1(config)# username delfirosales privilege 15
R1(config)# ip http authentication local
R1(config)# exit
R1# wr
Probando la Conectividad.
R1# ping 192.168.1.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.5, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 4/15/48 ms
Una vez probada la conectividad, podremos acceder al SDM desde el navegador.

Video Online
http://www.youtube.com/watch?v=8skBKbZzXP0

En este vídeo se muestra como instalar GNS3 en Windows 7, es el segundo vídeo de varios que quiero realizar para ayudar a los demás que tienen problemas con GNS3, después realizare algunos vídeos básicos sobre esta misma herramienta.

En resumen lo que se muestra en el video son los siguientes temas.
Video Online
http://www.youtube.com/watch?v=jdesSM5upAY

En este vídeo muestro cómo solucionar un defecto de GNS3 cuando se crean proyectos y éste no guarda el archivo de configuración inicial o startup_config de un router Cisco.

Video On-line:
http://www.youtube.com/watch?v=LQ0W0oOLKhk

Commandos
R1#show run
R1#show ip interface brief
R1#configure terminal
R1(config)#hostname delfirosales
delfirosales(config)#interface f0/0
delfirosales(config-if)#no shutdown
delfirosales(config-if)#ip address 192.168.1.1 255.255.255.0
delfirosales(config-if)#end
delfirosales#show ip int brief
delfirosales#wr

Instalar GNS3 en Ubuntu 9.10

He pasado un buen rato tratando de instalar gsn3 en ubuntu, es por eso que he decidido crear este post para mostrar los pasos que realice para instalar GNS3 v0.7RC1 en ubuntu 9.10.

¿Cómo instalar GNS3 en Ubuntu 9.10 ?

Abrimos la consola y agregamos lo siguiente.

sudo aptitude install build-essential libelf1 libelf libpcap0.8 libpcap0.8-dev python-dev, python-Python apoyo configobj python-qt4 estiba



Descargamos GNS3 del siguiente enlace http://www.gns3.net/download (Descargamos GNS3-0.7RC1-src.tar.gz)

Una vez descargado el archivo anterior lo extraemos dando clic derecho y "Extraer aquí" o igual puedes hacerlo desde consola con el siguiente comando

tar zxf GNS3-0.7RC1-src.tar.gz

Esto creara una carpeta llamada GNS3-0.7RC1-src.

Ahora pasamos a descargar el Dynamips desde la siguiente pagina http://www.ipflow.utc.fr/blog/ Descargamos 0.2.8-RC2 binary for Linux x86 platforms

Una vez descargado Dynamips hacemos clic derecho en el archivo descargado "dynamips-0.2.8-RC2-x86.bin" y seleccionamos Propiedades, en la sección de permisos activamos la opción "Permitir ejecutar el archivo como un programa" tal como se muestra en la siguiente imagen.


imagen permisos de ejecución.

Ahora desde la consola nos vamos al directorio donde extraimos GSN3, en mi caso GNS3-0.7RC1-src y ejecutamos el siguiente comando.

sudo python setup.py install



Nos dirigimos a la carpeta donde extraimos GSN3, en mi caso GNS3-0.7RC1-src, ahí encontraremos un archivo llamado gsn3, solo hacemos doble clic en el archivo y nos saldrá un recuadro preguntando que hacer, seleccionamos "Ejecutar" esto iniciaría GSN3, también podemos hacerlo desde consola ejecutando "./gns3".



Toca configurar la direccion donde tenemos el Dynamips (dynamips-0.2.8-RC2-x86.bin), para esto podemos dar clic en el numero 1 (step 1) del Menu que se nos presento por primera vez al ejecutar GSN3 o desde el Edit - Preferencias - Dynamips de GSN3.

En la sección de Ruta del ejecutable seleccionamos donde tenemos el archivo descargado "dynamips-0.2.8-RC2-x86.bin", una vez hecho esto hacemos clic en "Prueba" o test, si toda va bien tiene que aparecer un mensaje en verde "Dynamips Successfully started" tal y como se muestra en la siguiente imagen.



Ahora toca agregar las imágenes IOS para esto hacemos clic en el paso 2 (step 2) del menu que se nos presento por primera vez, o desde el menu Edit - Imagenes IOS e Hypervisors.

En la sección Image file seleccionamos la ubicación de la imagen IOS que deseamos agregar y hacemos clic en Save, tal como se muestra en la siguiente imagen.



En esta sección podemos agregar mas imágenes IOS, en mi caso solo agregue una imagen de un router 7200. Una vez hecho esto ya tenemos listo para empezar a emular imágenes IOS.





Realice un vídeo en el que se muestra como instalar GNS3 en ubuntu 9.10, puedes verlo en los siguientes enlaces.

Video - Instalación de GNS3 v0.7 RC1 en Ubuntu 9.10
http://delfirosales.blogspot.com/2010/02/video-instalacion-de-gns3-en-ubuntu.html


How-to: Crear un Laboratorio Basico en Dynamips

Revisando los logs de este pequeño espacio, he visto que la mayor parte de los que llegan por aqui, es por tener problemas en el puerto 7200 a la hora de ejecutar dynamips o cosas como, no se puede iniciar dynamips en el puerto 7200, asi que he decidido crear este pequeño articulo con el objetivo de realizar la configuracion correcta del archivo de configuracion de dynagen para no tener problemas a la hora de iniciar nuestro laboratorio virtual y asi poder correr dos routers que puedan comunicarse entre si en un entorno virtual.

Configuracion Basica de Dinamips

El principal error con el que nos encontraremos al instalar dinamips sera que no podra reconocernos el puerto 7200 y esto puede ser por las siguientes causas.

1. Que no tengas una imagen IOS
2. Que no hallas especificado claramente la ruta de la imagen IOS.

Asi que tendremos cuidado en estos 2 posibles causas. En primer lugar necesitamos descargar el dynagen y tambien necesitaremos el wincap pero para esto puedes revisar el siguiente post.

Una vez instalado todo y listo para iniciar nuestro laboratorio virtual, debemos tener los siguientes iconos en el escritorio.
  • Dynagen Sample Labs
  • Dynamips Server
  • Network device list
  • Pemu Server
Laboratorio Virtual con Dynagen

Lo primero que haremos es hacer doble clic a la carpeta Dynagen Sample Labs localizada en el escritorio y una vez dentro de la carpeta hacemos lo mismo con la carpeta simple1 y dentro de la carpeta nos encontraremos con un archivo llamado simple1.net, este archivo lo abrimos con cualquier editor de texto, ejemplo wordpad y nos encontraremos con lo siguiente:
# Simple lab

[localhost]

[[7200]]
image = \Program Files\Dynamips\images\c7200-jk9o3s-mz.124-7a.image
# On Linux / Unix use forward slashes:
# image = /opt/7200-images/c7200-jk9o3s-mz.124-7a.image
npe = npe-400
ram = 160

[[ROUTER R1]]
s1/0 = R2 s1/0

[[router R2]]
# No need to specify an adapter here, it is taken care of
# by the interface specification under Router R1
Hechemos un viztaso al significado de cada linea del archivo de configuracion simple1.net
# Simple lab
Cualquier linea con con el signo de # es un comentario y por lo tanto lo ignoramos.
[localhost]
El archivo de configuracion simple1.net se divide en tres secciones. El [localhost] de la parte superior es donde se indica el host que está ejecutando Dynamips, y como en este ejemplo tenemos como objetivo ejecutar dynamips en nuestra maquina local lo dejamos como esta [localhost]. Si ejecutaremos dynamips en otro equipo diferente, tendriamos que poner el nombre del equipo o la direccion IP de esa maquina en lugar de [localhost].
[[7200]]
En la seccion de [[7200]] define todos los valores por defecto que se aplicaran a cualquier router 7200, esto nos permite tambien especificar el tamaño de la ram y la imagen IOS.
image = \Program Files\Dynamips\images\c7200-jk9o3s-mz.124-7a.image
# On Linux / Unix use forward slashes:
# image = /opt/7200-images/c7200-jk9o3s-mz.124-7a.image
Esta seccion es primordial que tengas bien ubicado la ruta de donde tengas la imagen IOS, porque es por regular cuando falla el dynamips.
npe = npe-400
ram = 160
cada uno de los router se utilizara un NPE-400 y se le asignaran 160 mb de RAM.
[[ROUTER R1]]
En esta seccionse define el router virtual con la palabra ROUTER y la palabra siguiente es la que define el nombre a este router, que en este ejemplo es R1.
s1/0 = R2 s1/0
Esta lina indica que vamos a tomar la interfaz serial 1/0 del R1 y conectarlo al R2 en serial 1/0 (esto es virtual).
[[router R2]]
En esta linea se crea un segundo router con el nombre de R2.

En mi caso el archivo de configuracion lo tengo de la siguiente manera (poner la direccion de la imagen IOS en la seccion señalada).


Archivo de configuracion de simple1.net

El archivo de configuracion simple1.net como vimos tiene dos routers definidos, el R1 y R2, que están conectados en serie a través de 1/0 en ambos routers, una vez que ya tengamos la configuracion correctamente del simple1.net ahora pasaremos a iniciar el servidor dynamips haciendo doble clic en el icono del nuestro escritorio llamado Dynamips Server.

Iniciando Dynamips Server.

Como se muestra en los anteriores imágenes los dos routers R1 y R2 se han iniciado correctamente, y una cosa que notaras a la hora de iniciar el servidor es que el uso del CPU incrementara muy considerablmente, pero lo veremos un poquito adelante con que comando podremos bajar el uso del CPU para trabajar adecuadamente.

Lo primero que aremos ahora es iniciar la consola del R1 tecleando lo siguiente.
console R1
Haciendo esto nos permitira tener acceso a la consola de R1, y al instante deberiamos de ver todo el proceso de inicio del IOS, una vez que halla terminado este proceso ya podremos configurar nuestro router como si estuvieramos conectados directamente al puerto de consola.


Ahora lo que habras notado es que el uso del CPU se habra disparado al 100% de su uso, lo que tenemos que hacer es parar el R2, haciendo esto en consola de dynagen.
Stop R2
En la imagen anterior podremos ver que el R2 se ha detenido y podremos notar que el uso del CPU se ha dismininuido un poco pero podemos hacer algo mejor que eso con el comando idlepc.

En la imagen anterior podemos ver que R1 ha finalizado el ciclo de arranque y todas las interfaces se han inicializado.

Dynamips por defecto consume recursos de nuestra PC aún cuando los enrutadores no están ejecutando ninguna tarea, esto pone en riesgo la estabilidad de nuestro equipo, para esto podemos establecer un valor de parámetro para la opción de configuración idlepc. Este comando (idlepc) hace un análisis del ser de instrucciones en ejecución por parte de emulador. Detecta qué comandos se ejecutan cuando el enrutador está en idle, con el fin de optimizar
procesamiento) y cuando la consola termina de hacer el análisis, saca unos valores potenciales que podrían seleccionarse para bajar el nivel de procesamiento.

Al elegir el valor de idlepc para R1, podremos notar que el procesamiento cae inmediatamente.

Ahora toca iniciar el R2 escribiendo en consola lo siguiente:
start R2
Esto deberia iniciar el R2, el R2 utiliza el mismo IOS del R1 y debe utilizar los mismos valores de idle-pc para reducir los recursos de nuestro equipo.

Podemos iniciar la consola del R2 tecleando lo siguiente.
console R2
esperaramos a que inicie R2 y despues de halla terminado el proceso de inicio podremos configurarlos.

R1
Router#
Router# conf t
Router(config)# hostname R1
R1(config)# no ip domain-lookup
R1(config)# line con 0
R1(config-line)# exec-timeout 0 0
R1(config-line)# logging synchronous
R1(config-line)# int s1/0
R1(config-if)# ip address 192.168.1.1 255.255.255.0
R1(config-if)# no shut
R1(config-if)# end
R1# wr

R2
Router#
Router# conf t
Router(config)# hostname R2
R2(config)# no ip domain-lookup
R2(config)# line con 0
R2(config-line)# exec-timeout 0 0
R2(config-line)# logging synchronous
R2(config-line)# int s1/0
R2(config-if)# ip address 192.168.1.2 255.255.255.0
R2(config-if)# no shut
R2(config-if)# end
R2# wr
Una vez que los enrutadores virtuales se configuren deben ser capaces de reconocerse mutuamente como si estubieran conectados fisicamente.


Referencias:

Cisco 7200 simulator
Dynamips / Dynagen Tutorial
Pequeño extracto del blog:
This site is dedicated to helping you in your pursuit of becoming a Cisco Certified Internetwork Expert in Routing & Switching, Voice, Security, Service Provider, and Storage. Through this blog you can submit questions to our expert instructors, Brian Dennis - Quintuple CCIE #2210, Scott Morris - Quad CCIE #4713, Brian McGahan – Triple CCIE #8593, Petr Lapukhov - Quad CCIE #16379, Anthony Sequeira - CCIE #15626, and Marvin Greenlee - Triple CCIE #12237. Check back daily as this blog will be updated frequently.
CISSP - Certified Information Systems Security Professional

GCFA - GIAC Certified Forensics Analyst

CHFI - Certified Hacking Forensic Investigator

CCE - Certified Computer Examiner

CCFT - Certified Computer Forensic Technician

EnCE - EnCase Certified Examiner

ACE - AccessData Certified Examiner

CPE - Certified ProDiscover Examiner

De lo que he leído las certificaciones mas solicitadas son ECA y ENCE.