Seguridad y Redes

Tips & Video Tutoriales, Wifislax, VMware, GNS3, VirtualBox, CCNA, Cisco Routers & Switches, [ Programming ]

Rutas Conectadas y Rutas Estáticas

Los Routers necesitan tener rutas en sus tablas de enrutamiento IP para poder enviar los paquetes a la direcciónes correctas. Dos formas por el cual un router agrega rutas en su tabla de enrutamiento es aprendiendo o se da cuenta que redes tiene conectadas en sus interfaces y otra forma es mediante la configuración de las rutas desde la configuración global. La siguiente imagen muestra una topologia básica para configurar rutas estáticas.

Topologia Básica de la Red.

En GNS3, la topologia de rede se vería mas o menos de la siguiente manera.

Topologia de Red en GNS3.

Rutas Conectadas.


Configuración de las interfaces en el Router1
!
interface FastEthernet0/0
ip address 10.1.128.251 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.130.251 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 10.1.1.251 255.255.255.0
duplex auto
speed auto
!
El comando siguiente muestras el estado de las interfaces en el Router1, como se puede ver las tres interfaces están en estado "up & up" y cada interface tiene configurado una dirección IP.
Router1#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.1.128.251    YES manual up                    up
FastEthernet0/1            10.1.130.251    YES manual up                    up
FastEthernet1/0            10.1.1.251      YES manual up                    up
Router1#
El siguiente comando nos muestra las rutas conocidas por el Router1, todas las rutas conectadas (C).
Router1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 3 subnets
C       10.1.1.0 is directly connected, FastEthernet1/0
C       10.1.130.0 is directly connected, FastEthernet0/1
C       10.1.128.0 is directly connected, FastEthernet0/0
Router1#
El Router1 agrego las rutas de las tres subredes que se encuentran conectadas a su tabla de enrutamiento. La letra "C" significa "Conectado".

Rutas Estáticas

Las rutas conectadas son importantes, pero los routers suelen necesitar de otras rutas para enviar la información a todas las subredes de una red. Por ejemplo el Router1 puede fácilmente realizar un Ping a las subredes que tiene conectadas, por ejemplo a la subred conectada 10.1.1.0/24. Sin embargo si se realiza un Ping a la subred 10.1.2.0/24 no la conocerá y no podrá llegar a esa subred. Tal como se muestra a continuación.

Ping a la subred conectada, interface Fa0/0 del Router2.
Router1#ping 10.1.128.252

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.128.252, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/60/116 ms
Router1#
Ping a la Subred 10.1.2.0/24.
Router1#ping 10.1.2.252

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.252, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Router1#
El comando Ping envía un paquete de solicitud ICMP (echo request) a la dirección destino. El host destino responde al ping solicitado con un paquete llamada ICMP de respuesta o echo reply. El comando Ping envía el primer paquete y espera la respuesta. Si se recibe una respuesta, el comando muestra un "!". Si no se recibe una respuesta en el tiempo de espera predeterminado de 2 segundos, el comando ping nos muestra un ".". En el IOS de cisco, el comando Ping envía cinco de estos paquetes de forma predeterminada. En el ejemplo anterior el primer Ping dado a la IP 10.1.128.252 funciona correctamente, ya que nos muestra todos los "!!!!!". Sin embargo, el Ping dado a la dirección IP 10.1.2.252 no funciona, ya que nos muestra todo los ".....", esto es porque el Router1 no tiene una ruta para la subred 10.1.2.0/24 donde se encuentra la IP 10.1.2.252.

La solución mas sencilla y típica para este problema es configurar un protocolo de enrutamiento en los tres Routers. Sin embargo, en lugar de protocolos de enrutamientos, podemos configurar rutas estáticas. Para configurar rutas estáticas se realiza de la siguiente manera.

Configurando Rutas Estáticas en el Router1.
Router1#configure terminal
Router1(config)#ip route 10.1.2.0 255.255.255.0 10.1.128.252
Router1(config)#ip route 10.1.3.0 255.255.255.0 10.1.130.252
Router1(config)#^Z
Router1#
*Mar  1 00:11:14.279: %SYS-5-CONFIG_I: Configured from console by console
Router1#show ip route static
10.0.0.0/24 is subnetted, 5 subnets
S       10.1.3.0 [1/0] via 10.1.130.252
S       10.1.2.0 [1/0] via 10.1.128.252
Router1#
Desde configuración global le indicamos cual sera la subred con su respectiva mascara y la dirección IP del siguiente salto. Ahora el Router1 sabe como enviar las rutas a los demás Routers de la Red. También se muestra el comando show ip route static, con el podemos visualizar que rutas estáticas tenemos configuradas en el Router1. El Signo de "S" significa que la ruta fue configurada estaticamente.

Ping a las demás Subredes.
Router1#ping 10.1.2.252
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.252, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/56/132 ms

Router1#ping 10.1.3.253
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.3.253, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/44/136 ms
Router1#
Visualizar todas las rutas en el Router1.
Router1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 5 subnets
S       10.1.3.0 [1/0] via 10.1.130.252
S       10.1.2.0 [1/0] via 10.1.128.252
C       10.1.1.0 is directly connected, FastEthernet1/0
C       10.1.130.0 is directly connected, FastEthernet0/1
C       10.1.128.0 is directly connected, FastEthernet0/0
Router1#
Como se puede observar tenemos comunicación con las subredes configuradas, esto solo desde el Router1. En los demás Routers se tiene que hacer el mismo proceso para configurar las rutas estáticas y así tener comunicación con las demás subredes.

GNS3, impresionado con idlepc + idlemax

Todo iba muy bien con el uso de GNS3 en Windows, hasta que me encontré con una topologia de 8 routers corriendo OSPF, donde no podía configurar OSPF en el router 7 y 8, ya que el uso del CPU de mi maquina se disparaba al 100%. Aunque busque la forma de encontrar un mejor idle-pc, seguía al 100%. Lo que hice fue dejar el tema con solo 6 router corriendo OSPF y seguir con la practica aunque incompleta. Por cierto esto no paso con los protocolos de enrutamiento como RIP y EIGRP, en estos escenarios si pude configurar correctamente RIP y EIGRP en los 8 routers sin ningún problema. El problema fue al configurar OSPF.

Después de unos días, leyendo en algunos blogs, específicamente en el blog de Daniel Dib, me encontré con un valor interesante para reducir drásticamente el uso del CPU.

El valor se llama idlemax que esta relacionado con el famoso valor idle-pc, para reducir muy drásticamente el uso del CPU, el secreto es utilizar los dos valores (idlepc + idlemax). Como en mi laboratorio de OSPF tenia problemas de inestabilidad, así que decidí probar este valor agregándolo al archivo de configuración .net y estos fueron mis impresiones.

La siguiente imagen muestra mi topologia en GNS3 ejecutando Frame Relay entre en el R1, R2 y R3. También corriendo OSPF del R1 al R6, sin configurar R7 y R8. Pongan detalle en el uso del CPU.

El 89% de uso del CPU.
Configuración del Archivo .net.
autostart = False
[127.0.0.1:7000]
workingdir = OSPFr6_working
udp = 10000
[[3660]]
image = C:\Program Files\GNS3\ios\c3660-ik9o3s-mz.124-13b.bin
idlepc = 0x6051169c
ghostios = True
chassis = 3660
Ahora veamos la gran diferencia utilizando idlepc + idlemax.

Solo el 3% utilizando idlepc + idlemax.

Configuración del Archivo .net (uso de idlepc + idlemax).
autostart = False
[127.0.0.1:7000]
workingdir = OSPFr6_working
udp = 10000
[[3660]]
image = C:\Program Files\GNS3\ios\c3660-ik9o3s-mz.124-13b.bin
idlepc = 0x6051169c
idlemax = 100
ghostios = True
chassis = 3660
Me he quedado impresionado!!. Sin duda es muy útil el usar idlepc + idlemax. Espero que todo salga bien con su topologia.

Referencias:
Drastically decreasing CPU load in Dynamips
How to minimize CPU utilization when using Dynamips/GNS3 (idlepc + idlemax)

Configuración de Frame Relay

Frame Relay es un protocolo WAN muy popular porque facilita la construcción de redes confiables y de bajo costo. Uno de sus principales ventajas es de poder configurar enlaces seriales punto a punto con la capacidad de conectar un sitio a muchos sitios remotos a través de un circuito físico. En este post se mostrara la configuración de Frame Relay utilizando la siguiente topologia.
Empecemos configurando el primer Router
Router1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#int s1/0
Router1(config-if)#ip address 192.168.1.1 255.255.255.248
Router1(config-if)#encapsulation frame-relay
Router1(config-if)#no frame-relay inverse-arp
Router1(config-if)#frame-relay map ip 192.168.1.2 102 broadcast
Router1(config-if)#frame-relay map ip 192.168.1.3 103 broadcast
Router1(config-if)#no shut
Router1(config-if)#
*Mar  1 00:11:15.775: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up
Router1(config-if)#
*Mar  1 00:11:26.775: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up
Router1(config-if)#end
Router1#
Hacemos lo mismo con el Router2
Router2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router2(config)#int s1/0
Router2(config-if)#ip address 192.168.1.2 255.255.255.248
Router2(config-if)#encapsulation frame-relay
Router2(config-if)#no frame-relay inverse-arp
Router2(config-if)#frame-relay map ip 192.168.1.1 201 broadcast
Router2(config-if)#frame-relay map ip 192.168.1.3 201    
Router2(config-if)#no shut
Router2(config-if)#
*Mar  1 00:11:01.831: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up
Router2(config-if)#
*Mar  1 00:11:12.831: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up
Router2(config-if)#end
Router2#
Finalmente la configuracion del Router3
Router3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router3(config)#int s1/0
Router3(config-if)#ip address 192.168.1.3 255.255.255.248
Router3(config-if)#encapsulation frame-relay
Router3(config-if)#no frame-relay inverse-arp
Router3(config-if)#frame-relay map ip 192.168.1.1 301 broadcast
Router3(config-if)#frame-relay map ip 192.168.1.2 301   
Router3(config-if)#no shut
Router3(config-if)#
*Mar  1 00:11:33.187: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up
Router3(config-if)#
*Mar  1 00:11:44.187: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up
Router3(config-if)#
Router3(config-if)#end
Router3#
Mostrar el estado de la interface serial1/0 en el Router3
Router3#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet0/1            unassigned      YES unset  administratively down down
Serial1/0                  192.168.1.3     YES manual up                    up
Serial1/1                  unassigned      YES unset  administratively down down
Serial1/2                  unassigned      YES unset  administratively down down
Serial1/3                  unassigned      YES unset  administratively down down
Realizar una prueba de conectividad.
Router3#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/73/132 ms
Router3#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/105/344 ms
Router3#
Mostrar el estado de la interface serial1/0 en el Router2
Router2#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet0/1            unassigned      YES unset  administratively down down
Serial1/0                  192.168.1.2     YES manual up                    up
Serial1/1                  unassigned      YES unset  administratively down down
Serial1/2                  unassigned      YES unset  administratively down down
Serial1/3                  unassigned      YES unset  administratively down down
Realizar una prueba de conectividad.
Router2#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/63/148 ms
Router2#ping 192.168.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/127/276 ms
Router2#
Verificacamos la misma informacion en el Router1
Router1#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet0/1            unassigned      YES unset  administratively down down
Serial1/0                  192.168.1.1     YES manual up                    up
Serial1/1                  unassigned      YES unset  administratively down down
Serial1/2                  unassigned      YES unset  administratively down down
Serial1/3                  unassigned      YES unset  administratively down down

Router1#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/56/140 ms
Router1#ping 192.168.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/60/140 ms
Router1#
Información de encapsulacion y otros datos de la interface serial1/0
Router1#show interfaces serial1/0
Serial1/0 is up, line protocol is up
 Hardware is M4T
 Internet address is 192.168.1.1/29
 MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation FRAME-RELAY, crc 16, loopback not set
 Keepalive set (10 sec)
 Restart-Delay is 0 secs
 LMI enq sent  44, LMI stat recvd 45, LMI upd recvd 0, DTE LMI up
 LMI enq recvd 0, LMI stat sent  0, LMI upd sent  0
 LMI DLCI 0  LMI type is ANSI Annex D  frame relay DTE
 Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 0
 Last input 00:00:00, output 00:00:00, output hang never
 Last clearing of "show interface" counters 00:08:52
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: weighted fair
 Output queue: 0/1000/64/0 (size/max total/threshold/drops)
    Conversations  0/1/256 (active/max active/max total)
    Reserved Conversations 0/0 (allocated/max allocated)
    Available Bandwidth 1158 kilobits/sec
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
    85 packets input, 4870 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    89 packets output, 4936 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 output buffer failures, 0 output buffers swapped out
    1 carrier transitions     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
Router1#
Estadísticas LMI
Router1#show frame-relay lmi

LMI Statistics for interface Serial1/0 (Frame Relay DTE) LMI TYPE = ANSI
Invalid Unnumbered info 0             Invalid Prot Disc 0
Invalid dummy Call Ref 0              Invalid Msg Type 0
Invalid Status Message 0              Invalid Lock Shift 0
Invalid Information ID 0              Invalid Report IE Len 0
Invalid Report Request 0              Invalid Keep IE Len 0
Num Status Enq. Sent 51               Num Status msgs Rcvd 52
Num Update Status Rcvd 0              Num Status Timeouts 0
Last Full Status Req 00:00:36         Last Full Status Rcvd 00:00:36
El siguiente comando muestra el estado y varias estadísticas útiles de cada uno de los PVC (Permanent Virtual Circuits).
Router1#show frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

       Active     Inactive      Deleted       Static
Local          2            0            0            0
Switched       0            0            0            0
Unused         0            0            0            0

DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 20            output pkts 21           in bytes 2080
out bytes 2140           dropped pkts 0           in pkts dropped 0  
out pkts dropped 0                out bytes dropped 0  
in FECN pkts 0           in BECN pkts 0           out FECN pkts 0  
out BECN pkts 0          in DE pkts 0             out DE pkts 0  
out bcast pkts 0         out bcast bytes 0  
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:09:11, last time pvc status changed 00:07:44

DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 20            output pkts 21           in bytes 2080
out bytes 2140           dropped pkts 0           in pkts dropped 0  
out pkts dropped 0                out bytes dropped 0  
in FECN pkts 0           in BECN pkts 0           out FECN pkts 0  
out BECN pkts 0          in DE pkts 0             out DE pkts 0  
out bcast pkts 0         out bcast bytes 0  
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:08:52, last time pvc status changed 00:07:45
Información de los mapas actuales
Router1#show frame-relay map
Serial1/0 (up): ip 192.168.1.2 dlci 102(0x66,0x1860), static,
       broadcast,
       CISCO, status defined, active
Serial1/0 (up): ip 192.168.1.3 dlci 103(0x67,0x1870), static,
       broadcast,
       CISCO, status defined, active
Estadisticas de trafico
Router1#show frame-relay traffic
Frame Relay statistics:
 ARP requests sent 0, ARP replies sent 0
 ARP request recvd 0, ARP replies recvd 0
Router1#

GNS3 Lab: Configuración de SSH (Secure SHell) en GNS3

El primer paso es configurar la interface de bucle invertido con la dirección IP 192.168.1.2 y mascara de subred 255.255.255.0. Hecho lo anterior ahora agregamos un Router y una Nube (Interface de Bucle Invertido) en GNS3 y los conectamos con un cable FastEthernet. Iniciamos el Router (R1) dando clic derecho - "Inicio", una vez mas hacemos clic derecho para abrir la "consola" y ya que hallamos realizado estos pasos, el router comenzara a descomprimir el IOS.


Connected to Dynamips VM "R1" (ID 0, type c3725) - Console port
Smart Init is disabled. IOMEM set to: 5
                         Using iomem percentage: 5
Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

cisco Systems, Inc.
170 West Tasman Drive
San Jose, California 95134-1706

Cisco IOS Software, 3700 Software (C3725-ADVENTERPRISEK9-M), Version 12.4(15)T5, RELEASE SOFTWARE (fc4)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2008 by Cisco Systems, Inc.
Compiled Wed 30-Apr-08 18:27 by prod_rel_team
Image text-base: 0x60008930, data-base: 0x6363A000

Use format command to format the card as DOS File System.
Or use erase command to format the card as Low End File System.

This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 3725 (R7000) processor (revision 0.1) with 124928K/6144K bytes of memory.
Processor board ID XXXXXXXXXXX
R7000 CPU at 240MHz, Implementation 39, Rev 2.1, 256KB L2, 512KB L3 Cache
2 FastEthernet interfaces
DRAM configuration is 64 bits wide with parity enabled.
55K bytes of NVRAM.
16384K bytes of ATA System CompactFlash (Read/Write)
Installed image archive

SETUP: new interface FastEthernet0/0 placed in "shutdown" state
SETUP: new interface FastEthernet0/1 placed in "shutdown" state

Press RETURN to get started!

echsupport
Copyright (c) 1986-2008 by Cisco Systems, Inc.
Compiled Wed 30-Apr-08 18:27 by prod_rel_team
*Mar  1 00:00:22.995: %SNMP-5-COLDSTART: SNMP agent on host R1 is undergoing a cold start
*Mar  1 00:00:23.319: %CRYPTO-6-ISAKMP_ON_OFF: ISAKMP is OFF
*Mar  1 00:00:23.319: %CRYPTO-6-GDOI_ON_OFF: GDOI is OFF
R1>
Ya que el router se halla iniciado correctamente, le configuraremos una IP 192.168.1.1 con mascara de subred 255.255.255.0 y probamos la conectividad haciendo un ping a la interface loopback.
R1> en
R1# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)# int f0/0
R1(config-if)# ip address 192.168.1.1 255.255.255.0
R1(config-if)# no shut
R1(config-if)# end
*Mar  1 00:00:56.195: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar  1 00:00:57.195: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1# show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.1.1     YES manual up                    up
FastEthernet0/1            unassigned      YES unset  administratively down down
R1#
R1# ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 20/58/92 ms
R1#
Ahora empezamos a configurar SSH, para esto primero tenemos que hacer, es crear un nombre de dominio.
R1# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)# enable secret cisco
R1(config)# ip domain-name delfirosales.com
Generar el certificado RSA con un tamaño entre el rango de 360-2048. En este ejemplo se muestra con el tamaño de 1024.
R1(config)# crypto key generate rsa general-keys modulus 1024
The name for the keys will be: R1.delfirosales.com

% The key modulus size is 1024 bits
% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]

R1(config)#
*Mar  1 00:01:36.367: %SSH-5-ENABLED: SSH 1.99 has been enabled
Algunos detalles adicionales como el configurar el tiempo de inactividad para la sesión, el numero de veces que uno puede fallar al intentarse logearse.
R1(config)# ip ssh time-out ?
<1-120>  SSH time-out interval (secs)
R1(config)# ip ssh time-out 60
R1(config)# ip ssh authentication-retries 3
Configurar los protocolos permitidos en las lineas VTY.
R1(config)# line vty 0 4
R1(config-line)# login local
R1(config-line)# transport input ssh telnet
R1(config-line)# exit
R1(config)#
Crear un usuario y contraseña
R1(config)# username delfirosales password cisco
R1(config)# exit
R1# wr
Building configuration...
[OK]

Iniciamos sesion SSH con PuTTY

login as: delfirosales
Using keyboard-interactive authentication.
Password:

R1> enable
Password:
R1#
R1# show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.1.1     YES manual up                    up
FastEthernet0/1            unassigned      YES unset  administratively down down
R1# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)# hostname delfirosales
delfirosales(config)# end
delfirosales# wr
Building configuration...
[OK]

SSH funcionando en GNS3.

Configurando SDM en un Router Cisco

Para configurar Security Device Manager (SDM) en el Router, lo primero que aremos es conectar el Router con nuestra PC directamente utilizando un cable crossover, y verificar que halla conectividad entre el Router y nuestra Computadora.

Configuración
PC: 192.168.1.5
Router: 192.168.1.6
R1> enable
R1# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)# interface f0/0
R1(config-if)# ip address 192.168.1.6 255.255.255.0
R1(config-if)# no shutdown
*Mar  1 00:06:21.423: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar  1 00:06:22.423: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)# exit
R1(config)# exit
R1# ping 192.168.1.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.5, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 4/20/44 ms
En los comandos anteriores, lo que se realizo es configurar la interfaz FastEthernet del Router con una dirección IP y activamos el comando no shutdown para encender la interface. Luego probamos la conectividad con un ping a la PC conectada directamente.

Ahora lo que haremos es habilitar el protocolo HTTP en el router (tambien podemos configurar el HTTPS). Crear un usuario y password con su respectivos privilegios. También utilizaremos el comando authentication loca para iniciar sesión en SDM localmente. Por últimos configuramos la consola, telnet y SSH (si deseamos usar telnet o SSH) para proporcionar autenticación en el inicio de sesión local de acceso privilegiado.
R1# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)# ip http server
R1(config)# ip http secure-server
% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]
R1(config)# ip http authentication local
R1(config)# username delfirosales privilege 15 password cisco
R1(config)# line console 0
R1(config-line)# login local
R1(config-line)# exit
R1(config)# line vty 0 ?
<1-1276>  Last Line number

R1(config)# line vty 0 1276
R1(config-line)# privilege level 15
R1(config-line)# login local
R1(config-line)# transport input ssh telnet
R1(config-line)# exit
R1(config)# exit
R1#
*Mar  1 00:24:31.659: %SYS-5-CONFIG_I: Configured from console by console
R1# copy running-config startup-config
Building configuration...
[OK]
Ahora desde SDM ponemos la dirección IP del Router e iniciamos. Entonces empieza a cargar SDM utilizando Java.

Configuración de SSH en un Router Cisco

SSH (Secure Shell) es mas seguro que Telnet, es por eso que en este post veremos como configurarlo en un Router Cisco. Lo primero que aremos es configurarle un hostname al router y establecer un nombre de dominio. Estos detalles son necesarios para generar las claves rsa y una vez terminado de generar las claves, solo tendremos que configurar algunas cosas adicionales, como crear un nombre de usuario con su respectiva contraseña, configurar el tiempo de inactividad para la sesión, el numero de veces que uno puede fallar al intentarse logearse y así como los protocolos permitidos para entrar por las lineas VTY.
R1# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)# hostname Delfi
Delfi(config)# ip domain-name delfirosales.com  
Delfi(config)# crypto key generate rsa general-keys modulus ?
<360-2048>  size of the key modulus [360-2048]

Delfi(config)# crypto key generate rsa general-keys modulus 1024
The name for the keys will be: Delfi.delfirosales.com

% The key modulus size is 1024 bits
% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]
*Mar  1 00:03:52.355: %SSH-5-ENABLED: SSH 1.99 has been enabled

Delfi(config)# ip ssh time-out ?
<1-120>  SSH time-out interval (secs)

Delfi(config)# ip ssh time-out 60
Delfi(config)# ip ssh authentication-retries ?
<0-5>  Number of authentication retries

Delfi(config)# ip ssh authentication-retries 3
Delfi(config)# line vty 0 4
Delfi(config-line)# login local
Delfi(config-line)# transport input ssh telnet
Delfi(config-line)# exit
Delfi(config)# username delfirosales password cisco
Delfi(config)# exit
Utilizamos PuTTy para iniciar sesión en SSH, al conectarnos nos mostrado un dialogo para aceptar el certificado tal como se muestra en la siguiente imagen.

Una vez aceptado el certificado, iniciamos sesión con nuestro nombre de usuario y contraseña.

Interface Loopback + Cisco SDM (Security Device Manager) en GNS3

Este vídeo muestra como instalar una interface Loopback en Windows 7 y después realizar una conexión con un router simulado en GNS3. Tambien se muestra como configurar el router para poder acceder desde el Security Device Manager (SDM).

SDM (Security Device Manager) es una herramienta de configuración basada en el explorador web que simplifica la configuración y las funciones de seguridad de un router a través de asistentes de forma facil y rápida sin conocimientos de la interfaz de linea de comandos (CLI).

Comandos

Configurar una IP al Router y verifica el estado.
R1# configure terminal
R1(config)# interface FastEthernet0/0
R1(config-if)# ip address 192.168.1.6 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# exit
R1# show ip interface brief
Habilitamos el HTTP en el Router y creamos un usuario con sus respectivos privilegios
R1# configure terminal
R1(config)# ip http server
R1(config)# ip http secure-server
R1(config)# username delfirosales password cisco123
R1(config)# username delfirosales privilege 15
R1(config)# ip http authentication local
R1(config)# exit
R1# wr
Probando la Conectividad.
R1# ping 192.168.1.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.5, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 4/15/48 ms
Una vez probada la conectividad, podremos acceder al SDM desde el navegador.

Video Online
http://www.youtube.com/watch?v=8skBKbZzXP0

En este vídeo se muestra como instalar GNS3 en Windows 7, es el segundo vídeo de varios que quiero realizar para ayudar a los demás que tienen problemas con GNS3, después realizare algunos vídeos básicos sobre esta misma herramienta.

En resumen lo que se muestra en el video son los siguientes temas.
Video Online
http://www.youtube.com/watch?v=jdesSM5upAY

En este vídeo muestro cómo solucionar un defecto de GNS3 cuando se crean proyectos y éste no guarda el archivo de configuración inicial o startup_config de un router Cisco.

Video On-line:
http://www.youtube.com/watch?v=LQ0W0oOLKhk

Commandos
R1#show run
R1#show ip interface brief
R1#configure terminal
R1(config)#hostname delfirosales
delfirosales(config)#interface f0/0
delfirosales(config-if)#no shutdown
delfirosales(config-if)#ip address 192.168.1.1 255.255.255.0
delfirosales(config-if)#end
delfirosales#show ip int brief
delfirosales#wr

Este tutorial muestra cómo instalar GNS3 en linux, en la distribución de ubuntu en su versión 9.10, como se muestra en el post anterior. Tal como se describe en el vídeo, solo tenemos que seguir algunos pasos sencillos para poder instalar GNS3.
  • Descargar GNS3
  • Descargar el binario de Dynamips para Linux
  • Cambiar el permiso del binario de Dynamips para que se ejecute.
  • Iniciar GNS3 haciendo doble clic al archivo gsn3
  • Establecer la ubicación del binario de Dynamips en las preferencias de GNS3.
  • Añadir una imagen IOS
  • Crear un LAB
  • Entrar en el modo de emulación.
Espero les sirva.

Instalar GNS3 en Ubuntu 9.10

He pasado un buen rato tratando de instalar gsn3 en ubuntu, es por eso que he decidido crear este post para mostrar los pasos que realice para instalar GNS3 v0.7RC1 en ubuntu 9.10.

¿Cómo instalar GNS3 en Ubuntu 9.10 ?

Abrimos la consola y agregamos lo siguiente.

sudo aptitude install build-essential libelf1 libelf libpcap0.8 libpcap0.8-dev python-dev, python-Python apoyo configobj python-qt4 estiba



Descargamos GNS3 del siguiente enlace http://www.gns3.net/download (Descargamos GNS3-0.7RC1-src.tar.gz)

Una vez descargado el archivo anterior lo extraemos dando clic derecho y "Extraer aquí" o igual puedes hacerlo desde consola con el siguiente comando

tar zxf GNS3-0.7RC1-src.tar.gz

Esto creara una carpeta llamada GNS3-0.7RC1-src.

Ahora pasamos a descargar el Dynamips desde la siguiente pagina http://www.ipflow.utc.fr/blog/ Descargamos 0.2.8-RC2 binary for Linux x86 platforms

Una vez descargado Dynamips hacemos clic derecho en el archivo descargado "dynamips-0.2.8-RC2-x86.bin" y seleccionamos Propiedades, en la sección de permisos activamos la opción "Permitir ejecutar el archivo como un programa" tal como se muestra en la siguiente imagen.


imagen permisos de ejecución.

Ahora desde la consola nos vamos al directorio donde extraimos GSN3, en mi caso GNS3-0.7RC1-src y ejecutamos el siguiente comando.

sudo python setup.py install



Nos dirigimos a la carpeta donde extraimos GSN3, en mi caso GNS3-0.7RC1-src, ahí encontraremos un archivo llamado gsn3, solo hacemos doble clic en el archivo y nos saldrá un recuadro preguntando que hacer, seleccionamos "Ejecutar" esto iniciaría GSN3, también podemos hacerlo desde consola ejecutando "./gns3".



Toca configurar la direccion donde tenemos el Dynamips (dynamips-0.2.8-RC2-x86.bin), para esto podemos dar clic en el numero 1 (step 1) del Menu que se nos presento por primera vez al ejecutar GSN3 o desde el Edit - Preferencias - Dynamips de GSN3.

En la sección de Ruta del ejecutable seleccionamos donde tenemos el archivo descargado "dynamips-0.2.8-RC2-x86.bin", una vez hecho esto hacemos clic en "Prueba" o test, si toda va bien tiene que aparecer un mensaje en verde "Dynamips Successfully started" tal y como se muestra en la siguiente imagen.



Ahora toca agregar las imágenes IOS para esto hacemos clic en el paso 2 (step 2) del menu que se nos presento por primera vez, o desde el menu Edit - Imagenes IOS e Hypervisors.

En la sección Image file seleccionamos la ubicación de la imagen IOS que deseamos agregar y hacemos clic en Save, tal como se muestra en la siguiente imagen.



En esta sección podemos agregar mas imágenes IOS, en mi caso solo agregue una imagen de un router 7200. Una vez hecho esto ya tenemos listo para empezar a emular imágenes IOS.





Realice un vídeo en el que se muestra como instalar GNS3 en ubuntu 9.10, puedes verlo en los siguientes enlaces.

Video - Instalación de GNS3 v0.7 RC1 en Ubuntu 9.10
http://delfirosales.blogspot.com/2010/02/video-instalacion-de-gns3-en-ubuntu.html


How-to: Crear un Laboratorio Basico en Dynamips

Revisando los logs de este pequeño espacio, he visto que la mayor parte de los que llegan por aqui, es por tener problemas en el puerto 7200 a la hora de ejecutar dynamips o cosas como, no se puede iniciar dynamips en el puerto 7200, asi que he decidido crear este pequeño articulo con el objetivo de realizar la configuracion correcta del archivo de configuracion de dynagen para no tener problemas a la hora de iniciar nuestro laboratorio virtual y asi poder correr dos routers que puedan comunicarse entre si en un entorno virtual.

Configuracion Basica de Dinamips

El principal error con el que nos encontraremos al instalar dinamips sera que no podra reconocernos el puerto 7200 y esto puede ser por las siguientes causas.

1. Que no tengas una imagen IOS
2. Que no hallas especificado claramente la ruta de la imagen IOS.

Asi que tendremos cuidado en estos 2 posibles causas. En primer lugar necesitamos descargar el dynagen y tambien necesitaremos el wincap pero para esto puedes revisar el siguiente post.

Una vez instalado todo y listo para iniciar nuestro laboratorio virtual, debemos tener los siguientes iconos en el escritorio.
  • Dynagen Sample Labs
  • Dynamips Server
  • Network device list
  • Pemu Server
Laboratorio Virtual con Dynagen

Lo primero que haremos es hacer doble clic a la carpeta Dynagen Sample Labs localizada en el escritorio y una vez dentro de la carpeta hacemos lo mismo con la carpeta simple1 y dentro de la carpeta nos encontraremos con un archivo llamado simple1.net, este archivo lo abrimos con cualquier editor de texto, ejemplo wordpad y nos encontraremos con lo siguiente:
# Simple lab

[localhost]

[[7200]]
image = \Program Files\Dynamips\images\c7200-jk9o3s-mz.124-7a.image
# On Linux / Unix use forward slashes:
# image = /opt/7200-images/c7200-jk9o3s-mz.124-7a.image
npe = npe-400
ram = 160

[[ROUTER R1]]
s1/0 = R2 s1/0

[[router R2]]
# No need to specify an adapter here, it is taken care of
# by the interface specification under Router R1
Hechemos un viztaso al significado de cada linea del archivo de configuracion simple1.net
# Simple lab
Cualquier linea con con el signo de # es un comentario y por lo tanto lo ignoramos.
[localhost]
El archivo de configuracion simple1.net se divide en tres secciones. El [localhost] de la parte superior es donde se indica el host que está ejecutando Dynamips, y como en este ejemplo tenemos como objetivo ejecutar dynamips en nuestra maquina local lo dejamos como esta [localhost]. Si ejecutaremos dynamips en otro equipo diferente, tendriamos que poner el nombre del equipo o la direccion IP de esa maquina en lugar de [localhost].
[[7200]]
En la seccion de [[7200]] define todos los valores por defecto que se aplicaran a cualquier router 7200, esto nos permite tambien especificar el tamaño de la ram y la imagen IOS.
image = \Program Files\Dynamips\images\c7200-jk9o3s-mz.124-7a.image
# On Linux / Unix use forward slashes:
# image = /opt/7200-images/c7200-jk9o3s-mz.124-7a.image
Esta seccion es primordial que tengas bien ubicado la ruta de donde tengas la imagen IOS, porque es por regular cuando falla el dynamips.
npe = npe-400
ram = 160
cada uno de los router se utilizara un NPE-400 y se le asignaran 160 mb de RAM.
[[ROUTER R1]]
En esta seccionse define el router virtual con la palabra ROUTER y la palabra siguiente es la que define el nombre a este router, que en este ejemplo es R1.
s1/0 = R2 s1/0
Esta lina indica que vamos a tomar la interfaz serial 1/0 del R1 y conectarlo al R2 en serial 1/0 (esto es virtual).
[[router R2]]
En esta linea se crea un segundo router con el nombre de R2.

En mi caso el archivo de configuracion lo tengo de la siguiente manera (poner la direccion de la imagen IOS en la seccion señalada).


Archivo de configuracion de simple1.net

El archivo de configuracion simple1.net como vimos tiene dos routers definidos, el R1 y R2, que están conectados en serie a través de 1/0 en ambos routers, una vez que ya tengamos la configuracion correctamente del simple1.net ahora pasaremos a iniciar el servidor dynamips haciendo doble clic en el icono del nuestro escritorio llamado Dynamips Server.

Iniciando Dynamips Server.

Como se muestra en los anteriores imágenes los dos routers R1 y R2 se han iniciado correctamente, y una cosa que notaras a la hora de iniciar el servidor es que el uso del CPU incrementara muy considerablmente, pero lo veremos un poquito adelante con que comando podremos bajar el uso del CPU para trabajar adecuadamente.

Lo primero que aremos ahora es iniciar la consola del R1 tecleando lo siguiente.
console R1
Haciendo esto nos permitira tener acceso a la consola de R1, y al instante deberiamos de ver todo el proceso de inicio del IOS, una vez que halla terminado este proceso ya podremos configurar nuestro router como si estuvieramos conectados directamente al puerto de consola.


Ahora lo que habras notado es que el uso del CPU se habra disparado al 100% de su uso, lo que tenemos que hacer es parar el R2, haciendo esto en consola de dynagen.
Stop R2
En la imagen anterior podremos ver que el R2 se ha detenido y podremos notar que el uso del CPU se ha dismininuido un poco pero podemos hacer algo mejor que eso con el comando idlepc.

En la imagen anterior podemos ver que R1 ha finalizado el ciclo de arranque y todas las interfaces se han inicializado.

Dynamips por defecto consume recursos de nuestra PC aún cuando los enrutadores no están ejecutando ninguna tarea, esto pone en riesgo la estabilidad de nuestro equipo, para esto podemos establecer un valor de parámetro para la opción de configuración idlepc. Este comando (idlepc) hace un análisis del ser de instrucciones en ejecución por parte de emulador. Detecta qué comandos se ejecutan cuando el enrutador está en idle, con el fin de optimizar
procesamiento) y cuando la consola termina de hacer el análisis, saca unos valores potenciales que podrían seleccionarse para bajar el nivel de procesamiento.

Al elegir el valor de idlepc para R1, podremos notar que el procesamiento cae inmediatamente.

Ahora toca iniciar el R2 escribiendo en consola lo siguiente:
start R2
Esto deberia iniciar el R2, el R2 utiliza el mismo IOS del R1 y debe utilizar los mismos valores de idle-pc para reducir los recursos de nuestro equipo.

Podemos iniciar la consola del R2 tecleando lo siguiente.
console R2
esperaramos a que inicie R2 y despues de halla terminado el proceso de inicio podremos configurarlos.

R1
Router#
Router# conf t
Router(config)# hostname R1
R1(config)# no ip domain-lookup
R1(config)# line con 0
R1(config-line)# exec-timeout 0 0
R1(config-line)# logging synchronous
R1(config-line)# int s1/0
R1(config-if)# ip address 192.168.1.1 255.255.255.0
R1(config-if)# no shut
R1(config-if)# end
R1# wr

R2
Router#
Router# conf t
Router(config)# hostname R2
R2(config)# no ip domain-lookup
R2(config)# line con 0
R2(config-line)# exec-timeout 0 0
R2(config-line)# logging synchronous
R2(config-line)# int s1/0
R2(config-if)# ip address 192.168.1.2 255.255.255.0
R2(config-if)# no shut
R2(config-if)# end
R2# wr
Una vez que los enrutadores virtuales se configuren deben ser capaces de reconocerse mutuamente como si estubieran conectados fisicamente.


Referencias:

Cisco 7200 simulator
Dynamips / Dynagen Tutorial
Corriendo 14 routers en Dynamips bajo Ubuntu, y lo impresionante con solo 2 Gb de RAM.

Instalación y Configuración de Dynamips/Dynagen

Dynamips es un emulador de equipos cisco que fue escrito por Christophe Fillot, que emula routers 1700, 2600, 3600, 3700, y 7200. Esto nos permitirá familiarizarnos mas con los comandos de los dispositivos cisco, y claro esta que este emulador no podra igualar a un router real, pero nos sera de mucha ayuda porque es una herramienta muy buena para las personas que quieran practicar y lograr las certificaciones como el CCNA/CCNP/CCIE o también para los administradores de redes cisco.

Dynamips esta escrito en Python y es compatible con cualquier plataforma como Linux, Mac OS X o Windows y lo mejor de todo es de código abierto y gratuito para descargar!!

Para poder ejecutar Dinamips primero debemos instalar las WinPcap, descargamos las librerias de su sitio web http://www.winpcap.org/ y también descargamos el Dynamips/Dynagen http://dynagen.org/.
Instalacion de WinPcap

Ejecutamos WinPcap, y nos saldrá la siguiente pantalla.
Una vez hecho lo anterior, nos aparecerá la siguiente imagen, solo damos clic en Next
Damos clic en I Agree.
Y comenzara a copiar los archivos necesarios para terminar la instalación.
Al final solo hacemos clic en Finish para terminar la instalación de WinPcap.

Instalación y configuración de Dynamips/Dynagen.

Ejecutamos Dynagen para comenzar la instalación, nos aparecerá la siguiente imagen de bienvenida, solo damos clic en Next.
En el siguiente paso nos aparecerá lo siguiente, y solo damos clic en I gree para seguir con la instalación.
En el siguiente paso hacemos clic en Install.
Una vez hecho lo anterior, automáticamente comenzara a copiar los archivos al disco duro.
Al terminar nos aparecerá lo siguiente, y solo damos clic en Finish para terminar la instalación de Dynagen.

Al terminar la instalación nos aparecerán en el escritorio las siguientes accesos directos.

Imágenes IOS(Internetwork Operating System)

Ahora toca copiar las imágenes IOS en la ruta de instalación de Dynagen/Dynamips y en la subcarpeta images, como se muestra en la siguiente imagen.
imagen IOS c7200-ik9s-mz.124-17a.bin copiada en la carpeta images de la instalacion de dynagen.
Ahora abrimos la carpeta del escritorio Dynagen Sample Labs y nos vamos a la carpeta simple1, en la carpeta nos encontraremos un archivo con el nombre de simple1.net, este archivo debemos modificarlo, y para eso damos clic derecho al archivo y seleccionamos Abrir con... y Seleccionamos el Blog de notas o cualquier editor de texto.
En el archivo simple1.net nos encontraremos lo siguiente. y en la parte seleccionada \Program Files\Dynamips\images\c7200-jk9o3s-mz.124-7a.image cambiamos la ruta por la imagen de nuestra imagen IOS, por ejemplo en mi caso, la imagen IOS lo tengo direccion, C:\Archivos de programa\Dynamips\images\c7200-ik9s-mz.124-17a.bin, esta direccion la agrego como se muestra en las siguientes dos imagenes.


Ruta de la imagen IOS

Iniciar el Laboratorio Virtual.

Para iniciar el laboratorio necesitamos ejecutar el archivo Dynamips Server, en nuestro escritorio podremos encontrar un acceso directo con el nombre de Dynamips Server, este acceso directo si lo ejecutamos lo que hara es iniciar el servidor, (Por defecto escucha en el puerto 7200) como se muestra en la siguiente imagen.
Ejecutando Dynamips Server.

Ahora nos dirigimos a la dirección C:\Archivos de programa\Dynamips\sample_labs\simple1 y hacemos doble clic en el archivo simple1.net, al hacer esto nos aparecerá lo siguiente.


Podemos ejecutar el comando List y veremos hay dos routers, R1 y R2. Ambos routers se está ejecutando en nuestra máquina local. R1 ligado al puerto TCP 2000, y R2 al puerto 2001.
Para iniciar la consola del R1 solo tecleamos telnet R1 o si queremos que sean todos tecleamos console /all, y se abrirán todas las ventanas de cada enrutador.


También notaremos como el procesamiento del CPU sube a casi el 100%, y para evitar esto es necesario generar un valor de idlepc el cual permite que los enrutadores virtuales no consuman recursos de nuestra maquina cuando no están ejecutando tareas. Para generar el valor de idlepc para el enrutador R1, debemos ejecutar lo siguiente.

=> idlepc get R1

Al ejecutar este comando bajara el procesamiento del CPU muy considerablemente.

Sin duda Dynagen tiene muchas ventajas ya que es un emulador, no un simulador como el packet tracer.

Espero que les sirva esta pequeña guía.

Referencias.

Using Dynamips for CCIE Lab Preparation on a PC
http://classroom.internetworkexpert.com/p27794135/

Dynamips / Dynagen Tutorial
http://dynagen.org/tutorial.htm