Seguridad y Redes

Tips & Video Tutoriales, Wifislax, VMware, GNS3, VirtualBox, CCNA, Cisco Routers & Switches, [ Programming ]

Configuración de OSPF en un Cisco 3725 (IOS) y Nexus 7000 (NX-OS)

A continuación, se muestra un ejemplo de configuración básica de OSPF entre un Switch Nexus y un Router 3725. Para habilitar OSPF en el Cisco Nexus se realiza desde la configuración de la interfaz.

Topologia en GNS3.

Habilitamos OSPF
N7K-2(config)# feature ospf
Habilitamos el proceso de OSPF
N7K-2(config)# router ospf 10
N7K-2(config-router)# router-id 10.10.10.1
Habilitamos OSPF en la interface en particular
N7K-2(config)# int ethernet 2/2
N7K-2(config-if)# ip address 10.10.10.1 255.255.255.0
N7K-2(config-if)# no shutdown
N7K-2(config-if)# ip router ospf 10 area 0
N7K-2(config-if)# end
N7K-2#
Configuración de OSPF en el Cisco 3725.
ESW1(config)#interface fastEthernet0/1
ESW1(config-if)#ip add 10.10.10.2 255.255.255.0
ESW1(config-if)#no shutdown

ESW1(config)#interface fastEthernet0/0
ESW1(config-if)#ip add 10.4.4.4 255.255.255.0
ESW1(config-if)#no shutdown
ESW1(config-if)#exit

ESW1(config)#interface loopback2
ESW1(config-if)#ip address 10.3.3.3 255.255.255.0
ESW1(config-if)#end

ESW1#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.4.4.4        YES manual up                    up      
FastEthernet0/1            10.10.10.2      YES manual up                    up      
FastEthernet1/0            unassigned      YES unset  up                    down    
FastEthernet1/14           unassigned      YES unset  up                    down    
FastEthernet1/15           unassigned      YES unset  up                    down    
Vlan1                      unassigned      YES unset  up                    down    
Loopback1                  10.2.2.2        YES manual up                    up      
Loopback2                  10.3.3.3        YES manual up                    up      

ESW1(config)#router ospf 10
ESW1(config-router)#network 10.10.10.0 0.0.0.255 area 0
*Mar  1 00:06:10.307: %OSPF-5-ADJCHG: Process 10, Nbr 10.10.10.1 on FastEthernet0/1 from LOADING to FULL, Loading Done
ESW1(config-router)#networ 10.4.4.0 0.0.0.255 area 0
ESW1(config-router)#

Verificación
ESW1#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.10.10.1        1   FULL/BDR        00:00:33    10.10.10.1      FastEthernet0/1
ESW1


ESW1#show cdp neighbors detail 
-------------------------
Device ID: N7K-2(Nexus-Switch)
Entry address(es): 
  IP address: 10.10.10.1
Platform: Nexus-Switch,  Capabilities: Router Switch IGMP 
Interface: FastEthernet0/1,  Port ID (outgoing port): Ethernet2/2
Holdtime : 165 sec

Version :
Cisco Nexus Operating System (NX-OS) Software, Version 5.1(2)

advertisement version: 2
Duplex: full

ESW1#
Verificación en el Cisco Nexus
N7K-2# show ip route
IP Route Table for VRF "default"
'*' denotes best ucast next-hop
'**' denotes best mcast next-hop
'[x/y]' denotes [preference/metric]

10.4.4.0/24, ubest/mbest: 1/0
    *via 10.10.10.2, Eth2/2, [110/50], 00:00:11, ospf-10, intra
10.10.10.0/24, ubest/mbest: 1/0, attached
    *via 10.10.10.1, Eth2/2, [0/0], 00:01:52, direct
10.10.10.1/32, ubest/mbest: 1/0, attached
    *via 10.10.10.1, Eth2/2, [0/0], 00:01:52, local
N7K-2#

N7K-2# show ip ospf neighbors
 OSPF Process ID 10 VRF default
 Total number of neighbors: 1
 Neighbor ID     Pri State            Up Time  Address         Interface
 10.3.3.3          1 FULL/DR          00:00:09 10.10.10.2      Eth2/2


N7K-2# ping 10.10.10.2
PING 10.10.10.2 (10.10.10.2): 56 data bytes
64 bytes from 10.10.10.2: icmp_seq=0 ttl=254 time=10 ms
64 bytes from 10.10.10.2: icmp_seq=1 ttl=254 time=10 ms
64 bytes from 10.10.10.2: icmp_seq=2 ttl=254 time=10 ms
64 bytes from 10.10.10.2: icmp_seq=3 ttl=254 time=10 ms
64 bytes from 10.10.10.2: icmp_seq=4 ttl=254 time=10 ms

--- 10.10.10.2 ping statistics ---
5 packets transmitted, 5 packets received, 0.00% packet loss
round-trip min/avg/max = 10/10/10 ms
N7K-2#

N7K-2# ping 10.4.4.4
PING 10.4.4.4 (10.4.4.4): 56 data bytes
64 bytes from 10.4.4.4: icmp_seq=0 ttl=254 time=10 ms
64 bytes from 10.4.4.4: icmp_seq=1 ttl=254 time=10 ms
64 bytes from 10.4.4.4: icmp_seq=2 ttl=254 time=0 ms
64 bytes from 10.4.4.4: icmp_seq=3 ttl=254 time=0 ms
64 bytes from 10.4.4.4: icmp_seq=4 ttl=254 time=10 ms

--- 10.4.4.4 ping statistics ---
5 packets transmitted, 5 packets received, 0.00% packet loss
round-trip min/avg/max = 0/6/10 ms
N7K-2#

Configuración de SVIs en un Switch de Capa 3

Las VLAN dividen dominios de transmisión en un entorno LAN. Siempre que los host de una VLAN necesitan comunicarse con algun otro host en otra VLAN, debe enrutarse el tráfico entre ellos. Esto se denomina ruteo interVLAN. En los switches Catalyst, se logra al crear interfaces de Capa 3 (Switch Virtual Interface - SVI).

Host1
IP: 10.1.1.5
Default Gateway: 10.1.1.1
Subnet: 255.255.255.0 

Host2
IP: 10.1.2.2
Default Gateway: 10.1.2.1
Subnet: 255.255.255.0
Topologia en GNS3 utilizando la imagen vIOS-L2 y Core Linux.

Configuracion en Core Linux 1.
labs login: delfi
Password:
                                   /\_/\
                                  ( o.o )
                                   > ^ <
                              delfirosales.com
delfi@labs:~$ 
delfi@labs:~$ sudo su
root@labs:/home/delfi# ifconfig eth0 10.1.1.5 netmask 255.255.255.0 up
root@labs:/home/delfi# route add default gw 10.1.1.1
Core Linux 2.
delfi@labs:~$ 
delfi@labs:~$ sudo su
root@labs:/home/delfi# ifconfig eth0 10.1.2.2 netmask 255.255.255.0 up
root@labs:/home/delfi# route add default gw 10.1.2.1
root@labs:/home/delfi# 
Habilitar ruteo en el Switch
vIOS-L2#configure terminal
vIOS-L2(config)#ip routing 
Configuracion y creacion de VLANs
vIOS-L2(config)#interface gigabitEthernet0/1
vIOS-L2(config-if)#switchport access vlan 2
% Access VLAN does not exist. Creating vlan 2
vIOS-L2(config-if)#switchport mode access 
vIOS-L2(config-if)#exit

vIOS-L2(config)#interface gigabitEthernet0/2
vIOS-L2(config-if)#switchport access vlan 3
% Access VLAN does not exist. Creating vlan 3
vIOS-L2(config-if)#switchport mode access 
vIOS-L2(config-if)#exit
Verificacion de las VLANs creadas anterior.
vIOS-L2#show vlan   

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi0/0, Gi0/3
2    VLAN0002                         active    Gi0/1
3    VLAN0003                         active    Gi0/2
100  VLAN100                          active    
200  VLAN0200                         active    
300  VLAN0300                         active    
1002 fddi-default                     act/unsup 
1003 trcrf-default                    act/unsup 
1004 fddinet-default                  act/unsup 
1005 trbrf-default                    act/unsup 

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0   
2    enet  100002     1500  -      -      -        -    -        0      0   
3    enet  100003     1500  -      -      -        -    -        0      0   
100  enet  100100     1500  -      -      -        -    -        0      0   
200  enet  100200     1500  -      -      -        -    -        0      0   
300  enet  100300     1500  -      -      -        -    -        0      0   
1002 fddi  101002     1500  -      -      -        -    -        0      0   
          
VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1003 trcrf 101003     4472  1005   3276   -        -    srb      0      0   
1004 fdnet 101004     1500  -      -      -        ieee -        0      0   
1005 trbrf 101005     4472  -      -      15       ibm  -        0      0   


VLAN AREHops STEHops Backup CRF
---- ------- ------- ----------
1003 7       7       off

Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------


Creacion de la SVI 2.
vIOS-L2(config)#interface vlan 2
vIOS-L2(config-if)#ip address 10.1.1.1 255.255.255.0
vIOS-L2(config-if)#no shutdown 
vIOS-L2(config-if)#exit
Creacion de la SVI 3.
vIOS-L2(config)#interface vlan 3
vIOS-L2(config-if)#ip address 10.1.2.1 255.255.255.0
vIOS-L2(config-if)#no shutdown 
vIOS-L2(config-if)#end
vIOS-L2#
Si ingresamos el siguiente comando podremos observar que las interfaces se encuentran arriba.
vIOS-L2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0     unassigned      YES unset  up                    up      
GigabitEthernet0/1     unassigned      YES unset  up                    up      
GigabitEthernet0/2     unassigned      YES unset  up                    up      
GigabitEthernet0/3     unassigned      YES unset  up                    up      
Vlan2                  10.1.1.1        YES manual up                    up      
Vlan3                  10.1.2.1        YES manual up                    up      
vIOS-L2#
Tambien podremos observar la tabla de ruteo con el comando show ip route.
vIOS-L2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C        10.1.1.0/24 is directly connected, Vlan2
L        10.1.1.1/32 is directly connected, Vlan2
C        10.1.2.0/24 is directly connected, Vlan3
L        10.1.2.1/32 is directly connected, Vlan3
vIOS-L2#

vIOS-L2#show interfaces vlan 2
Vlan2 is up, line protocol is up 
  Hardware is Ethernet SVI, address is 0000.ab5a.8002 (bia 0000.ab5a.8002)
  Internet address is 10.1.1.1/24
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not supported 
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:10, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     652 packets input, 98538 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     17 packets output, 1054 bytes, 0 underruns
     0 output errors, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
vIOS-L2#
Verificacion de Core Linux 1 a Core Linux 2.


Otros comandos de verificacion.
vIOS-L2#show interfaces vlan 3
vIOS-L2#show interface gigabitEthernet0/0
vIOS-L2#show interfaces gigabitEthernet0/0 switchport
vIOS-L2#show vlan brief
Descargar Core Linux: LinuxCore-6.4.1.img

Linux Core en Qemu

Imágenes ISO de Linux Core Live x86 o x86-64 se pueden descargar de su pagina la versión mas reciente es el Core 6.4.1.

Creación de la imagen Qemu
$ qemu-img.exe create -f qcow2 LinuxCore.img 300M
Iniciar Qemu con la imagen ISO Live de Core Linux
$ qemu-system-i386w.exe -boot d -cdrom Core-6.4.1.iso -hda LinuxCore.img
Instalacion de Syslinux Extensions
$ tce-load -wi syslinux
Creación de una nueva Particion Ext4
$ sudo fdisk /dev/sda

n - Agregar particion
p - Particion primaria
Partition number (1-4): 1
First cylinder (1-25, default 1): ENTER
Last cylinder (1-25, default 25): ENTER
a - bootable flag
Partition number (1-4): 1
w - guardar la tabla de particion y salir

$ mkfs.ext4 /dev/sda1


Instalar el Boot Sector
$ dd if=/usr/local/share/syslinux/mbr.bin of=/dev/sda
Reconstruir /etc/fstab y Montar la Particion /dev/sda1
$ sudo rebuildfstab
$ mount /mnt/sda1
Montar el CDROM y copiar los archivos core.gz y vmlinuz a /mnt/sda1/boot
$ sudo mkdir -p /mnt/sda1/boot/extlinux
$ mount /mnt/sr0
$ sudo cp -p /mnt/sr0/boot/* /mnt/sda1/boot
Instalar el Boot Loader
$ sudo extlinux --install /mnt/sda1/boot/extlinux
Creación del Archivo extlinux.conf
$ sudo vi /mnt/sda1/boot/extlinux/extlinux.conf

DEFAULT core
LABEL core
KERNEL /boot/vmlinuz
APPEND initrd=/boot/core.gz quiet
Creación de directorios
$ sudo mkdir /mnt/sda1/tce
$ sudo chown tc:staff /mnt/sda1/tce
$ touch /mnt/sda1/tce/mydata.tgz
Apagar Linux Core

Despues de apagar Linux Core ingresar desde consola
$ qemu-system-i386w.exe -boot c -hda LinuxCore.img
Habilitar en Linux Core la redirección al Puerto Serial
default core
label core
kernel /boot/vmlinuz console=ttyS0,38400n8
        append initrd=/boot/core.gz quiet
Extaer el archivo core.gz
$ mkdir -p /home/tc/temp/extract
$ sudo cp /mnt/sda1/boot/core.gz /home/tc/temp/
$ cd /home/tc/temp/extract/

$ zcat ../core.gz | sudo cpio -i -H newc -d
Desabilitar Autologin para tty1 y agregar ttyS0
$ sudo vi /etc/inittab

#tty1::respawn:/sbin/getty -nl /sbin/autologin 38400 tty1
tty1::respawn:/sbin/getty 38400 tty1
ttyS0::respawn:/sbin/getty 38400 ttyS0

Personalizar entrada al sistema
$ sudo vi /etc/issue

Bienvenido a Core Linux

Username "tc", password no establecido
Editar /etc/securetty y permitir acceso al Puerto Serial ttyS0
Descomentar la linea #ttyS0
$ sudo vi ./etc/securetty

ttyS0
Pack File core.gz
$ sudo su
$ cd /home/tc/temp/extract/

$ find | cpio -o -H newc | gzip -2 > /mnt/sda1/boot/core.gz

$ cd /home/tc
$ rm -rf /home/tc/temp

Guardar cambios de configuración de Linux Core

Por default al reiniciar Linux Core no se guardan los cambios realizados, para guardar los cambios que se realicen se debe editar el scrpt /opt/bootlocal.sh el cual se ejecuta en cada inicio de la maquina virtual. El único editor que viene instalado en Linux Core es el editor vi, para editar el script bootlocal.sh ingresar el siguiente comando.
$ sudo vi /opt/bootlocal.sh
Por ejemplo si desea mantener la dirección IP para la interface eth0 con la direccion 10.1.1.1/24 y el nombre de host sea labs, añadir las siguientes líneas a este archivo.
sudo hostname labs
sudo ifconfig eth0 10.1.1.1 netmask 255.255.255.0 up

Ejemplo de guardar cambios en los directorios.
sudo vi /opt/.filetool.lst
/etc/inittab
/etc/issue
/etc/securetty
Una vez guardado los cambios en vi, se tendrá que guardar esta configuración mediante otro script llamado filetool.sh, para guardar cambios ejecutar el siguiente comando:
$ filetool.sh -b
Otros comandos utiles para utilizar.

sudo reboot
sudo poweroff

Apagar Core Linux Qemu y verificar.

$ sudo poweroff

Una vez apagado Core Linux Ingresar el siguiente comando para verificar
$ qemu-system-i386w.exe -boot c -hda LinuxCore.img -serial telnet:0.0.0.0:3000,server,nowait
Una vez iniciado Core Linux ejecutar el siguiente comando desde consola.
$ telnet localhost 3000



NetFlow - Monitorea los equipos de tu red

NetFlow es un protocolo de red desarrollado por Cisco Systems para recolectar información sobre tráfico IP. Netflow se ha convertido en un estándar de la industria para monitorización de tráfico de red, y actualmente está soportado para varias plataformas además de Cisco IOS y NXOS, como por ejemplo en dispositivos de fabricantes como Juniper, Enterasys Switches, y en sistemas operativos como Linux, FreeBSD, NetBSD y OpenBSD.

Existen varias diferencias entre la versión de implementación del Netflow original, por lo que algunas versiones incorporan algunos datos más, pero en líneas generales el Netflow básico envía al menos la siguiente información.
  • Dirección IP de origen.
  • Dirección IP de destino.
  • Puerto UDP o TCP de origen.
  • Puerto UDP o TCP de destino.
  • Protocolo IP.
  • Interfaz (SNMP ifIndex).
  • Tipo de servicio IP.

R1#configure terminal
R1(config)#interface fastethernet0/0
R1(config-if)#ip address 10.10.10.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#end
R1#

Configuración de SNMP y NetFlow
R1(config)#ip access-list standard ACL
R1(config-std-nacl)#permit host 10.10.10.10
R1(config-std-nacl)#exit

R1(config)#hostname RouterLocal

RouterLocal(config)#snmp-server community secreto rw ACL
RouterLocal(config)#snmp-server location Mexico
RouterLocal(config)#snmp-server contact delfirosales

RouterLocal(config)#interface fastEthernet0/0
RouterLocal(config-if)#ip flow egress 
RouterLocal(config-if)#ip flow ingress 
RouterLocal(config-if)#exit

RouterLocal(config)#ip flow-export version 9
RouterLocal(config)#ip flow-export destination 10.10.10.10 99
RouterLocal(config)#ip flow-export source fastEthernet0/0

RouterLocal(config)#service timestamps 
RouterLocal(config)#logging 10.10.10.10
RouterLocal(config)#ip domain name delfirosales.com
Comandos shows
RouterLocal#show ip cache flow
RouterLocal#show ip flow export
RouterLocal#show ip flow interface
RouterLocal#debug ip flow export


Configuración del NetFlow Collector

Hay varios colectores disponibles, algunos licenciados y otros libres, dependiendo de lo que necesites, con cualquier collector te será muy fácil generar el reporte de los top 10 terminales que consumen ancho de banda. Para esta practica se utilizo Real-Time NetFlow Analyzer de SolarisWinds para concentrar la información, analizarla y generar resportes.




Agregar un Adaptador Loopback en GNS3 con Windows 10

Se recomienda no utilizar el asistente de windows (hdwwiz.exe) para crear el adapatador de bluce invertido (loopback) ya que al querer utilizarlo en el GNS3 envia el siguiente error.
Error en GNS3.
GNS3 management console.
Running GNS3 version 1.3.11 on Windows (64-bit) with Python 3.4.2 Qt 4.8.6.
Copyright (c) 2006-2015 GNS3 Technologies.

== > Server error from 127.0.0.1:8000: R1: unable to create generic ethernet NIO

Para solucionar esto debemos utilizar la herramienta llamada Loopback Manager de GNS3, desde el cual podemos eliminar o agregar algun adaptador loopback. En el siguiente video se muestra la solución a este error.


Dynamic PAT en el Cisco ASA

El Cisco ASA soporta los siguientes tipos mas comunes de NAT.
  • Dynamic NAT: Traducción de muchos a muchos. Traduce las direcciones de origen en las interfaces de seguridad más altos en un rango de direcciones o pool a una interface menos segura para las conexiones salientes.
  • Dynamic PAT: Traducción de muchos a uno. Usualmente un pool de direcciones internas a una interface externa.
  • Static NAT: Traducción de uno a uno, entre una dirección IP en una interface más segura y otra interface menos segura (ejemplo internet) para así poder acceder a los host de una interface de mayor seguridad (ejemplo servidores web en la DMZ) sin exponer la dirección IP real del host en la interface de mayor seguridad.
  • Twice NAT: Permite definir origen y destino desde una sola regla. Son procesadas de acuerdo a la secuencia que fueron insertadas (sin diferenciar estáticos de dinámicos). Puede Referenciar objetos de tipo “network” y “service”.
Configuración Básica de NAT - ASA versión 8.4

Practica en GNS3
Topologia de red Dynamic PAT.

Lo primero es configurar las tres interfaces en el ASA. El segmento de la red ISP está conectada a la interface gigabitEthernet3 con la etiqueta de outside y nivel de seguridad 0. La red interna está conectada a la interface gigabitEthernet1 con etiqueta de nombre inside y con nivel de seguridad 100. El segmento DMZ, donde reside el WebServer está conectado a la interface gigabitEthernet2 del ASA y etiquetado con el nombre de dmz con nivel de seguridad 50.

Datos adicionales:

Interface inside: 192.168.0.1 y es default gateway para los host internos.
Interface dmz: 192.168.1.1 y es el default gateway para los host internos.
Interface outside: 198.51.100.100
Ruta de default: Next-Hop 198.50.100.101

Configuración de la Topología de Red

Configuración PC
Configuración WebServer
!
interface FastEthernet0/0
 ip address 192.168.1.100 255.255.255.0
!         
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!

Configuración ISP
!
interface FastEthernet0/0
 ip address 198.51.100.101 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/1
 ip address 100.1.1.2 255.255.255.252
 serial restart-delay 0
!
ip route 50.50.50.0 255.255.255.0 100.1.1.1
ip route 89.89.89.0 255.255.255.248 198.51.100.100
ip route 192.168.0.0 255.255.255.0 198.51.100.100
!
Configuración R4
!
interface FastEthernet0/0
 ip address 50.50.50.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/1
 ip address 100.1.1.1 255.255.255.252
 serial restart-delay 0
!
ip route 89.89.89.0 255.255.255.248 Serial1/1
ip route 198.51.100.0 255.255.255.0 Serial1/1
!
Configuración R5
!
interface FastEthernet0/0
 ip address 50.50.50.17 255.255.255.0
 duplex auto
 speed auto
!         
ip route 0.0.0.0 0.0.0.0 50.50.50.1
!
line vty 0 5
 password cisco
 login
!
Configuración del ASA
!
interface GigabitEthernet1
 nameif inside
 security-level 100
 ip address 192.168.0.1 255.255.255.0 
!
interface GigabitEthernet2
 nameif dmz
 security-level 50
 ip address 192.168.1.1 255.255.255.0 
!
interface GigabitEthernet3
 nameif outside
 security-level 0
 ip address 198.51.100.100 255.255.255.0 
!
route outside 0.0.0.0 0.0.0.0 198.51.100.101 1
!

Configuración de Dynamic PAT en el ASA
CiscoASA# configure terminal
CiscoASA(config)# object network red-interna
CiscoASA(config-network-object)# subnet 192.168.0.0 255.255.255.0
CiscoASA(config-network-object)# nat (inside,outside) dynamic interface
CiscoASA(config-network-object)# exit

CiscoASA(config)# object network red-dmz
CiscoASA(config-network-object)# subnet 192.168.1.0 255.255.255.0
CiscoASA(config-network-object)# nat (dmz,outside) dynamic interface
CiscoASA(config-network-object)# end
CiscoASA#

Verificación.
Para verificar que está funcionando, volvemos a intentar realizando un telnet a la ip 50.50.50.17.



Habilitando el debug ip icmp para verificar el comportamiento y algunos comandos shows.
R5#debug ip icmp

CiscoASA# show xlate


CiscoASA# show nat detail
CiscoASA# show nat translated interface outside
CiscoASA# sh  local-host

Configuración de NTP con Autenticacion en un Router Cisco

NTP son las siglas de Network Time Protocol el cual nos permite sincronizar los dispositivos que funcionan en una red. Esto es muy importante ya que hay una gran variedad de servicios de red que se basan en la correcta sincronización de horarios de los servidores.

Para esto, el equipo realiza una referencia a un servidor de horario, que puede comparar y ajustar su fecha y la hora con otro servidor NTP publico en internet. El protocolo NTP utiliza el puerto UDP 123 para establecer la conexión con los servidores de horario. Es recomendable e importante configurar primero el protocolo NTP en los equipos de la nuestra red antes de implementar el protocolo estándar Syslog centralizado.

NTP en GNS3.

Configuración de un router Cisco para que sincronice la fecha y hora con un servidor de NTP público en internet.

Primero verificamos conectividad con el servidor NTP público en internet.
R1#ping pool.ntp.org
Translating "pool.ntp.org"...domain server (192.168.137.1) [OK]
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 132.248.30.3, timeout is 2 seconds:
!!!.!
Success rate is 80 percent (4/5), round-trip min/avg/max = 76/98/120 ms
R1#

Verificando conexión.
Configuración del Cliente NTP en R1.
R1#configure terminal
R1(config)#ntp server pool.ntp.org
Translating "pool.ntp.org"...domain server (192.168.137.1) [OK]
R1(config)#

Verificación.
R1#show clock detail
07:17:15.480 UTC Sun Mar 29 2015
Time source is NTP
 
R1#show ntp status
R1#show ntp associations


Verificación de NTP y comandos adicionales del estado de NTP.

Configuración en R2.
R2#configure terminal
R2(config)#ntp server 10.10.10.1
R2(config)#end
R2#
*Mar  1 00:14:15.523: %SYS-5-CONFIG_I: Configured from console by console
 
R2#show clock detail
.07:22:29.536 UTC Sun Mar 29 2015
Time source is NTP
R2#

NTP con Autenticación
R1#configure terminal
R1(config)#ntp authentication-key 1 md5 cisco
R1(config)#ntp authenticate
R1(config)#ntp trusted-key 1

Configuración de R2 como cliente NTP con autenticación.
R2#configure terminal
R2(config)#ntp authenticate
R2(config)#ntp authentication-key 1 md5 cisco
R2(config)#ntp trusted-key 1
R2(config)#ntp server 10.10.10.1 key 1

Syslog Server: Kiwi Syslog - Configuracion de un router Cisco

Si queremos enviar los mensajes de log a un servidor de Syslog (Syslog server) para poder administrar los logs del dispositivo de la red de una forma mas centralizada, podemos enviar los logs que se generan y para que los mensajes se envíen a un servidor.

Es importante que antes de implementar el almacenamiento del log en un Syslog Server, todos los dispositivos de la red estén sincronizados con la misma hora, día y fecha. Para esto debemos de configurar el protocolo Network Time Protocol (NTP) en los switches y routers. Si no sabes realizar esta configuración podras consultar la siguiente publicación sobre NTP Server.

Syslog Server en GNS3.

Para configurar a que el router envíe los logs al Syslog Server debemos ingresar el siguiente comando, loggin host ip_servidor o el comando loggin ip_servidor, indicando la dirección IP del Servidor de Syslog.

Router(config)#logging host 10.10.20.10

10.10.20.10 es el servidor de log.

Podemos limitar la cantidad de mensajes enviados al servidor syslog, según la gravedad con el comando logging trap para establecer el nivel de detalle de la información que será registrada en el log. En este caso es de nivel 7 (debugging) que es el nivel más alto. Niveles de mensajes de Syslog.

R1(config)# logging trap 7

Otro comando importante es el service timestamps, esta configuración es muy importante cuando estemos configurando el loggin porque con esto vamos habilitar que aparezcan los logs con la fecha y la hora en que se genera el log, por default no está habilitado y básicamente lo que hace es que si te pone el log pero no te dice a qué hora fue generado el log, entonces este comando es importante configurarlo en el router.

Router(config)#service timestamps

La segunda parte del procedimiento es efectivamente instalar un software servidor de Syslog en una PC Windows o Linux. Kiwi Syslog Server para Windows es una excelente opción, fácil de instalar y configurar.

Verificacion

R1#debug ip icmp 
ICMP packet debugging is on
R1#

R1#ping 10.10.20.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.20.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/50/148 ms
R1#

00:09:28: ICMP: echo reply rcvd, src 10.10.20.10, dst 10.10.20.1
00:09:28: ICMP: echo reply rcvd, src 10.10.20.10, dst 10.10.20.1
00:09:28: ICMP: echo reply rcvd, src 10.10.20.10, dst 10.10.20.1
00:09:28: ICMP: echo reply rcvd, src 10.10.20.10, dst 10.10.20.1
00:09:28: ICMP: echo reply rcvd, src 10.10.20.10, dst 10.10.20.1

R1#conf t
R1(config)#exit
R1#
*Mar  1 00:09:35.999: %SYS-5-CONFIG_I: Configured from console by console
R1#


Kiwi Syslog en Windows.

Así de simple podemos centralizar la administración del log en nuestra red y mejorar significativamente la respuesta a un posible incidente o ataque de seguridad que tengamos que enfrentar.

DHCP Relay en el Cisco ASA

Las comunicaciones DHCP se realizan por broadcast y los mensajes broadcast no pasan a través de los routers. Por consiguiente, tanto las peticiones DHCP como las respuestas de los servidores no producen ninguna acción fuera de la red local. La solución mas fácil consiste evidentemente en poner un servidor DHCP en cada segmento de la red donde sean necesarios. Sin embargo, si se desea utilizar solo un servidor para varias redes, existe una solución , los agentes DHCP relay.

Un DHCP relay recibe las solicitudes de los clientes en formato de broadcast y las reenvía como unicast a la dirección del servidor DHCP.

Los mensajes unicast pueden pasar por los routers, llegando la información a buen puerto. En seguida, el servidor DHCP responderá con un mensaje en modo unicast con el agente relay como destino y este, a su vez enviara un mensaje broadcast que recibirá el equipo cliente. El cliente DHCP no sabrá que esta tratando con un agente relay, si no que piensa que hay un servidor DHCP real en su segmento.

Habilitar la función DHCP relay en el Cisco ASA.

Identificar el servidor DHCP
ciscoasa(config)# dhcprelay server ip-address interface

Si se tiene más de un servidor DHCP, puede repetir este comando para definir hasta cuatro servidores diferentes. En este caso, las solicitudes DHCP se transmiten a cada uno de los servidores de forma simultánea.

Identificar los clientes DHCP
ciscoasa(config)# dhcprelay enable interface

La palabra clave setroute instala automáticamente una ruta por defecto en el dispositivo.
ciscoasa(config)# dhcprelay setroute interface


CiscoASA(config)# dhcprelay server 20.1.1.2 DMZ
CiscoASA(config)# dhcprelay enable inside
CiscoASA(config)# dhcprelay setroute inside

Configurar la interface inside de los host para obtener la dirección IP por DHCP.
R1(config)#interface fastEthernet0/0
R1(config-if)#ip address dhcp 
R1(config-if)#no shutdown 
R1(config-if)#end
Interface FastEthernet0/0 assigned DHCP address 192.168.1.2, mask 255.255.255.0
R1#
R1#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.1.2     YES DHCP   up                    up      
FastEthernet0/1            unassigned      YES unset  administratively down down   

JunOS - Comandos Basicos

Ingresar al modo de “Operational Mode”.
root@% cli
Es este modo (Operational Mode) no vas a poder realizar ningún tipo de configuración en particular, se usa solo para ver configuraciones y monitorear el estado del equipo. Para ingresar a “Configuration Mode”.
root> configure
Entering configuration mode
root#
Ahora el prompt se muestra con un # al final, arriba podes ver entre corchetes tu ubicación (sumamente útil). Para ejecutar el equivalente a “show run” de CISCO existen dos opciones, desde “Operational mode”.
root> show configuration
Y desde “Configuration Mode”.
root# run show configuration

Establecer una password para el usuario root:
root# set system root-authentication plain-text-password
Configurar Hostname
root# set system host-name Juniper 

Mostrar interfaces o similar a show ip interfaces brief de Cisco.
root@Juniper# run show interfaces terse


Asignar una dirección IP a la interface em0
root@Juniper# set interfaces em0 unit 0 family inet address 192.168.10.1/30

Mostrar configuracion
root@Juniper# show

Borrar alguna linea de configuracion
root@Juniper# delete interfaces em0 unit 0 family inet address 192.168.10/30

Guardar configuración
root@Juniper# commit


Prueba de conectividad con un Ping
root@Juniper# run ping 192.168.10.2

Habilitar Telnet
root@Juniper# set system services telnet

Crear un Usuario y contraseña con class “super-user”:
root@Juniper# set system login user delfirosales class super-user authentication plain-text-password

Guardar cambios con commit

Dejar todo a los valores de fábrica
root@Juniper# load factory-default
root@Juniper# set system root-authentication plain-text-password
root@Juniper# commit

Servidor DHCP en el Cisco ASA

El Cisco ASA puede actuar como un servidor DHCP para distribuir dirección IP a los hosts finales que ejecutan servicios de un cliente DHCP. Esta característica es importante si usted tiene una pequeña sucursal que no posee un servidor DHCP dedicado. 


Para configurar el servidor DHCP a través de ASDM, ir a Configuración > Device Management > DHCP > DHCP server y seleccione la interface en la que desea habilitar los servicios DHCP.



Para configurar un ASA como un servidor DHCP, desde la línea de comandos.

Configuramos la interface inside.
CiscoASA# configure terminal
CiscoASA(config)# interface gigabitEthernet0 
CiscoASA(config-if)# nameif inside
INFO: Security level for "inside" set to 100 by default.
CiscoASA(config-if)# ip address 192.168.1.1 255.255.255.0
CiscoASA(config-if)# no shutdown 

Definir el conjunto de direcciones IP y asignar el pool a los usuarios internos.
CiscoASA(config)# dhcpd address 192.168.1.10-192.168.1.30 inside

Habilitar el servicio de servidor DHCP en la interface
CiscoASA(config)# dhcpd enable inside

Definir el nombre de dominio para los clientes DHCP.
CiscoASA(config)# dhcpd domain delfirosales

Definir un servidor de nombres de dominio (DNS.
CiscoASA(config)# dhcpd dns 192.168.1.50

Tiempo de concesión en segundos. El valor predeterminado es de 3600 segundos (1 hora).
CiscoASA(config)# dhcpd lease 7200



Para comprobar la configuración de DHCP, podemos utilizar el comando show dhcpd state para mostrar el estado actual de DHCP en  las interfaces internas y externas. El comando show dhcpd binding para visualizar los enlaces actuales de los usuarios internos y el comando show dhcpd statistics para mostrar las estadísticas de DHCP.

CiscoASA# show dhcpd state    
Context  Configured as DHCP Server
Interface inside, Configured for DHCP SERVER

CiscoASA# show dhcpd binding
IP address       Client Identifier        Lease expiration        Type
   192.168.1.10  0063.6973.636f.2d63.           7020 seconds    Automatic
                 3830.302e.3037.3734.
                 2e30.3030.302d.4661.
                 302f.30


Para borrar los enlaces de DHCP o estadísticas, utilice el comando clear dhcpd binding o clear dhcpd statistics.

CiscoASA# clear dhcpd binding
CiscoASA# clear dhcpd statistics

Configuración de EIGRP

Las mínimas opciones que podemos configurar para habilitar EIGRP son las siguientes.
  1. Proceso de EIGRP
  2. Sistema Autonomo
  3. Habilitar EIGRP en las interfaces
Topologia a configurar.

Configurar la parte del direccionamiento.

Configuración de R2
R2#configure terminal
R2(config)#interface fastEthernet1/0
R2(config-if)#ip address 192.168.2.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

R2(config)#interface serial2/1
R2(config-if)#ip address 192.168.0.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#end
R2#

Cofiguración de R3
R3#configure terminal 
R3(config)#interface serial1/3
R3(config-if)#ip address 192.168.0.1 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit

R3(config)#interface ethernet0/0
R3(config-if)#ip address 192.168.35.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#end
R3# 

Configuracón de R5
R5#configure terminal 
R5(config)#interface ethernet0/0
R5(config-if)#ip address 192.168.35.5 255.255.255.0
R5(config-if)#no shutdown
R5(config-if)#exit

R5(config)#interface ethernet0/1
R5(config-if)#ip address 192.168.5.5 255.255.255.0
R5(config-if)#no shutdown
R5(config-if)#end
R5#

Si ingresamos el comando show ip route en R2, podremos ver lo siguiente.


Si realizamos un ping a 192.168.35.3 no va responder ya que no tenemos una ruta hacia él. Podemos configurar rutas estáticas, pero en este caso vamos a configurar EIGRP.

R2#ping 192.168.35.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.35.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Pasos para configurar EIGRP

Entrar a configuración global.
R2#configure terminal

Ingresar el comando router eigrp sistema_autonomo. Podemos asignarle un número de AS que va del 1 al 65535.
R2(config)#router eigrp ?
  <1-65535>  Autonomous system number

R2(config)#router eigrp 10
R2(config-router)#no auto-summary

El siguiente paso es indicar en que interfaces va estar corriendo EIGRP. Esto se realiza con el comando network.

R2(config-router)#network 192.168.2.0 0.0.0.255
R2(config-router)#network 192.168.0.0 0.0.0.3

Con este estamos indicando que estamos corriendo EIGRP en ambas interfaces.

Configuración de EIGRP en las interfaces de R3.
R3#configure terminal
R3(config)#router eigrp 10
R3(config-router)#no auto-summary
R3(config-router)#network 192.168.0.0 0.0.0.3
R3(config-router)#network 192.168.35.0 0.0.0.255

*Mar  1 00:01:59.599: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 192.168.0.2 (Serial1/3) is up: new adjacency

Podemos observar que se ha creado una adyacencia.

Como ya tenemos corriendo EIGRP en R3 con R2 podemos ingresar el siguiente comando, el cual nos va listar los vecinos o neighbors que tenemos.

R3#show ip eigrp neighbors


R3#show ip route eigrp


Configuración de EIGRP en R5.

Si primero hacemos un show ip route en R5, veremos las redes que están solamente conectadas.

R5#configure terminal 
R5(config)#router eigrp 10
R3(config-router)#no auto-summary
R5(config-router)#network 192.168.35.0 0.0.0.255 
R5(config-router)#network 192.168.5.5 0.0.0.0 

Configuración de Cisco IOS Zone - Based Policy Firewall

Una de las principales diferencias entre un firewall usando CBAC y ZBPFW (zone based Firewall) es el uso de zonas de seguridad. Estas zonas separan las áreas específicas de seguridad dentro de una red. Cada organización tiene sus propias divisiones específicas de seguridad que deben ser definidos antes de la implementación de un ZBPFW.

Topologia de ejemplo para la Configuracion del IOS Zone Firewall.

Lo primero es crear el Par de Zonas, desde configuración global.
Creamos el inside security zona con el nombre de inside
Creamos el otra zona con el nombre de Outside

Router#configure terminal 
Router(config)#zone security inside
Router(config-sec-zone)#exit
Router(config)#zone security outside
Router(config-sec-zone)#exit

Creamos un class map con el nombre de MI-CLASS-MAP, luego los Matchs de ICMP y telnet.

Router(config)#class-map type inspect match-any MI-CLASS-MAP
Router(config-cmap)#match protocol telnet
Router(config-cmap)#match protocol icmp  
Router(config-cmap)#exit

Creamos una politica de servicio con el nombre de MI-POLITICA, identificamos el class map MI-CLASS-MAP Inspeccionamos todo el trafico.

Router(config)#policy-map type inspect MI-POLITICA
Router(config-pmap)#class type inspect MI-CLASS-MAP
Router(config-pmap-c)#inspect 
Router(config-pmap-c)#exit
Router(config-pmap)#exit

Creamos una Par de Zona o Zone pair identicando la zona fuente (inside) y el destino (outside). Asignamos la política de servicio MI-POLITICA para todo el trafico que pasa del origen al destino.

Router(config)#zone-pair security IN-TO-OUT source inside destination outside
Router(config-sec-zone-pair)#service-policy type inspect MI-POLITICA
Router(config-sec-zone-pair)#exit
Router(config)#

Asignamos las interfaces a su respectivas zonas.

Router(config)#interface fastEthernet0/0 
Router(config-if)#description Es la Zona Inside
Router(config-if)#zone-member security inside
Router(config-if)#exit
Router(config)#interface fastEthernet0/1
Router(config-if)#description Es la Zona Outside
Router(config-if)#zone-member security outside
Router(config-if)#exit
Router(config)#

Verificación desde el Cliente o Inside.

Video - Implementación de Cisco IOS Zone-Based Firewall usando CCP

Qemu & GNS3 en Ubuntu 12.10

Primero instalar algunas aplicaciones necesarias.
root@cisco:/home/delfi# apt-get update
root@cisco:/home/delfi# apt-get install libpcap-dev
root@cisco:/home/delfi# apt-get install build-essential libssl-dev uuid-dev zlib1g-dev libncurses5-dev libx11-dev

Segundo, creamos carpetas y asignamos permisos

root@cisco:/home/delfi# mkdir GNS3
root@cisco:/home/delfi# chmod 777 GNS3
root@cisco:/home/delfi# cd GNS3
root@cisco:/home/delfi/GNS3# mkdir Dynamips
root@cisco:/home/delfi/GNS3# mkdir IOS
root@cisco:/home/delfi/GNS3# mkdir Proyectos
root@cisco:/home/delfi/GNS3# mkdir Capturas
root@cisco:/home/delfi/GNS3# mkdir working
root@cisco:/home/delfi/GNS3# mkdir qemu
root@cisco:/home/delfi/GNS3# chmod 777 Dynamips
root@cisco:/home/delfi/GNS3# chmod 777 IOS
root@cisco:/home/delfi/GNS3# chmod 777 Proyectos
root@cisco:/home/delfi/GNS3# chmod 777 Capturas
root@cisco:/home/delfi/GNS3# chmod 777 working
root@cisco:/home/delfi/GNS3# chmod 777 qemu

Luego descargamos GNS3 v0.8.3.1 en su versión mas reciente, descomprimos y asignamos permisos.
root@cisco:/home/delfi/GNS3# wget http://voxel.dl.sourceforge.net/project/gns-3/GNS3/0.8.3.1/GNS3-0.8.3.1-src.tar.gz
root@cisco:/home/delfi/GNS3# tar -xvzf GNS3-0.8.3.1-src.tar.gz
root@cisco:/home/delfi/GNS3# chmod 777 GNS3-0.8.3.1-src
root@cisco:/home/delfi/GNS3# cd GNS3-0.8.3.1-src
root@cisco:/home/delfi/GNS3/GNS3-0.8.3.1-src# chmod 777 *.*
root@cisco:/home/delfi/GNS3/GNS3-0.8.3.1-src# cd ..
root@cisco:/home/delfi/GNS3# ls
Capturas  Dynamips  GNS3-0.8.3.1-src  GNS3-0.8.3.1-src.tar.gz  IOS  Proyectos  qemu

Realizamos lo mismo con Dynamips.
root@cisco:/home/delfi/GNS3# cd Dynamips/
root@cisco:/home/delfi/GNS3/Dynamips# wget http://voxel.dl.sourceforge.net/project/gns-3/Dynamips/0.2.8-RC3-community/dynamips-0.2.8-RC3-community-x86.bin
root@cisco:/home/delfi/GNS3/Dynamips# chmod 77 dynamips-0.2.8-RC3-community-x86.bin
root@cisco:/home/delfi/GNS3/Dynamips# cd ..
root@cisco:/home/delfi//GNS3# ./gns3

Configuración de Dynamips en GNS3.
Configuración de Qemu
Ahora toca configurar Qemu
root@cisco:/home/delfi/GNS3# cd qemu
root@cisco:/home/delfi/GNS3/qemu# wget http://download.savannah.gnu.org/releases/qemu/qemu-0.11.0.tar.gz
root@cisco:/home/delfi/GNS3/qemu# tar xvzf qemu-0.11.0.tar.gz
root@cisco:/home/delfi/GNS3/qemu# ls
qemu-0.11.0  qemu-0.11.0.tar.gz
root@cisco:/home/delfi/GNS3/qemu# cd qemu-0.11.0
root@cisco:/home/delfi/GNS3/qemu/qemu-0.11.0# wget http://voxel.dl.sourceforge.net/project/gns-3/Qemu/qemu-0.11.0-olive.patch
root@cisco:/home/delfi/GNS3/qemu/qemu-0.11.0# patch -p1 -i qemu-0.11.0-olive.patch
patching file Makefile.target
patching file configure
patching file hw/e1000.c
patching file hw/eepro100.c
patching file net.c
patching file qemu-options.hx
root@cisco:/home/delfi/GNS3/qemu/qemu-0.11.0# ./configure --target-list=i386-softmmu
root@cisco:/home/delfi/GNS3/qemu/qemu-0.11.0# make
root@cisco:/home/delfi/GNS3/qemu/qemu-0.11.0# make install

Averiguamos donde se encuentra qemu y qemu-img con el comando which.
root@cisco:/home/delfi/GNS3/qemu/qemu-0.11.0# which qemu
/usr/local/bin/qemu
root@cisco:/home/delfi/GNS3/qemu/qemu-0.11.0# which qemu-img
/usr/local/bin/qemu-img
root@cisco:/home/delfi/GNS3/qemu/qemu-0.11.0#
Finalmente la configuración de Qemu en GNS3 debe quedar como se muestra en la siguiente imagen.

Configuración de Qemu en GNS3.

Configuración de Linux Microcore en GNS3.

Descargamos Linux Microcore (linux-microcore-3.8.2.img) del siguiente enlace.
http://sourceforge.net/projects/gns-3/files/Qemu%20Appliances/
Una vez que hallamos descargado la imagen, el siguiente paso es abrir GNS3 y dirigirmos al Menú.
Edit > Preferences > Qemu > Qemu Guest

Finalmente quedaría como se muestra a continuación.

Configuración de Linux Microcore en GNS3.


Simple Lab

Arrastramos un Router y Quemu Guest al area de trabajo de GNS3, realizamos las conexiones y luego los inicializamos. Primero le configuramos al Router una dirección IP y habilitamos la interface.
R1#conf t
R1(config)#int f0/0      
R1(config-if)#ip add 192.168.10.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#end
R1#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.10.1    YES manual up                    up    
FastEthernet0/1            unassigned      YES unset  administratively down down  
R1#

Realizamos lo mismo con Linux Microcore.
Micro Core Linux
box login: login[1451]: root login on 'tty1'

Micro Core Linux
box login: root
Password: root

tc@box:~$ sudo su
root@box:~# ifconfig eth0 192.168.10.2 netmask 255.255.255.0 up
root@box:~# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:AB:29:8C:3E:00
          inet addr:192.168.10.2  Bcast:192.168.10.255  Mask:255.255.255.0
          inet6 addr: fe80::2ab:29ff:fe8c:3e00/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:36 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:10278 (10.0 KiB)

Finalmente realizamos una prueba de conectividad.
R1#ping 192.168.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 8/11/12 ms
R1#

root@box:~# ping 192.168.10.1
PING 192.168.10.1 (192.168.10.1): 56 data bytes
64 bytes from 192.168.10.1: seq=0 ttl=255 time=13.310 ms
64 bytes from 192.168.10.1: seq=1 ttl=255 time=11.636 ms
64 bytes from 192.168.10.1: seq=2 ttl=255 time=3.861 ms

Cisco ASA & ASDM en GNS3

Herramientas:
Configuración de ASA en GNS3

Abrimos GNS3, nos vamos al menu
Edit > Preference > QEMU > ASA

RAM: 1024 MiB
Number de Nics: 6
Quemu Options: -vnc none -vga none -m 1024 -icount auto -hdachs 980,16,32

Initrd: C:\Program Files\GNS3\ios\IOS_ASA\asa842-initrd.gz
Kernel: C:\Program Files\GNS3\ios\IOS_ASA\asa842-vmlinuz

Kernel cmd line: -append ide_generic.probe_mask=0x01 ide_core.chs=0.0:980,16,32 auto nousb console=ttyS0,9600 bigphysarea=65536

Configuración de ASA en GNS3.

Topologia.
Iniciamos ASA
Loading hardware drivers...
Intel(R) PRO/1000 Network Driver - version 7.3.21-k3-NAPI
Copyright (c) 1999-2006 Intel Corporation.
e1000 0000:00:02.0: found PCI INT A -> IRQ 9
e1000 0000:00:02.0: sharing IRQ 9 with 0000:00:06.0
e1000: 0000:00:02.0: e1000_probe: (PCI:33MHz:32-bit) 00:ab:cd:92:52:00
e1000: eth0: e1000_probe: Intel(R) PRO/1000 Network Connection
e1000 0000:00:03.0: found PCI INT A -> IRQ 11
e1000: 0000:00:03.0: e1000_probe: (PCI:33MHz:32-bit) 00:00:ab:b1:0b:01
e1000: eth1: e1000_probe: Intel(R) PRO/1000 Network Connection
e1000 0000:00:04.0: found PCI INT A -> IRQ 9

e1000: 0000:00:04.0: e1000_probe: (PCI:33MHz:32-bit) 00:00:ab:d6:5c:02
e1000: eth2: e1000_probe: Intel(R) PRO/1000 Network Connection
e1000 0000:00:05.0: found PCI INT A -> IRQ 11
pci 0000:00:01.3: IRQ routing conflict: have IRQ 9, want IRQ 11
e1000: 0000:00:05.0: e1000_probe: (PCI:33MHz:32-bit) 00:00:ab:d1:82:03
e1000: eth3: e1000_probe: Intel(R) PRO/1000 Network Connection
e1000 0000:00:06.0: found PCI INT A -> IRQ 9
e1000 0000:00:06.0: sharing IRQ 9 with 0000:00:02.0
e1000: 0000:00:06.0: e1000_probe: (PCI:33MHz:32-bit) 00:00:ab:52:cb:04
e1000: eth4: e1000_probe: Intel(R) PRO/1000 Network Connection
e1000: 0000:00:07.0: e1000_probe: (PCI:33MHz:32-bit) 00:00:ab:b5:3f:05
e1000: eth5: e1000_probe: Intel(R) PRO/1000 Network Connection
e100: Intel(R) PRO/100 Network Driver, 3.5.23-k6-NAPI
e100: Copyright(c) 1999-2006 Intel Corporation
loaded.
Initializing random number generator... done.
Starting network...
e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
device eth0 entered promiscuous mode
e1000: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
device eth1 entered promiscuous mode
e1000: eth2 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
device eth2 entered promiscuous mode
e1000: eth3 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
device eth3 entered promiscuous mode
e1000: eth4 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
device eth4 entered promiscuous mode
e1000: eth5 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
device eth5 entered promiscuous mode
Initializing partition -  hda: hda1
done!
mkdosfs 2.11 (12 Mar 2005)

System tables written to disk
dosfsck 2.11, 12 Mar 2005, FAT32, LFN
Starting check/repair pass.
Starting verification pass.
/dev/hda1: 0 files, 0/65463 clusters
dosfsck(/dev/hda1) returned 0
FAT: "posix" option is obsolete, not supported now
TIPC: Started in network mode
TIPC: Own node address <1 data-blogger-escaped-.1.1=".1.1">, network identity 1234
TIPC: Enabled bearer , discovery domain <1 data-blogger-escaped-.1.0=".1.0">, priority 10
msrif: module license 'Cisco Systems, Inc' taints kernel.
msrif module loaded.
Clocksource tsc unstable (delta = 117925313 ns)
grep: /mnt/disk0/.private/startup-config: No such file or directory
Starting Likewise Service Manager
Processor memory 650117120, Reserved memory: 62914560
WARNING: LINA Monitor notification queue not created
No such file or directory
IMAGE ERROR: An error occurred when reading the controller type

Total NICs found: 6
secstore_buf_fill: Error reading secure store -  buffer 0xddfffb08, size 0x14
key_nv_init: read returned error 1, len 129
L4TM: Unknown ASA Model

INFO: Unable to read firewall mode from flash
       Writing default firewall mode (single) to flash
Verify the activation-key, it might take a while...
Failed to retrieve permanent activation key.
Running Permanent Activation Key: 0x00000000 0x00000000 0x00000000 0x00000000 0x00000000
The Running Activation Key is not valid, using default settings:

Licensed features for this platform:
Maximum Physical Interfaces       : Unlimited      perpetual
Maximum VLANs                     : 100            perpetual
Inside Hosts                      : Unlimited      perpetual
Failover                          : Disabled       perpetual
VPN-DES                           : Disabled       perpetual
VPN-3DES-AES                      : Disabled       perpetual
Security Contexts                 : 0              perpetual
GTP/GPRS                          : Disabled       perpetual
AnyConnect Premium Peers          : 5000           perpetual
AnyConnect Essentials             : Disabled       perpetual
Other VPN Peers                   : 5000           perpetual
Total VPN Peers                   : 0              perpetual
Shared License                    : Disabled       perpetual
AnyConnect for Mobile             : Disabled       perpetual
AnyConnect for Cisco VPN Phone    : Disabled       perpetual
Advanced Endpoint Assessment      : Disabled       perpetual
UC Phone Proxy Sessions           : 2              perpetual
Total UC Proxy Sessions           : 2              perpetual
Botnet Traffic Filter             : Disabled       perpetual
Intercompany Media Engine         : Disabled       perpetual

This platform has an ASA 5520 VPN Plus license.

Cisco Adaptive Security Appliance Software Version 8.4(2)
_le_open: fd:4, name:eth0 ---Device eth0 (fd: 4) opened succesful!
_le_open: fd:8, name:eth1 ---Device eth1 (fd: 8) opened succesful!
_le_open: fd:9, name:eth2 ---Device eth2 (fd: 9) opened succesful!
_le_open: fd:10, name:eth3 ---Device eth3 (fd: 10) opened succesful!
_le_open: fd:11, name:eth4 ---Device eth4 (fd: 11) opened succesful!
_le_open: fd:12, name:eth5 ---Device eth5 (fd: 12) opened succesful!

  ****************************** Warning *******************************
  This product contains cryptographic features and is
  subject to United States and local country laws
  governing, import, export, transfer, and use.
  Delivery of Cisco cryptographic products does not
  imply third-party authority to import, export,
  distribute, or use encryption. Importers, exporters,
  distributors and users are responsible for compliance
  with U.S. and local country laws. By using this
  product you agree to comply with applicable laws and
  regulations. If you are unable to comply with U.S.
  and local laws, return the enclosed items immediately.

  A summary of U.S. laws governing Cisco cryptographic
  products may be found at:
  http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

  If you require further assistance please contact us by
  sending email to export@cisco.com.
  ******************************* Warning *******************************

Copyright (c) 1996-2011 by Cisco Systems, Inc.

                Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

                Cisco Systems, Inc.
                170 West Tasman Drive
                San Jose, California 95134-1706

config_fetcher: channel open failed
ERROR: MIGRATION - Could not get the startup configuration.
COREDUMP UPDATE: open message queue fail: No such file or directory/2

INFO: MIGRATION - Saving the startup errors to file 'flash:upgrade_startup_errors_201210220208.log'
Type help or '?' for a list of available commands.
ciscoasa>

Inicialización de ASA.

Configuración para utilizar ASDM

Para utilizar ASDM debemos configurar algunos parametros minimos como el habilitar la conexion HTTP y crear un usuario.
ciscoasa> enable
Password:
ciscoasa#
ciscoasa# show int ip brief
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0           unassigned      YES unset  administratively down up
GigabitEthernet1           unassigned      YES unset  administratively down up
GigabitEthernet2           unassigned      YES unset  administratively down up
GigabitEthernet3           unassigned      YES unset  administratively down up
GigabitEthernet4           unassigned      YES unset  administratively down up
GigabitEthernet5           unassigned      YES unset  administratively down up
ciscoasa#
ciscoasa# configure terminal
ciscoasa(config)#

***************************** NOTICE *****************************

Help to improve the ASA platform by enabling anonymous reporting,
which allows Cisco to securely receive minimal error and health
information from the device. To learn more about this feature,
please visit: http://www.cisco.com/go/smartcall

Would you like to enable anonymous error reporting to help improve
the product? [Y]es, [N]o, [A]sk later:
ciscoasa(config)#
ciscoasa(config)# interface gigabitEthernet0
ciscoasa(config-if)# ip address 192.168.2.1 255.255.255.0
ciscoasa(config-if)# no shutdown
ciscoasa(config-if)# nameif management
INFO: Security level for "management" set to 0 by default.
ciscoasa(config-if)# http server enable
ciscoasa(config)#
ciscoasa(config)# http 192.168.2.2 255.255.255.255 management
ciscoasa(config)# username delfirosales password cisco privilege 15
ciscoasa(config)# end
ciscoasa#

Configuración básica para utilizar ASDM.

Realizamos una prueba de conectividad con la interface Loopback de nuestra PC que tiene la direccion IP 192.168.2.2
ciscoasa# ping 192.168.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/10 ms

Tenemos conexion ahora configuramos el TFTP, en mi caso Solarwins que tiene una carpeta por default llamada TFTP-Root donde copiaremos el archivo ASDM asdm-645.bin

Copiar ASDM desde el Servidor TFTP

ciscoasa# copy tftp: flash:
Address or name of remote host []? 192.168.2.2
Source filename []? asdm-645.bin
Destination filename [asdm-645.bin]?
Accessing tftp://192.168.2.2/asdm-645.bin...!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Writing current ASDM file disk0:/asdm-645.bin
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Comienza el proceso de copiado de ASDM.

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
16280544 bytes copied in 100.60 secs (162805 bytes/sec)
ciscoasa# conf t
ciscoasa(config)# dir

Directory of disk0:/

2      drwx  4096         02:08:09 Oct 22 2012  log
9      drwx  4096         02:08:14 Oct 22 2012  coredumpinfo
11     -rwx  196          02:08:14 Oct 22 2012  upgrade_startup_errors_201210220208.log
12     -rwx  16280544     02:17:56 Oct 22 2012  asdm-645.bin

268136448 bytes total (251813888 bytes free)



Al finalizar el copiado verificamos.

Especificamos el archivo imagen de ASDM. Una vez que hemos especificado el archivo de imagen ASDM, puede utilizar el comando show asdm image para ver la ubicación y nombre del archivo.
ciscoasa(config)#
ciscoasa(config)# asdm image flash:asdm-645.bin
ciscoasa(config)# end
ciscoasa# wr
Building configuration...
Cryptochecksum: 83e572a4 edd8be50 3a7df498 7eef42ca

2376 bytes copied in 1.50 secs (2376 bytes/sec)
[OK]
ciscoasa#

Acceso al ASDM

Despues habrimos un navegador web para acceder al ASDM por primera vez. En la siguiente imagen se muestra accesando al ASDM.

Accesando al ASDM

La pagina nos muestra tres opciones.

Install ASDM Launcher and Run ASDM: El launcher y ASDM se ejecutaran como aplicaciones nativas desde la PC sin necesidad de un navegador web.

Run ASDM: Ejecutara ASDM desde el navegador web como una aplicación Java.

Run Startup Wizard: ASDM iniciará un asistente que nos guiará a través de la configuracion inicial de ASA,
si aún no se ha hecho.

La primera opcion es la mas comun y se debe realizar solo una vez. Ya que tengamos instalado Cisco ASDM-IDM Launcher en nuestra PC ya podremos ejecutar la aplicacion directamente para iniciar una sesion ASDM. La primera opción es la opción más común y se debe hacer sólo una vez. Después de la aplicación Launcher está instalado, puede ejecutarlo directamente para iniciar una sesión de ASDM.

Para iniciar una sesion ejecutamos esta aplicacion el cual nos pedirá la direccion IP, nombre de usuario y contraseña. La dirección IP será almacenada en memoria caché para que la proxima vez que queramos iniciar sesion podamos elegirla de nuevo.

Aplicacion ASDM Launcher

Una vez que lanzamos esta aplicación se conecta al ASA correctamente y con esto ya tenemos ASDM listo para trabajar.