Seguridad y Redes

Tips & Video Tutoriales, Wifislax, VMware, GNS3, VirtualBox, CCNA, Cisco Routers & Switches, [ Programming ]

Configuración de SVIs en un Switch de Capa 3

Las VLAN dividen dominios de transmisión en un entorno LAN. Siempre que los host de una VLAN necesitan comunicarse con algun otro host en otra VLAN, debe enrutarse el tráfico entre ellos. Esto se denomina ruteo interVLAN. En los switches Catalyst, se logra al crear interfaces de Capa 3 (Switch Virtual Interface - SVI).

Host1
IP: 10.1.1.5
Default Gateway: 10.1.1.1
Subnet: 255.255.255.0 

Host2
IP: 10.1.2.2
Default Gateway: 10.1.2.1
Subnet: 255.255.255.0
Topologia en GNS3 utilizando la imagen vIOS-L2 y Core Linux.

Configuracion en Core Linux 1.
labs login: delfi
Password:
                                   /\_/\
                                  ( o.o )
                                   > ^ <
                              delfirosales.com
delfi@labs:~$ 
delfi@labs:~$ sudo su
root@labs:/home/delfi# ifconfig eth0 10.1.1.5 netmask 255.255.255.0 up
root@labs:/home/delfi# route add default gw 10.1.1.1
Core Linux 2.
delfi@labs:~$ 
delfi@labs:~$ sudo su
root@labs:/home/delfi# ifconfig eth0 10.1.2.2 netmask 255.255.255.0 up
root@labs:/home/delfi# route add default gw 10.1.2.1
root@labs:/home/delfi# 
Habilitar ruteo en el Switch
vIOS-L2#configure terminal
vIOS-L2(config)#ip routing 
Configuracion y creacion de VLANs
vIOS-L2(config)#interface gigabitEthernet0/1
vIOS-L2(config-if)#switchport access vlan 2
% Access VLAN does not exist. Creating vlan 2
vIOS-L2(config-if)#switchport mode access 
vIOS-L2(config-if)#exit

vIOS-L2(config)#interface gigabitEthernet0/2
vIOS-L2(config-if)#switchport access vlan 3
% Access VLAN does not exist. Creating vlan 3
vIOS-L2(config-if)#switchport mode access 
vIOS-L2(config-if)#exit
Verificacion de las VLANs creadas anterior.
vIOS-L2#show vlan   

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi0/0, Gi0/3
2    VLAN0002                         active    Gi0/1
3    VLAN0003                         active    Gi0/2
100  VLAN100                          active    
200  VLAN0200                         active    
300  VLAN0300                         active    
1002 fddi-default                     act/unsup 
1003 trcrf-default                    act/unsup 
1004 fddinet-default                  act/unsup 
1005 trbrf-default                    act/unsup 

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0   
2    enet  100002     1500  -      -      -        -    -        0      0   
3    enet  100003     1500  -      -      -        -    -        0      0   
100  enet  100100     1500  -      -      -        -    -        0      0   
200  enet  100200     1500  -      -      -        -    -        0      0   
300  enet  100300     1500  -      -      -        -    -        0      0   
1002 fddi  101002     1500  -      -      -        -    -        0      0   
          
VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1003 trcrf 101003     4472  1005   3276   -        -    srb      0      0   
1004 fdnet 101004     1500  -      -      -        ieee -        0      0   
1005 trbrf 101005     4472  -      -      15       ibm  -        0      0   


VLAN AREHops STEHops Backup CRF
---- ------- ------- ----------
1003 7       7       off

Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------


Creacion de la SVI 2.
vIOS-L2(config)#interface vlan 2
vIOS-L2(config-if)#ip address 10.1.1.1 255.255.255.0
vIOS-L2(config-if)#no shutdown 
vIOS-L2(config-if)#exit
Creacion de la SVI 3.
vIOS-L2(config)#interface vlan 3
vIOS-L2(config-if)#ip address 10.1.2.1 255.255.255.0
vIOS-L2(config-if)#no shutdown 
vIOS-L2(config-if)#end
vIOS-L2#
Si ingresamos el siguiente comando podremos observar que las interfaces se encuentran arriba.
vIOS-L2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0     unassigned      YES unset  up                    up      
GigabitEthernet0/1     unassigned      YES unset  up                    up      
GigabitEthernet0/2     unassigned      YES unset  up                    up      
GigabitEthernet0/3     unassigned      YES unset  up                    up      
Vlan2                  10.1.1.1        YES manual up                    up      
Vlan3                  10.1.2.1        YES manual up                    up      
vIOS-L2#
Tambien podremos observar la tabla de ruteo con el comando show ip route.
vIOS-L2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C        10.1.1.0/24 is directly connected, Vlan2
L        10.1.1.1/32 is directly connected, Vlan2
C        10.1.2.0/24 is directly connected, Vlan3
L        10.1.2.1/32 is directly connected, Vlan3
vIOS-L2#

vIOS-L2#show interfaces vlan 2
Vlan2 is up, line protocol is up 
  Hardware is Ethernet SVI, address is 0000.ab5a.8002 (bia 0000.ab5a.8002)
  Internet address is 10.1.1.1/24
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not supported 
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:10, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     652 packets input, 98538 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     17 packets output, 1054 bytes, 0 underruns
     0 output errors, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
vIOS-L2#
Verificacion de Core Linux 1 a Core Linux 2.


Otros comandos de verificacion.
vIOS-L2#show interfaces vlan 3
vIOS-L2#show interface gigabitEthernet0/0
vIOS-L2#show interfaces gigabitEthernet0/0 switchport
vIOS-L2#show vlan brief
Descargar Core Linux: LinuxCore-6.4.1.img
HDLC (High-Level Data Link Control, control de enlace síncrono de datos) es un protocolo de comunicaciones de propósito general punto a punto y multipunto, que opera a nivel de enlace de datos. Se basa en ISO 3309 e ISO 4335. Surge como una evolución del anterior SDLC. Proporciona recuperación de errores en caso de pérdida de paquetes de datos, fallos de secuencia y otros, por lo que ofrece una comunicación confiable entre el transmisor y el receptor. De este protocolo derivan otros como LAPB, LAPF, LLC y PPP.

Configuración de HDLC

R1#configure terminal
R1(config)#interface Serial0/0
R1(config-if)#encapsulation hdlc
R1(config-if)#ip address 192.168.12.1 255.255.255.252
R1(config-if)#no shutdown

R2#configure terminal
R2(config)#interface Serial0/0
R2(config-if)#encapsulation hdlc
R2(config-if)#ip address 192.168.12.2 255.255.255.252
R2(config-if)#no shutdown

R1#show  interface Serial0/0                 
Serial0/0 is up, line protocol is up
  Hardware is GT96K Serial
  Internet address is 192.168.12.1/30
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  CRC checking enabled
  Last input 00:00:01, output 00:00:00, output hang never
  Last clearing of "show interface" counters 00:34:44
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     239 packets input, 16566 bytes, 0 no buffer
     Received 234 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     249 packets output, 17471 bytes, 0 underruns
     0 output errors, 0 collisions, 4 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

R2#ping 192.168.12.1         
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/35/72 ms

Point-to-Point Protocol

Point-to-point Protocol (Protocolo punto a punto), también conocido por su acrónimo PPP, es un protocolo de nivel de enlace estandarizado en el documento RFC 1661. Por tanto, se trata de un protocolo asociado a la pila TCP/IP de uso en Internet.

R1#configure terminal
R1(config)#interface Serial0/0
R1(config-if)#encapsulation ppp
R1(config-if)#ip address 192.168.12.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#

R2#configure terminal
R2(config)#interface Serial0/0
R2(config-if)#encapsulation ppp
R2(config-if)#ip address 192.168.12.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#

R2#show  interface Serial0/0
Serial0/0 is up, line protocol is up
  Hardware is GT96K Serial
  Internet address is 192.168.12.2/30
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open
  Open: IPCP, CDPCP, loopback not set
  Keepalive set (10 sec)
  CRC checking enabled
  Last input 00:00:16, output 00:00:08, output hang never
  Last clearing of "show interface" counters 00:06:03
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     83 packets input, 3580 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     83 packets output, 3580 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

R2#ping 192.168.12.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/46/68 ms

Comandos debug de PPP

debug ppp authentication
debug ppp negotiation
debug ppp packet
debug ppp error
debug ppp chap

Frame Relay sin Inverse ARP

Frame Relay sin Inverse ARP. Esto significa que crearemos los mapas manualmente.

Topologia Frame Relay
Lo primero es configurar los mapas.

R1(config-if)#no frame-relay inverse-arp
R1(config-if)#no shutdown
R1(config-if)#frame-relay map ip 192.168.123.2 102 broadcast
R1(config-if)#frame-relay map ip 192.168.123.3 103 broadcast
R1(config-if)#frame-relay map ip 192.168.123.4 104 broadcast

R2#conf t
R2(config)#int s1/0
R2(config-if)#no frame-relay inverse-arp
R2(config-if)#no shutdown
R2(config-if)#frame-relay map ip 192.168.123.1 201 broadcast
R2(config-if)#frame-relay map ip 192.168.123.3 203 broadcast
R2(config-if)#frame-relay map ip 192.168.123.4 204 broadcast
R2(config-if)#

R3#conf t
R3(config)#interface serial1/0
R3(config-if)#no frame-relay inverse-arp
R3(config-if)#no shutdown
R3(config-if)#frame-relay map ip 192.168.123.1 301 broadcast
R3(config-if)#frame-relay map ip 192.168.123.2 302 broadcast
R3(config-if)#frame-relay map ip 192.168.123.4 304 broadcast
R3(config-if)#

R4#conf t
R4(config)#int s1/0
R4(config-if)#no frame-relay inverse-arp
R4(config-if)#no shutdown
R4(config-if)#frame-relay map ip 192.168.123.1 401 broadcast
R4(config-if)#frame-relay map ip 192.168.123.2 402 broadcast
R4(config-if)#frame-relay map ip 192.168.123.3 403 broadcast
R4(config-if)#

R4#show frame map
Serial1/0 (up): ip 192.168.123.1 dlci 401(0x191,0x6410), static, broadcast,
              CISCO, status defined, active
Serial1/0 (up): ip 192.168.123.2 dlci 402(0x192,0x6420), staticbroadcast,
              CISCO, status defined, active
Serial1/0 (up): ip 192.168.123.3 dlci 403(0x193,0x6430), staticbroadcast,
              CISCO, status defined, active

R4#ping 192.168.123.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/52/116 ms

R4#ping 192.168.123.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/56/108 ms

R4#ping 192.168.123.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/52/124 ms


Configuración Interfaces.

R1#show running-config interface serial1/0
!
interface Serial1/0
 ip address 192.168.123.1 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.123.3 103 broadcast
 frame-relay map ip 192.168.123.4 104 broadcast
 frame-relay map ip 192.168.123.2 102 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco

R2#show running-config interface serial1/0
!
interface Serial1/0
 ip address 192.168.123.2 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.123.4 204 broadcast
 frame-relay map ip 192.168.123.3 203 broadcast
 frame-relay map ip 192.168.123.1 201 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco

R3#show running-config interface serial1/0
!
interface Serial1/0
 ip address 192.168.123.3 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.123.4 304 broadcast
 frame-relay map ip 192.168.123.2 302 broadcast
 frame-relay map ip 192.168.123.1 301 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco

R4#show run int s1/0
!
interface Serial1/0
 ip address 192.168.123.4 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.123.4 401
 frame-relay map ip 192.168.123.3 403 broadcast
 frame-relay map ip 192.168.123.2 402 broadcast
 frame-relay map ip 192.168.123.1 401 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco

Frame Relay con Inverse ARP

Con esta practica en GNS3, verificaremos y entenderemos el funcionamiento de Frame Relay. Esta tecnologia WAN (Wide Area Network) es muy popular porque facilita la construcción de redes confiables y de bajo costo. Uno de sus principales ventajas es de poder configurar enlaces seriales punto a punto con la capacidad de conectar un sitio a muchos sitios remotos a través de un circuito físico. En esta practica se mostrara el proceso de la configuración de Frame Relay utilizando la siguiente topologia.

Topologia de Frame Relay a Configurar en GNS3.

La imagen anterior muestra una topologia Full Mesh. Una red Mesh es una red múltiplemente conexa, en la cual los nodos tienen más de una conexión con más de un nodo diferente. No necesariamente deben conectarse todos contra todos, éste es un caso especial que se denomina Full-Mesh. Configuraremos esta topologia en GNS3, en el cual utilizaremos un Router central el cual le configuraremos cuatro interfaces seriales donde le indiciaremos los DLCIs para que puedan ser asignados dinamicamente con Inverse ARP. Al configurar la encapsulacion Frame Relay en cada Router, automaticamente detectara los DLCIs ya que Inverse ARP esta habilitado por defecto.

Frame Relay en GNS3 con topologia Full Mesh.

Para configurar esta toplogia primero realizaremos la configuracion del Switch de Frame Relay, donde le indicaremos los DLCIs. Lo primero es activar la conmutación Frame Relay en el Router con el siguiente comando.

FrameRelay(config)#frame-relay switching

Luego a configurar las interfaces seriales, la encapsulacion, el reloj, le indicaremos que la interface como dispositivo DCE y por ultimo definimos los DLCIs para cada interface.

FrameRelay#configure terminal
FrameRelay(config)#interface Serial1/0
FrameRelay(config-if)#no ip address
FrameRelay(config-if)#encapsulation frame-relay
FrameRelay(config-if)#clock rate 64000
FrameRelay(config-if)#frame-relay intf-type dce
FrameRelay(config-if)#frame-relay route 102 interface Serial1/1 201
FrameRelay(config-if)#frame-relay route 103 interface Serial1/2 301
FrameRelay(config-if)#frame-relay route 104 interface Serial1/3 401
FrameRelay(config-if)#no shutdown
FrameRelay(config-if)#exit
FrameRelay(config)#interface Serial1/1
FrameRelay(config-if)#no ip address
FrameRelay(config-if)#encapsulation frame-relay
FrameRelay(config-if)#clock rate 64000
FrameRelay(config-if)#frame-relay intf-type dce
FrameRelay(config-if)#frame-relay route 201 interface Serial1/0 102
FrameRelay(config-if)#frame-relay route 203 interface Serial1/2 302
FrameRelay(config-if)#frame-relay route 204 interface Serial1/3 402
FrameRelay(config-if)#no shutdown
FrameRelay(config-if)#exit
FrameRelay(config)#interface Serial1/2
FrameRelay(config-if)#no ip address
FrameRelay(config-if)#encapsulation frame-relay
FrameRelay(config-if)#clock rate 64000
FrameRelay(config-if)#frame-relay intf-type dce
FrameRelay(config-if)#frame-relay route 301 interface Serial1/0 103
FrameRelay(config-if)#frame-relay route 302 interface Serial1/1 203
FrameRelay(config-if)#frame-relay route 304 interface Serial1/3 403
FrameRelay(config-if)#no shutdown
FrameRelay(config-if)#exit
FrameRelay(config)#interface Serial1/3
FrameRelay(config-if)#no ip address
FrameRelay(config-if)#encapsulation frame-relay
FrameRelay(config-if)#clock rate 64000
FrameRelay(config-if)#frame-relay intf-type dce
FrameRelay(config-if)#frame-relay route 401 interface Serial1/0 104
FrameRelay(config-if)#frame-relay route 402 interface Serial1/1 204
FrameRelay(config-if)#frame-relay route 403 interface Serial1/2 304
FrameRelay(config-if)#no shutdown
FrameRelay(config-if)#exit
FrameRelay(config)#end
FrameRelay#
Ahora configuramos las interfaces de los Routers.
R1>enable
R1#configure terminal
R1(config)# interface serial1 /0
R1(config-if)#encapsulation frame-relay
R1(config-if)#frame-relay lmi-type cisco
R1(config-if)#ip address 192.168.123.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#end
R1#
R2>enable
R2#configure terminal
R2(config)#interface serial1/0
R2(config-if)#encapsulation frame-relay
R2(config-if)#frame-relay lmi-type cisco
R2(config-if)#ip address 192.168.123.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#end
R2#
R3>enable
R3#configure terminal
R3(config)#interface serial1/0
R3(config-if)#encapsulation frame-relay
R3(config-if)#frame-relay lmi-type cisco
R3(config-if)#ip address 192.168.123.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#end
R3#
R4>enable
R4#configure terminal
R4(config)#interface serial1/0
R4(config-if)#encapsulation frame-relay
R4(config-if)#frame-relay lmi-type cisco
R4(config-if)#ip address 192.168.123.4 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#end
R4#
Terminando de realizar lo anterior ya podemos verificar en cualquier router con el comando show frame-relay pvc que Inverse ARP ha realizado su trabajo.
R1#show frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          3            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 1             output pkts 1            in bytes 34      
  out bytes 34             dropped pkts 0           in pkts dropped 0        
  out pkts dropped 0                out bytes dropped 0        
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        
  out BECN pkts 0          in DE pkts 0             out DE pkts 0        
  out bcast pkts 1         out bcast bytes 34      
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:07:06, last time pvc status changed 00:06:46
         
DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 1             output pkts 2            in bytes 34      
  out bytes 68             dropped pkts 0           in pkts dropped 0        
  out pkts dropped 0                out bytes dropped 0        
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        
  out BECN pkts 0          in DE pkts 0             out DE pkts 0        
  out bcast pkts 2         out bcast bytes 68      
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:07:10, last time pvc status changed 00:06:50
         
DLCI = 104, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 1             output pkts 1            in bytes 34      
  out bytes 34             dropped pkts 0           in pkts dropped 0        
  out pkts dropped 0                out bytes dropped 0        
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        
  out BECN pkts 0          in DE pkts 0             out DE pkts 0        
  out bcast pkts 1         out bcast bytes 34      
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:07:11, last time pvc status changed 00:06:41
Muestra estadísticas acerca de los PVC para las interfaces.

Como podemos ver, Inverse ARP ha detectado los DLCIs. Como se muestra en la salida anterior ha detectado 3 DLCIs en funcionamiento. Estas DLCIs son las que tenemos en nuestra topologia. Para verificar el funcionamiento de Frame Relay podemos también utilizar los siguientes comandos.
Las Estadisticas de los LMI.
R1#show frame-relay lmi
LMI Statistics for interface Serial1/0 (Frame Relay DTE) LMI TYPE = CISCO
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 140              Num Status msgs Rcvd 115
  Num Update Status Rcvd 0              Num Status Timeouts 25
  Last Full Status Req 00:00:00         Last Full Status Rcvd 00:00:00

El mapeo de los DLCIs.
R1#show frame-relay map
Serial1/0 (up): ip 192.168.123.2 dlci 102(0x66,0x1860), dynamic,
              broadcast,, status defined, active
Serial1/0 (up): ip 192.168.123.3 dlci 103(0x67,0x1870), dynamic,
              broadcast,, status defined, active
Serial1/0 (up): ip 192.168.123.4 dlci 104(0x68,0x1880), dynamic,
              broadcast,, status defined, active0
Muestra las entradas de mapeo actuales.

En la salida anterior nos muestra los DLCIs y que han sido aprendidos de manera dinámica. Con el siguiente comando podemos verificar que estamos utilizando la encapsulación de frame-relay en la interface, los datos de LMI, los Keepalive y mas informacion sobre la interface.
R1#show interface serial1/0
Serial1/0 is up, line protocol is up
  Hardware is M4T
  Internet address is 192.168.123.1/24
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  CRC checking enabled
  LMI enq sent  105, LMI stat recvd 80, LMI upd recvd 0, DTE LMI up
  LMI enq recvd 0, LMI stat sent  0, LMI upd sent  0
  LMI DLCI 1023  LMI type is CISCO  frame relay DTE
  FR SVC disabled, LAPF state down
  Broadcast queue 0/64, broadcasts sent/dropped 5/0, interface broadcasts 0
  Last input 00:00:06, output 00:00:06, output hang never
  Last clearing of "show interface" counters 00:18:53
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     85 packets input, 1618 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     114 packets output, 1671 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
Encapsulacion Frame Relay en la Interface Serial.

Verificamos la conectividad dando un ping a cada router.
R1#ping 192.168.123.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/142/332 ms
R1#ping 192.168.123.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/120/192 ms
R1#ping 192.168.123.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/127/240 ms


PortFast = Inmediatamente a Forwarding

Spanning Tree esta habilitado por default en los Switches Cisco. A los host no les importa saber sobre como esta la topologia de red. Asi que cuando un host esta conectado a la red no es realmente necesario que tenga que esperar a que transiten los estados del spanning tree. Los estados de los puertos en el protocolo Spanning tree son lo siguientes.
  • Blocking
  • Listening
  • Learning
  • Forwarding
  • Disable
Por default al conectar un host en un Switch pasa por estos estados.

Estado Listening.
Name                 Port ID Prio Cost  Sts Cost  Bridge ID            Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet1/1      128.42   128    19 LIS     0 32768 c200.0598.0000 128.42
FastEthernet1/2      128.43   128    19 FWD     0 32768 c200.0598.0000 128.43
Estado Learning:
Name                 Port ID Prio Cost  Sts Cost  Bridge ID            Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet1/1      128.42   128    19 LRN     0 32768 c200.0598.0000 128.42
FastEthernet1/2      128.43   128    19 FWD     0 32768 c200.0598.0000 128.43
Finalmente el Estado de Forwarding.
Name                 Port ID Prio Cost  Sts Cost  Bridge ID            Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet1/1      128.42   128    19 FWD     0 32768 c200.0598.0000 128.42
FastEthernet1/2      128.43   128    19 FWD     0 32768 c200.0598.0000 128.43
Para llegar al estado de Forwarding se requiere mas o menos como 50 segundos mientras el STP converge la red.

Listening - Leargnin - Forwarding del STP

El comando spanning-tree portfast indica que el puerto no tiene que esperar a que pasen todos estos estadados para empezar a trasmitir los datos en la LAN. PortFast no debe ser configurado en los Switches y bridges ya que puede generar loops de capa 2, incluso cuando se activa portFast en la interface nos envia la siguiente advertencia.

Switch(config-if)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single host.
 Connecting hubs, concentrators, switches,  bridges, etc.to this interface
 when portfast is enabled, can cause temporary spanning tree loops.
 Use with CAUTION

%Portfast has been configured on FastEthernet1/1 but will only
 have effect when the interface is in a non-trunking mode.

Advertencia de Portfast

Portfast sólo debe ser configurado en los puertos donde se conectan las PCs, Servidores con una sola targeta de red, teléfonos IP o routers. No se debe de configurar un puerto que este conectado un Switch, un bridge o un Hub.

Portfast está desactivado por defecto en los puertos del switch. Para habilitarlo debemos estar en la configuracion de puerto y realizarlo de la siguiente manera.

Switch(config-if)# spanning-tree portfast

Al habilitar portfast, automaticamente el puerto se pone en un estado de forwarding.
Name                 Port ID Prio Cost  Sts Cost  Bridge ID            Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet1/1      128.42   128    19 FWD     0 32768 c200.0598.0000 128.42
FastEthernet1/2      128.43   128    19 FWD     0 32768 c200.0598.0000 128.43

Tambien podemos habilitarlo desde la configuracion global para todos los puertos.

Switch(config)# spanning-tree portfast default

Para desabilitar Portfast en el puerto se realiza de la siguiente manera.

Switch(config-if)# no spanning-tree portfast

Spanning Tree Protocol (STP) en GNS3

Spanning Tree Protocol es un protocolo de capa 2 (enlace de datos) del modelo OSI. Este protocolo esta basado en un algoritmo diseñado por Radia Perlman. La función principal de STP es gestionar la presencia de loops en las topologias de red debido a la existencia de enlaces redundantes, estos enlaces redundantes son necesarios en varios casos para garantizar la disponibilidad de las conexiones. STP permite activar o desactivar automáticamente los enlaces de conexión de forma que se garantice que la topologia este libre de loops. Si existen varios enlaces y en el caso de que un enlace falle, otro enlaces puede seguir soportando el trafico de la red.
Tologia Spanning Tree Protocol
Spanning Tree Protocol (STP) en GNS3

El objetivo de esta practica es analizar la configuración y el funcionamiento básico del Spanning Tree Protocol (STP). En GNS3 vamos utilizar el modulo NM-16ESW, asi que lo primero que haremos es agregar el modulo NM-16ESW al router. Si necesitas ayudar del como agregar el  modulo revisa este enlace.
Spanning Tree Protocol en GNS3
Una vez configurado los cuatro Switches con el modulo NM-16ESW, iniciamos los routers y realizamos las configuraciones básicas.

Configuración básica del Switch1
SW1>enable
SW1#configure terminal
SW1(config)#hostname Switch1
Switch1(config)#enable secret cisco
Switch1(config)#no ip domain lookup
Switch1(config)#interface Vlan1
Switch1(config-if)#ip address 192.168.1.1 255.255.255.0
Switch1(config-if)#no shut
Switch1(config-if)#line con 0
Switch1(config-line)#exec-timeout 0 0
Switch1(config-line)#logging synchronous
Switch1(config-line)#password cisco2
Switch1(config-line)#login
Switch1(config-line)#exit
Switch1(config)#line vty 0 15
Switch1(config-line)#logging synchronous
Switch1(config-line)#password cisco3
Switch1(config-line)#login
Switch1(config-line)#end
Switch1#copy running-config startup-config
Destination filename [startup-config]? 
Building configuration...
[OK]
Switch1#
Configuracion Switch2
SW2>enable
SW2#configure terminal
SW2(config)#hostname Switch2
Switch2(config)#enable secret cisco
Switch2(config)#no ip domain lookup
Switch2(config)#interface Vlan1
Switch2(config-if)#ip address 192.168.1.2 255.255.255.0
Switch2(config-if)#no shut
Switch2(config-if)#line con 0
Switch2(config-line)#exec-timeout 0 0
Switch2(config-line)#logging synchronous
Switch2(config-line)#password cisco2
Switch2(config-line)#login
Switch2(config-line)#exit
Switch2(config)#line vty 0 15
Switch2(config-line)#logging synchronous
Switch2(config-line)#password cisco3
Switch2(config-line)#login
Switch2(config-line)#end
Switch2#copy running-config startup-config
Destination filename [startup-config]? 
Building configuration...
[OK]
Switch2#
Configuración Switch3
SW3>enable
SW3#configure terminal
SW3(config)#hostname Switch3
Switch3(config)#enable secret cisco
Switch3(config)#no ip domain lookup
Switch3(config)#interface Vlan1
Switch3(config-if)#ip address 192.168.1.3 255.255.255.0
Switch3(config-if)#no shut
Switch3(config-if)#line con 0
Switch3(config-line)#exec-timeout 0 0
Switch3(config-line)#logging synchronous
Switch3(config-line)#password cisco2
Switch3(config-line)#login
Switch3(config-line)#exit
Switch3(config)#line vty 0 15
Switch3(config-line)#logging synchronous
Switch3(config-line)#password cisco3
Switch3(config-line)#login
Switch3(config-line)#end
Switch3#copy running-config startup-config
Destination filename [startup-config]? 
Building configuration...
[OK]
Switch3#
Configuración Switch4
SW4>enable
SW4#configure terminal
SW4(config)#hostname Switch4
Switch4(config)#enable secret cisco
Switch4(config)#no ip domain lookup
Switch4(config)#interface Vlan1
Switch4(config-if)#ip address 192.168.1.4 255.255.255.0
Switch4(config-if)#no shut
Switch4(config-if)#line con 0
Switch4(config-line)#exec-timeout 0 0
Switch4(config-line)#logging synchronous
Switch4(config-line)#password cisco2
Switch4(config-line)#login
Switch4(config-line)#exit
Switch4(config)#line vty 0 15
Switch4(config-line)#logging synchronous
Switch4(config-line)#password cisco3
Switch4(config-line)#login
Switch4(config-line)#end
Switch4#copy running-config startup-config
Destination filename [startup-config]? 
Building configuration...
[OK]
Switch4#
Configuramos las interfaces en modo trunk
Switch1(config)#interface range fastEthernet 1/1 - 3
Switch1(config-if-range)#switchport mode trunk
Switch1(config-if-range)#no shutdown 
Switch1(config-if-range)#end
Switch1#
Switch2(config)#interface range fastEthernet 1/1 - 3
Switch2(config-if-range)#switchport mode trunk
Switch2(config-if-range)#no shutdown 
Switch2(config-if-range)#end
Switch2#
Switch3(config)#interface range fastEthernet 1/1 - 3
Switch3(config-if-range)#switchport mode trunk
Switch3(config-if-range)#no shutdown 
Switch3(config-if-range)#end
Switch3#
Switch4(config)#interface range fastEthernet 1/1 - 3
Switch4(config-if-range)#switchport mode trunk
Switch4(config-if-range)#no shutdown 
Switch4(config-if-range)#end
Switch4#
Verficamos STP
Switch1#show spanning-tree brief

VLAN1
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     c204.1490.0000
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32768
             Address     c204.1490.0000
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface                                   Designated
Name                 Port ID Prio Cost  Sts Cost  Bridge ID            Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet1/1      128.42   128    19 FWD     0 32768 c204.1490.0000 128.42 
FastEthernet1/2      128.43   128    19 FWD     0 32768 c204.1490.0000 128.43 
FastEthernet1/3      128.44   128    19 FWD     0 32768 c204.1490.0000 128.44
Switch2#show spanning-tree brief

VLAN1
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     c204.1490.0000
             Cost        19
             Port        43 (FastEthernet1/2)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32768
             Address     c205.1490.0000
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface                                   Designated
Name                 Port ID Prio Cost  Sts Cost  Bridge ID            Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet1/1      128.42   128    19 FWD    19 32768 c205.1490.0000 128.42 
FastEthernet1/2      128.43   128    19 FWD     0 32768 c204.1490.0000 128.42 
FastEthernet1/3      128.44   128    19 FWD    19 32768 c205.1490.0000 128.44 
Switch3#show spanning-tree brief

VLAN1
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     c204.1490.0000
             Cost        19
             Port        42 (FastEthernet1/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32768
             Address     c206.1490.0000
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface                                   Designated
Name                 Port ID Prio Cost  Sts Cost  Bridge ID            Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet1/1      128.42   128    19 FWD     0 32768 c204.1490.0000 128.44 
FastEthernet1/2      128.43   128    19 BLK    19 32768 c205.1490.0000 128.44 
FastEthernet1/3      128.44   128    19 FWD    19 32768 c206.1490.0000 128.44 
Switch4#show spanning-tree brief

VLAN1
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     c204.1490.0000
             Cost        19
             Port        44 (FastEthernet1/3)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32768
             Address     c207.1490.0000
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface                                   Designated
Name                 Port ID Prio Cost  Sts Cost  Bridge ID            Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet1/1      128.42   128    19 BLK    19 32768 c206.1490.0000 128.44 
FastEthernet1/2      128.43   128    19 BLK    19 32768 c205.1490.0000 128.42 
FastEthernet1/3      128.44   128    19 FWD     0 32768 c204.1490.0000 128.43 
Otro comando para verificar el Switch Root.
Switch1#show spanning-tree root
VLAN1            
  Root ID    Priority    32768
             Address     c204.1490.0000
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
Para mostrar los puertos bloqueados
Switch4#show spanning-tree blockedports 

Name                 Blocked Interfaces List
-------------------- ------------------------------------
VLAN1                Fa1/1, Fa1/2

Number of blocked ports (segments) in the system : 2
Debuggin de STP en GNS3
Switch1#debug spanning-tree ?
  all           All Spanning Tree debugging messages
  backbonefast  BackboneFast events
  bpdu          Spanning tree bridge protocol data units
  bpdu-opt      Optimized BPDU handling
  config        Spanning tree config changes
  etherchannel  EtherChannel support
  events        Spanning tree topology events
  exceptions    Spanning tree exceptions
  general       Spanning tree general
  pvst+         PVST+ events
  root          Spanning tree root events
  snmp          Spanning Tree SNMP handling
  uplinkfast    UplinkFast events
Como se muestra en la salida anterior, hay varias opciones disponibles en GNS3. Nosotros activaremos uno en especifico, el debug de los eventos de la topologia de Spanning Tree.
Switch1#debug spanning-tree events 
Spanning Tree event debugging is on

Eleccion de Root Bridge

Un Root Switch es el Switch que tenga el Bridge ID (BID) mas pequeña. El bridge ID esta compuesto por:

La prioridad.
La mac address.

Si en todos los Switches son iguales en la prioridad, entonces busca la dirección MAC mas pequeña. En este ejemplo como en todos los switches la prioridad es la misma entonces lo que tomara para elegir el root bridge sera el switch que tenga la mac address mas pequeña. En nuestro caso el Root Brigde con la Mac Address mas pequeña es el Switch1. Ahora veamos un ejemplo de como cambiar la prioridad para que el Switch2 sea el Root.

Cambiar a que Switch2 sea el Root.

Para que el Switch2 sea elegido como Root lo que haremos es cambiar la prioridad y para esto se hace de la siguiente manera.

Switch2(config)#spanning-tree vlan 1 priority 4096
Al hacer esto, las notificaciones en consola del STP se han generado en cada Switch.
Switch1#
*Mar  1 00:53:30.151: STP: VLAN1 heard root  4096-c205.1490.0000 on Fa1/1
*Mar  1 00:53:30.151: current Root has 32768-c204.1490.0000
*Mar  1 00:53:30.151:     supersedes 32768-c204.1490.0000
*Mar  1 00:53:30.151: STP: VLAN1 new root is 4096, c205.1490.0000 on port Fa1/1, cost 19
Switch2#
*Mar  1 00:52:51.147: STP: VLAN1 we are the spanning tree root
*Mar  1 00:52:51.323: STP: VLAN1 Topology Change rcvd on Fa1/1
*Mar  1 00:52:51.331: STP: VLAN1 Topology Change rcvd on Fa1/3
*Mar  1 00:53:21.331: STP: VLAN1 Topology Change rcvd on Fa1/3
Switch3#
*Mar  1 00:52:19.175: STP: VLAN1 heard root  4096-c205.1490.0000 on Fa1/2
*Mar  1 00:52:19.175: current Root has 32768-c204.1490.0000
*Mar  1 00:52:19.175:     supersedes 32768-c204.1490.0000
*Mar  1 00:52:19.179: STP: VLAN1 new root is 4096, c205.1490.0000 on port Fa1/2, cost 19
*Mar  1 00:52:19.251: STP: VLAN1 Fa1/2 -> listening
*Mar  1 00:52:19.259: STP: VLAN1 sent Topology Change Notice on Fa1/2
*Mar  1 00:52:19.331: STP: VLAN1 Fa1/1 -> blocking
*Mar  1 00:52:34.271: STP: VLAN1 Fa1/2 -> learning
*Mar  1 00:52:49.295: STP: VLAN1 sent Topology Change Notice on Fa1/2
*Mar  1 00:52:49.295: STP: VLAN1 Fa1/2 -> forwarding
Switch4#
*Mar  1 00:51:57.111: STP: VLAN1 heard root  4096-c205.1490.0000 on Fa1/2
*Mar  1 00:51:57.111: current Root has 32768-c204.1490.0000
*Mar  1 00:51:57.111:     supersedes 32768-c204.1490.0000
*Mar  1 00:51:57.111: STP: VLAN1 new root is 4096, c205.1490.0000 on port Fa1/2, cost 19
*Mar  1 00:51:57.143: STP: VLAN1 Fa1/1 -> listening
*Mar  1 00:51:57.207: STP: VLAN1 Fa1/2 -> listening
*Mar  1 00:51:57.211: STP: VLAN1 sent Topology Change Notice on Fa1/2
*Mar  1 00:51:57.259: STP: VLAN1 Fa1/3 -> blocking
*Mar  1 00:51:57.327: STP: VLAN1 Fa1/1 -> blocking
*Mar  1 00:52:12.227: STP: VLAN1 Fa1/2 -> learning
*Mar  1 00:52:27.247: STP: VLAN1 Fa1/2 -> forwarding
Como hemos cambiado la prioridad al Switch2 ahora es el Root.
Switch2#show spanning-tree brief   

VLAN1
  Spanning tree enabled protocol ieee
  Root ID    Priority    4096
             Address     c205.1490.0000
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    4096
             Address     c205.1490.0000
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface                                   Designated
Name                 Port ID Prio Cost  Sts Cost  Bridge ID            Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet1/1      128.42   128    19 FWD     0  4096 c205.1490.0000 128.42 
FastEthernet1/2      128.43   128    19 FWD     0  4096 c205.1490.0000 128.43 
FastEthernet1/3      128.44   128    19 FWD     0  4096 c205.1490.0000 128.44 
Otros modos de la eleccion de Root Switch es cambiando la prioridad mas baja. Por ejemplo, ahora queremos que el Switch3 sea el Root.

Switch3(config)#spanning-tree vlan 1 priority 0
Switch3(config)#spanning-tree vlan 1 priority 0
Switch3(config)#
*Mar  1 01:01:16.907: STP: VLAN1 we are the spanning tree root
*Mar  1 01:01:16.931: STP: VLAN1 Fa1/1 -> listening
*Mar  1 01:01:17.091: STP: VLAN1 Topology Change rcvd on Fa1/1
*Mar  1 01:01:18.039: STP: VLAN1 Topology Change rcvd on Fa1/3
Switch3(config)#end
Switch3#show spanning-tree brief

VLAN1
  Spanning tree enabled protocol ieee
  Root ID    Priority    0
             Address     c206.1490.0000
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    0
             Address     c206.1490.0000
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface                                   Designated
Name                 Port ID Prio Cost  Sts Cost  Bridge ID            Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet1/1      128.42   128    19 LIS     0     0 c206.1490.0000 128.42 
FastEthernet1/2      128.43   128    19 FWD     0     0 c206.1490.0000 128.43 
FastEthernet1/3      128.44   128    19 FWD     0     0 c206.1490.0000 128.44 
Otra manera es indicandole que por ejemplo el Switch4 sea el Root.

Switch4(config)# spanning-tree vlan 1 root primary

Switch4(config)#spanning-tree vlan 1 root primary 
 VLAN 1 bridge priority set to 8192
 VLAN 1 bridge max aging time unchanged at 20
 VLAN 1 bridge hello time unchanged at 2
 VLAN 1 bridge forward delay unchanged at 15
Switch4#show spanning-tree brief

VLAN1
  Spanning tree enabled protocol ieee
  Root ID    Priority    8192
             Address     c207.1490.0000
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    8192
             Address     c207.1490.0000
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface                                   Designated
Name                 Port ID Prio Cost  Sts Cost  Bridge ID            Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet1/1      128.42   128    19 FWD     0  8192 c207.1490.0000 128.42 
FastEthernet1/2      128.43   128    19 FWD     0  8192 c207.1490.0000 128.43 
FastEthernet1/3      128.44   128    19 FWD     0  8192 c207.1490.0000 128.44 

Routing entre VLANs (InterVLAN Routing)

Configurar el siguiente escenario. Donde tenemos dos Switches, en cada uno de los switches configuraremos dos VLANs, uno con nombre de vlan10 y el segundo con nombre de vlan20. Cada uno de los switches tendra conectado un host, el primero switch tendra un host que estara en la vlan10 y el segundo switch tendra otro host que estara en la vlan20.
Inter-VLAN Routing
Para que halla comunicación entre vlans en diferentes segmentos de red necesitaremos un dispositivo de capa 3, un router con como se ve en la imagen. A este router le configuraremos dos subinterfaces el cual nos ayudara a que halla comunicion entre vlans.

Inter-VLAN Routing en GNS3
Lo primero que haremos es crear dos vlan en cada switch (sin el VTP).
SW1(config)#vlan 10
SW1(config-vlan)#name VLAN10
SW1(config-vlan)#vlan 20
SW1(config-vlan)#name VLAN20
SW1(config-vlan)#end

SW2(config)#vlan 10
SW2(config-vlan)#name VLAN10
SW2(config-vlan)#vlan 20
SW2(config-vlan)#name VLAN20
SW2(config-vlan)#end
Verificamos
SW1#show vlan-sw
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0, Fa1/1, Fa1/2, Fa1/3
                                                Fa1/4, Fa1/5, Fa1/6, Fa1/7
                                                Fa1/8, Fa1/9, Fa1/10, Fa1/11
                                                Fa1/12, Fa1/13, Fa1/14, Fa1/15
10   VLAN10                           active   
20   VLAN20                           active   
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
Una vez creada las VLANs, ahora las asignaremos a los puertos.
SW1(config)#int f1/3
SW1(config-if)#switchport access vlan 10
SW1(config-if)#end
SW1#show vlan-sw brief
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0, Fa1/1, Fa1/2, Fa1/4
                                                Fa1/5, Fa1/6, Fa1/7, Fa1/8
                                                Fa1/9, Fa1/10, Fa1/11, Fa1/12
                                                Fa1/13, Fa1/14, Fa1/15
10   VLAN10                           active    Fa1/3
20   VLAN20                           active   
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
SW2(config)#int f1/2
SW2(config-if)#switchport access vlan 20
SW2(config-if)#end
SW2#show vlan-sw brief
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0, Fa1/1, Fa1/3, Fa1/4
                                                Fa1/5, Fa1/6, Fa1/7, Fa1/8
                                                Fa1/9, Fa1/10, Fa1/11, Fa1/12
                                                Fa1/13, Fa1/14, Fa1/15
10   VLAN10                           active   
20   VLAN20                           active    Fa1/2
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
Configuramos los Puertos en modo Trunk.
SW1(config)#int f1/2
SW1(config-if)#switchport mode trunk
SW1(config)#int f1/1
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#switchport mode trunk
SW1(config-if)#end
SW1#show int trunk

Port      Mode         Encapsulation  Status        Native vlan
Fa1/1     on           802.1q         trunking      1
Fa1/2     on           802.1q         trunking      1

Port      Vlans allowed on trunk
Fa1/1     1-4094
Fa1/2     1-4094

Port      Vlans allowed and active in management domain
Fa1/1     1,10,20
Fa1/2     1,10,20

Port      Vlans in spanning tree forwarding state and not pruned
Fa1/1     none
Fa1/2     1,10,20
SW2(config)#int f1/1
SW2(config-if)#switchport mode trunk
SW2#show int trunk

Port      Mode         Encapsulation  Status        Native vlan
Fa1/1     on           802.1q         trunking      1

Port      Vlans allowed on trunk
Fa1/1     1-4094

Port      Vlans allowed and active in management domain
Fa1/1     1,10,20

Port      Vlans in spanning tree forwarding state and not pruned
Fa1/1     none
Configuramos el Router
R1(config)#int f0/0
R1(config-if)#no ip address
R1(config-if)#no shutdown
R1(config-if)#int f0/0.10
R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip address 172.17.10.1 255.255.255.0
R1(config-subif)#exit
R1(config)#int f0/0.20
R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip add 172.17.20.1 255.255.255.0
R1(config-subif)#end
R1#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES manual up                    up     
FastEthernet0/0.10         172.17.10.1     YES manual up                    up     
FastEthernet0/0.20         172.17.20.1     YES manual up                    up     
FastEthernet0/1            unassigned      YES unset  administratively down down   
R1#
Configuramos una IP y el Default Gateway a cada uno de los hosts (qemu host):
PC1:
ifconfig eth0 172.17.10.10 netmask 255.255.255.0 up
route add default gw 172.17.10.1
PC2:
ifconfig eth0 172.17.20.10 netmask 255.255.255.0 up
route add default gw 172.17.20.1
Verificamos con un ping desde cada PC.



Este video muestra como configurar un Servidor DHCP en un Router Cisco. El laboratorio se realizo con el simulador GNS3, con una topologia basica utilizando un router como cliente y otro con el modulo NM-16ESW, una interface loopback y qemu host.

Vídeo Configuración del Servidor DHCP en un Router Cisco.
Video Online:
http://www.youtube.com/watch?v=wNa95REmJxc

Proceso de Conexión al Servidor DHCP

El protocolo DHCP es connectionless, lo que significa que utiliza el protocolo UDP (User Datagram Protocol) en la capa de transporte, tambien conocido como la capa de host-to-host. La siguiente figura muestra el proceso de Cliente/Servidor utilizando una conexión DHCP.

Mensajes DHCP para obtener una Dirección IP.
Un Host en la red para obtener una direccion IP mediante un servidor DHCP, lo que realiza es enviar un mensaje broadcast en capa 2 y capa 3. Un mensaje de tipo DHCP Discover para detectar servidores de DHCP en la red. La direccion broadcast de capa 2 son puros Fs en hexadecimal algo como esto  FF:FF:FF:FF:FF:FF. La direccion broadcast de capa 3 es la direccion 255.255.255.255, lo que significa que todas las redes y todos hosts.
Ethernet II, Src: c2:00:07:68:00:00 (c2:00:07:68:00:00), Dst: Broadcast (ff:ff:ff:ff:ff:ff)
Internet Protocol Version 4, Src: 0.0.0.0 (0.0.0.0), Dst: 255.255.255.255 (255.255.255.255)
El cliente DHCP envia un mensaje DHCP Discover en busca de un servidor DHCP.
El servidor DHCP recibe el mensaje DHCP Discover, revisa si hay una ip disponible en su configuracion para ofrecerla, crea una tabla ARP que incluye la direccion MAC del host solicitante y la direccion IP a ofrecer, envía un mensaje de respuesta DHCP Offer. El mensaje DHCP Offer se envia como unicast mediante la dirección MAC del Servidor DHCP (R2) como direccion de origen y la direccion del cliente (R1) como destino.

El servidor envia la siguiente informacion al cliente (R2) que esta solicitando una direccion IP.
  • Direccion IP
  • Mascare de Subred
  • El tiempo para utilizar la direccion IP
  • La direccion IP del Servidor
  • El servidor DNS
  • Windows Internet Naming Service (WINS)
Esta informacion es lo mas comun que puede ofrecer un servidor DHCP.
Información del Servidor DHCP.
En resumen:
Paso 1. El cliente DHCP envia un mensaje DHCP Discover en busca de un servidor DHCP.
Paso 2. El servidor DHCP que recibio el mensaje DHCP Discover reponde con un mensaje Unicast DHCP Offer.
paso 3. El cliente entonces trasmite al servidor un mensaje DHCP Request para solicitar una direccion IP y posiblemente otra informacion.
Paso 4. El servidor DHCP finalazara el intercambio de informacion con un mensaje unicast DHCP Acknowledgment como confirmacion .

Modos de Switch Frame Transmission


Cuando un switch recibe un frame, el switch decide que hace con el frame. Para tener un mejor rendimiento en la red es importante mantener una latencia baja como sea posible. La latencia es el tiempo en entre el envió y la recepción de un frame. Los Switches de una LAN pueden realizar una de las tres modos de operación para trasmitir un frame. Los tres modos son los siguiente.
  • Cut-through
  • Store and Forward
  • Fragment-Free
En los Switches Cisco Catalyst 1900, el valor por defecto es fragment free, mientras que la seria de Cisco Catalyst 2950 utiliza el modo Store & Forward como configuración predeterminada.

Cut-Through
El switch comenzará a enviar datos después de que éste reciba la DD (dirección de destino) del Frame. La diferencia entre éste y store-and-forward es que store-and-forward recibe el Frame completo antes de enviarlo. Así, Frames con Errores no pueden ser detectados leyendo sólo la DD, por lo que el método de switching cut-through puede impactar en el rendimiento de una red, al enviar Frames corruptos o truncados. Estos "Bad" Frames pueden originar Tormentas de Broadcasts (Broadcasts Storms) en que muchos de los dispositivos de la red responderán a los Frames corruptos simultáneamente.

Store and Forward
El Switch esperará hasta que todo el Frame haya arribado, antes de enviarlo. Este proceso asegura que la red de destino no se verá afectada por Frames corruptos o truncados, pero con la desventaja que tiene mayor latencia que cut-through.

Fragment Free (Modificacion de Cut-Through)
El punto medio entre cut-through y store-and-forward, es el método fragment free cut-through el cuál sólo envía paquetes cuyo largo mínimo es de 64 bytes, y filtra aquellos paquetes cuya longitud es menor que 64 bytes, tales como paquetes corruptos o runt. La diferencia entre éste método y store-and-forward es que de todas formas puede enviar paquetes corruptos aún cuando ellos sean mayores que 64 bytes.

Como utilizar un Switch en GNS3

En GNS3 no podemos simular la serie de Switches Cisco 2900 y 3500. Solo podemos practicar un 40% de la parte de Switching utilizando un IOS de un router 3700, específicamente el ios c3725-adventerprisek9-mz124-15.bin y agregando el modulo NM-16ESW. Así podemos practicar una parte de los temas de Switching, como VTP, VLANs, InterVLAN Routing, modos de puertos trunk, access y la encapsulación de datos (ISL & IEEE 802.1Q).
  • En nuestro primer paso, abriremos GNS3, después nos vamos al menú Editar - Administrador de Símbolos.

  • Añadimos ethernet_switching, agreamos un nombre y en la parte de Tipo seleccionamos el router 3700, al final damos clic en aceptar.
  • Ahora podemos ver el SW en la parte de abajo.

  • Ahora arrastramos el Switch en el campo de trabajo de GNS3, hacemos clic derecho y añadimos el modulo NM-16ESW desde el menu Slots.
Laboratorio de Switching en GNS3

Bueno ahora que tenemos el modulo instalado, toca realizar las conexiones con los equipos o simplemente iniciar el Switch para realizar las diferentes configuración.

  • Cambiamos el nombre del equipo, creamos dos VLANs y verificamos.
R2>
R2>en
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#hostname Switch
Switch(config)#
Switch(config)#do show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet0/1            unassigned      YES unset  administratively down down
FastEthernet1/0            unassigned      YES unset  up                    up
FastEthernet1/1            unassigned      YES unset  up                    down
FastEthernet1/2            unassigned      YES unset  up                    down
FastEthernet1/3            unassigned      YES unset  up                    down
FastEthernet1/4            unassigned      YES unset  up                    down
FastEthernet1/5            unassigned      YES unset  up                    down
FastEthernet1/6            unassigned      YES unset  up                    down
FastEthernet1/7            unassigned      YES unset  up                    down
FastEthernet1/8            unassigned      YES unset  up                    down
FastEthernet1/9            unassigned      YES unset  up                    down
FastEthernet1/10           unassigned      YES unset  up                    down
FastEthernet1/11           unassigned      YES unset  up                    down
FastEthernet1/12           unassigned      YES unset  up                    down
FastEthernet1/13           unassigned      YES unset  up                    down
FastEthernet1/14           unassigned      YES unset  up                    down
FastEthernet1/15           unassigned      YES unset  up                    down
Vlan1                      unassigned      YES unset  up                    up
Switch(config)#int vlan1
Switch(config-if)#ip add 192.168.1.1 255.255.255.0
Switch(config-if)#no shut
Switch(config-if)#exit
Switch(config)#
Switch(config)#vlan 10
Switch(config-vlan)#name delfirosales
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#name RH
Switch(config-vlan)#exit
Switch(config)#end
Switch#show
*Mar  1 00:08:02.799: %SYS-5-CONFIG_I: Configured from console by console
Switch#show vlan-sw

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0, Fa1/1, Fa1/2, Fa1/3
                             Fa1/4, Fa1/5, Fa1/6, Fa1/7
                             Fa1/8, Fa1/9, Fa1/10, Fa1/11
                             Fa1/12, Fa1/13, Fa1/14, Fa1/15
10   delfirosales                     active
20   RH                               active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
10   enet  100010     1500  -      -      -        -    -        0      0
20   enet  100020     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0
1005 trnet 101005     1500  -      -      1        ibm  -        0      0
Switch#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet0/1            unassigned      YES unset  administratively down down
FastEthernet1/0            unassigned      YES unset  up                    up
FastEthernet1/1            unassigned      YES unset  up                    down
FastEthernet1/2            unassigned      YES unset  up                    down
FastEthernet1/3            unassigned      YES unset  up                    down
FastEthernet1/4            unassigned      YES unset  up                    down
FastEthernet1/5            unassigned      YES unset  up                    down
FastEthernet1/6            unassigned      YES unset  up                    down
FastEthernet1/7            unassigned      YES unset  up                    down
FastEthernet1/8            unassigned      YES unset  up                    down
FastEthernet1/9            unassigned      YES unset  up                    down
FastEthernet1/10           unassigned      YES unset  up                    down
FastEthernet1/11           unassigned      YES unset  up                    down
FastEthernet1/12           unassigned      YES unset  up                    down
FastEthernet1/13           unassigned      YES unset  up                    down
FastEthernet1/14           unassigned      YES unset  up                    down
FastEthernet1/15           unassigned      YES unset  up                    down
Vlan1                      192.168.1.1     YES manual up                    up
Switch#ping 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
Switch#ping 192.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 12/50/116 ms
Switch#