Seguridad y Redes

Tips & Video Tutoriales, Wifislax, VMware, GNS3, VirtualBox, CCNA, Cisco Routers & Switches, [ Programming ]

Configuración de OSPF en un Cisco 3725 (IOS) y Nexus 7000 (NX-OS)

A continuación, se muestra un ejemplo de configuración básica de OSPF entre un Switch Nexus y un Router 3725. Para habilitar OSPF en el Cisco Nexus se realiza desde la configuración de la interfaz.

Topologia en GNS3.

Habilitamos OSPF
N7K-2(config)# feature ospf
Habilitamos el proceso de OSPF
N7K-2(config)# router ospf 10
N7K-2(config-router)# router-id 10.10.10.1
Habilitamos OSPF en la interface en particular
N7K-2(config)# int ethernet 2/2
N7K-2(config-if)# ip address 10.10.10.1 255.255.255.0
N7K-2(config-if)# no shutdown
N7K-2(config-if)# ip router ospf 10 area 0
N7K-2(config-if)# end
N7K-2#
Configuración de OSPF en el Cisco 3725.
ESW1(config)#interface fastEthernet0/1
ESW1(config-if)#ip add 10.10.10.2 255.255.255.0
ESW1(config-if)#no shutdown

ESW1(config)#interface fastEthernet0/0
ESW1(config-if)#ip add 10.4.4.4 255.255.255.0
ESW1(config-if)#no shutdown
ESW1(config-if)#exit

ESW1(config)#interface loopback2
ESW1(config-if)#ip address 10.3.3.3 255.255.255.0
ESW1(config-if)#end

ESW1#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.4.4.4        YES manual up                    up      
FastEthernet0/1            10.10.10.2      YES manual up                    up      
FastEthernet1/0            unassigned      YES unset  up                    down    
FastEthernet1/14           unassigned      YES unset  up                    down    
FastEthernet1/15           unassigned      YES unset  up                    down    
Vlan1                      unassigned      YES unset  up                    down    
Loopback1                  10.2.2.2        YES manual up                    up      
Loopback2                  10.3.3.3        YES manual up                    up      

ESW1(config)#router ospf 10
ESW1(config-router)#network 10.10.10.0 0.0.0.255 area 0
*Mar  1 00:06:10.307: %OSPF-5-ADJCHG: Process 10, Nbr 10.10.10.1 on FastEthernet0/1 from LOADING to FULL, Loading Done
ESW1(config-router)#networ 10.4.4.0 0.0.0.255 area 0
ESW1(config-router)#

Verificación
ESW1#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.10.10.1        1   FULL/BDR        00:00:33    10.10.10.1      FastEthernet0/1
ESW1


ESW1#show cdp neighbors detail 
-------------------------
Device ID: N7K-2(Nexus-Switch)
Entry address(es): 
  IP address: 10.10.10.1
Platform: Nexus-Switch,  Capabilities: Router Switch IGMP 
Interface: FastEthernet0/1,  Port ID (outgoing port): Ethernet2/2
Holdtime : 165 sec

Version :
Cisco Nexus Operating System (NX-OS) Software, Version 5.1(2)

advertisement version: 2
Duplex: full

ESW1#
Verificación en el Cisco Nexus
N7K-2# show ip route
IP Route Table for VRF "default"
'*' denotes best ucast next-hop
'**' denotes best mcast next-hop
'[x/y]' denotes [preference/metric]

10.4.4.0/24, ubest/mbest: 1/0
    *via 10.10.10.2, Eth2/2, [110/50], 00:00:11, ospf-10, intra
10.10.10.0/24, ubest/mbest: 1/0, attached
    *via 10.10.10.1, Eth2/2, [0/0], 00:01:52, direct
10.10.10.1/32, ubest/mbest: 1/0, attached
    *via 10.10.10.1, Eth2/2, [0/0], 00:01:52, local
N7K-2#

N7K-2# show ip ospf neighbors
 OSPF Process ID 10 VRF default
 Total number of neighbors: 1
 Neighbor ID     Pri State            Up Time  Address         Interface
 10.3.3.3          1 FULL/DR          00:00:09 10.10.10.2      Eth2/2


N7K-2# ping 10.10.10.2
PING 10.10.10.2 (10.10.10.2): 56 data bytes
64 bytes from 10.10.10.2: icmp_seq=0 ttl=254 time=10 ms
64 bytes from 10.10.10.2: icmp_seq=1 ttl=254 time=10 ms
64 bytes from 10.10.10.2: icmp_seq=2 ttl=254 time=10 ms
64 bytes from 10.10.10.2: icmp_seq=3 ttl=254 time=10 ms
64 bytes from 10.10.10.2: icmp_seq=4 ttl=254 time=10 ms

--- 10.10.10.2 ping statistics ---
5 packets transmitted, 5 packets received, 0.00% packet loss
round-trip min/avg/max = 10/10/10 ms
N7K-2#

N7K-2# ping 10.4.4.4
PING 10.4.4.4 (10.4.4.4): 56 data bytes
64 bytes from 10.4.4.4: icmp_seq=0 ttl=254 time=10 ms
64 bytes from 10.4.4.4: icmp_seq=1 ttl=254 time=10 ms
64 bytes from 10.4.4.4: icmp_seq=2 ttl=254 time=0 ms
64 bytes from 10.4.4.4: icmp_seq=3 ttl=254 time=0 ms
64 bytes from 10.4.4.4: icmp_seq=4 ttl=254 time=10 ms

--- 10.4.4.4 ping statistics ---
5 packets transmitted, 5 packets received, 0.00% packet loss
round-trip min/avg/max = 0/6/10 ms
N7K-2#

NetFlow - Monitorea los equipos de tu red

NetFlow es un protocolo de red desarrollado por Cisco Systems para recolectar información sobre tráfico IP. Netflow se ha convertido en un estándar de la industria para monitorización de tráfico de red, y actualmente está soportado para varias plataformas además de Cisco IOS y NXOS, como por ejemplo en dispositivos de fabricantes como Juniper, Enterasys Switches, y en sistemas operativos como Linux, FreeBSD, NetBSD y OpenBSD.

Existen varias diferencias entre la versión de implementación del Netflow original, por lo que algunas versiones incorporan algunos datos más, pero en líneas generales el Netflow básico envía al menos la siguiente información.
  • Dirección IP de origen.
  • Dirección IP de destino.
  • Puerto UDP o TCP de origen.
  • Puerto UDP o TCP de destino.
  • Protocolo IP.
  • Interfaz (SNMP ifIndex).
  • Tipo de servicio IP.

R1#configure terminal
R1(config)#interface fastethernet0/0
R1(config-if)#ip address 10.10.10.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#end
R1#

Configuración de SNMP y NetFlow
R1(config)#ip access-list standard ACL
R1(config-std-nacl)#permit host 10.10.10.10
R1(config-std-nacl)#exit

R1(config)#hostname RouterLocal

RouterLocal(config)#snmp-server community secreto rw ACL
RouterLocal(config)#snmp-server location Mexico
RouterLocal(config)#snmp-server contact delfirosales

RouterLocal(config)#interface fastEthernet0/0
RouterLocal(config-if)#ip flow egress 
RouterLocal(config-if)#ip flow ingress 
RouterLocal(config-if)#exit

RouterLocal(config)#ip flow-export version 9
RouterLocal(config)#ip flow-export destination 10.10.10.10 99
RouterLocal(config)#ip flow-export source fastEthernet0/0

RouterLocal(config)#service timestamps 
RouterLocal(config)#logging 10.10.10.10
RouterLocal(config)#ip domain name delfirosales.com
Comandos shows
RouterLocal#show ip cache flow
RouterLocal#show ip flow export
RouterLocal#show ip flow interface
RouterLocal#debug ip flow export


Configuración del NetFlow Collector

Hay varios colectores disponibles, algunos licenciados y otros libres, dependiendo de lo que necesites, con cualquier collector te será muy fácil generar el reporte de los top 10 terminales que consumen ancho de banda. Para esta practica se utilizo Real-Time NetFlow Analyzer de SolarisWinds para concentrar la información, analizarla y generar resportes.




Configuración de EIGRP

Las mínimas opciones que podemos configurar para habilitar EIGRP son las siguientes.
  1. Proceso de EIGRP
  2. Sistema Autonomo
  3. Habilitar EIGRP en las interfaces
Topologia a configurar.

Configurar la parte del direccionamiento.

Configuración de R2
R2#configure terminal
R2(config)#interface fastEthernet1/0
R2(config-if)#ip address 192.168.2.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

R2(config)#interface serial2/1
R2(config-if)#ip address 192.168.0.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#end
R2#

Cofiguración de R3
R3#configure terminal 
R3(config)#interface serial1/3
R3(config-if)#ip address 192.168.0.1 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit

R3(config)#interface ethernet0/0
R3(config-if)#ip address 192.168.35.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#end
R3# 

Configuracón de R5
R5#configure terminal 
R5(config)#interface ethernet0/0
R5(config-if)#ip address 192.168.35.5 255.255.255.0
R5(config-if)#no shutdown
R5(config-if)#exit

R5(config)#interface ethernet0/1
R5(config-if)#ip address 192.168.5.5 255.255.255.0
R5(config-if)#no shutdown
R5(config-if)#end
R5#

Si ingresamos el comando show ip route en R2, podremos ver lo siguiente.


Si realizamos un ping a 192.168.35.3 no va responder ya que no tenemos una ruta hacia él. Podemos configurar rutas estáticas, pero en este caso vamos a configurar EIGRP.

R2#ping 192.168.35.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.35.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Pasos para configurar EIGRP

Entrar a configuración global.
R2#configure terminal

Ingresar el comando router eigrp sistema_autonomo. Podemos asignarle un número de AS que va del 1 al 65535.
R2(config)#router eigrp ?
  <1-65535>  Autonomous system number

R2(config)#router eigrp 10
R2(config-router)#no auto-summary

El siguiente paso es indicar en que interfaces va estar corriendo EIGRP. Esto se realiza con el comando network.

R2(config-router)#network 192.168.2.0 0.0.0.255
R2(config-router)#network 192.168.0.0 0.0.0.3

Con este estamos indicando que estamos corriendo EIGRP en ambas interfaces.

Configuración de EIGRP en las interfaces de R3.
R3#configure terminal
R3(config)#router eigrp 10
R3(config-router)#no auto-summary
R3(config-router)#network 192.168.0.0 0.0.0.3
R3(config-router)#network 192.168.35.0 0.0.0.255

*Mar  1 00:01:59.599: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 192.168.0.2 (Serial1/3) is up: new adjacency

Podemos observar que se ha creado una adyacencia.

Como ya tenemos corriendo EIGRP en R3 con R2 podemos ingresar el siguiente comando, el cual nos va listar los vecinos o neighbors que tenemos.

R3#show ip eigrp neighbors


R3#show ip route eigrp


Configuración de EIGRP en R5.

Si primero hacemos un show ip route en R5, veremos las redes que están solamente conectadas.

R5#configure terminal 
R5(config)#router eigrp 10
R3(config-router)#no auto-summary
R5(config-router)#network 192.168.35.0 0.0.0.255 
R5(config-router)#network 192.168.5.5 0.0.0.0 

Frame Relay sin Inverse ARP

Frame Relay sin Inverse ARP. Esto significa que crearemos los mapas manualmente.

Topologia Frame Relay
Lo primero es configurar los mapas.

R1(config-if)#no frame-relay inverse-arp
R1(config-if)#no shutdown
R1(config-if)#frame-relay map ip 192.168.123.2 102 broadcast
R1(config-if)#frame-relay map ip 192.168.123.3 103 broadcast
R1(config-if)#frame-relay map ip 192.168.123.4 104 broadcast

R2#conf t
R2(config)#int s1/0
R2(config-if)#no frame-relay inverse-arp
R2(config-if)#no shutdown
R2(config-if)#frame-relay map ip 192.168.123.1 201 broadcast
R2(config-if)#frame-relay map ip 192.168.123.3 203 broadcast
R2(config-if)#frame-relay map ip 192.168.123.4 204 broadcast
R2(config-if)#

R3#conf t
R3(config)#interface serial1/0
R3(config-if)#no frame-relay inverse-arp
R3(config-if)#no shutdown
R3(config-if)#frame-relay map ip 192.168.123.1 301 broadcast
R3(config-if)#frame-relay map ip 192.168.123.2 302 broadcast
R3(config-if)#frame-relay map ip 192.168.123.4 304 broadcast
R3(config-if)#

R4#conf t
R4(config)#int s1/0
R4(config-if)#no frame-relay inverse-arp
R4(config-if)#no shutdown
R4(config-if)#frame-relay map ip 192.168.123.1 401 broadcast
R4(config-if)#frame-relay map ip 192.168.123.2 402 broadcast
R4(config-if)#frame-relay map ip 192.168.123.3 403 broadcast
R4(config-if)#

R4#show frame map
Serial1/0 (up): ip 192.168.123.1 dlci 401(0x191,0x6410), static, broadcast,
              CISCO, status defined, active
Serial1/0 (up): ip 192.168.123.2 dlci 402(0x192,0x6420), staticbroadcast,
              CISCO, status defined, active
Serial1/0 (up): ip 192.168.123.3 dlci 403(0x193,0x6430), staticbroadcast,
              CISCO, status defined, active

R4#ping 192.168.123.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/52/116 ms

R4#ping 192.168.123.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/56/108 ms

R4#ping 192.168.123.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/52/124 ms


Configuración Interfaces.

R1#show running-config interface serial1/0
!
interface Serial1/0
 ip address 192.168.123.1 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.123.3 103 broadcast
 frame-relay map ip 192.168.123.4 104 broadcast
 frame-relay map ip 192.168.123.2 102 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco

R2#show running-config interface serial1/0
!
interface Serial1/0
 ip address 192.168.123.2 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.123.4 204 broadcast
 frame-relay map ip 192.168.123.3 203 broadcast
 frame-relay map ip 192.168.123.1 201 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco

R3#show running-config interface serial1/0
!
interface Serial1/0
 ip address 192.168.123.3 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.123.4 304 broadcast
 frame-relay map ip 192.168.123.2 302 broadcast
 frame-relay map ip 192.168.123.1 301 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco

R4#show run int s1/0
!
interface Serial1/0
 ip address 192.168.123.4 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.123.4 401
 frame-relay map ip 192.168.123.3 403 broadcast
 frame-relay map ip 192.168.123.2 402 broadcast
 frame-relay map ip 192.168.123.1 401 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco

Frame Relay con Inverse ARP

Con esta practica en GNS3, verificaremos y entenderemos el funcionamiento de Frame Relay. Esta tecnologia WAN (Wide Area Network) es muy popular porque facilita la construcción de redes confiables y de bajo costo. Uno de sus principales ventajas es de poder configurar enlaces seriales punto a punto con la capacidad de conectar un sitio a muchos sitios remotos a través de un circuito físico. En esta practica se mostrara el proceso de la configuración de Frame Relay utilizando la siguiente topologia.

Topologia de Frame Relay a Configurar en GNS3.

La imagen anterior muestra una topologia Full Mesh. Una red Mesh es una red múltiplemente conexa, en la cual los nodos tienen más de una conexión con más de un nodo diferente. No necesariamente deben conectarse todos contra todos, éste es un caso especial que se denomina Full-Mesh. Configuraremos esta topologia en GNS3, en el cual utilizaremos un Router central el cual le configuraremos cuatro interfaces seriales donde le indiciaremos los DLCIs para que puedan ser asignados dinamicamente con Inverse ARP. Al configurar la encapsulacion Frame Relay en cada Router, automaticamente detectara los DLCIs ya que Inverse ARP esta habilitado por defecto.

Frame Relay en GNS3 con topologia Full Mesh.

Para configurar esta toplogia primero realizaremos la configuracion del Switch de Frame Relay, donde le indicaremos los DLCIs. Lo primero es activar la conmutación Frame Relay en el Router con el siguiente comando.

FrameRelay(config)#frame-relay switching

Luego a configurar las interfaces seriales, la encapsulacion, el reloj, le indicaremos que la interface como dispositivo DCE y por ultimo definimos los DLCIs para cada interface.

FrameRelay#configure terminal
FrameRelay(config)#interface Serial1/0
FrameRelay(config-if)#no ip address
FrameRelay(config-if)#encapsulation frame-relay
FrameRelay(config-if)#clock rate 64000
FrameRelay(config-if)#frame-relay intf-type dce
FrameRelay(config-if)#frame-relay route 102 interface Serial1/1 201
FrameRelay(config-if)#frame-relay route 103 interface Serial1/2 301
FrameRelay(config-if)#frame-relay route 104 interface Serial1/3 401
FrameRelay(config-if)#no shutdown
FrameRelay(config-if)#exit
FrameRelay(config)#interface Serial1/1
FrameRelay(config-if)#no ip address
FrameRelay(config-if)#encapsulation frame-relay
FrameRelay(config-if)#clock rate 64000
FrameRelay(config-if)#frame-relay intf-type dce
FrameRelay(config-if)#frame-relay route 201 interface Serial1/0 102
FrameRelay(config-if)#frame-relay route 203 interface Serial1/2 302
FrameRelay(config-if)#frame-relay route 204 interface Serial1/3 402
FrameRelay(config-if)#no shutdown
FrameRelay(config-if)#exit
FrameRelay(config)#interface Serial1/2
FrameRelay(config-if)#no ip address
FrameRelay(config-if)#encapsulation frame-relay
FrameRelay(config-if)#clock rate 64000
FrameRelay(config-if)#frame-relay intf-type dce
FrameRelay(config-if)#frame-relay route 301 interface Serial1/0 103
FrameRelay(config-if)#frame-relay route 302 interface Serial1/1 203
FrameRelay(config-if)#frame-relay route 304 interface Serial1/3 403
FrameRelay(config-if)#no shutdown
FrameRelay(config-if)#exit
FrameRelay(config)#interface Serial1/3
FrameRelay(config-if)#no ip address
FrameRelay(config-if)#encapsulation frame-relay
FrameRelay(config-if)#clock rate 64000
FrameRelay(config-if)#frame-relay intf-type dce
FrameRelay(config-if)#frame-relay route 401 interface Serial1/0 104
FrameRelay(config-if)#frame-relay route 402 interface Serial1/1 204
FrameRelay(config-if)#frame-relay route 403 interface Serial1/2 304
FrameRelay(config-if)#no shutdown
FrameRelay(config-if)#exit
FrameRelay(config)#end
FrameRelay#
Ahora configuramos las interfaces de los Routers.
R1>enable
R1#configure terminal
R1(config)# interface serial1 /0
R1(config-if)#encapsulation frame-relay
R1(config-if)#frame-relay lmi-type cisco
R1(config-if)#ip address 192.168.123.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#end
R1#
R2>enable
R2#configure terminal
R2(config)#interface serial1/0
R2(config-if)#encapsulation frame-relay
R2(config-if)#frame-relay lmi-type cisco
R2(config-if)#ip address 192.168.123.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#end
R2#
R3>enable
R3#configure terminal
R3(config)#interface serial1/0
R3(config-if)#encapsulation frame-relay
R3(config-if)#frame-relay lmi-type cisco
R3(config-if)#ip address 192.168.123.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#end
R3#
R4>enable
R4#configure terminal
R4(config)#interface serial1/0
R4(config-if)#encapsulation frame-relay
R4(config-if)#frame-relay lmi-type cisco
R4(config-if)#ip address 192.168.123.4 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#end
R4#
Terminando de realizar lo anterior ya podemos verificar en cualquier router con el comando show frame-relay pvc que Inverse ARP ha realizado su trabajo.
R1#show frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          3            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 1             output pkts 1            in bytes 34      
  out bytes 34             dropped pkts 0           in pkts dropped 0        
  out pkts dropped 0                out bytes dropped 0        
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        
  out BECN pkts 0          in DE pkts 0             out DE pkts 0        
  out bcast pkts 1         out bcast bytes 34      
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:07:06, last time pvc status changed 00:06:46
         
DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 1             output pkts 2            in bytes 34      
  out bytes 68             dropped pkts 0           in pkts dropped 0        
  out pkts dropped 0                out bytes dropped 0        
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        
  out BECN pkts 0          in DE pkts 0             out DE pkts 0        
  out bcast pkts 2         out bcast bytes 68      
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:07:10, last time pvc status changed 00:06:50
         
DLCI = 104, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 1             output pkts 1            in bytes 34      
  out bytes 34             dropped pkts 0           in pkts dropped 0        
  out pkts dropped 0                out bytes dropped 0        
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        
  out BECN pkts 0          in DE pkts 0             out DE pkts 0        
  out bcast pkts 1         out bcast bytes 34      
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:07:11, last time pvc status changed 00:06:41
Muestra estadísticas acerca de los PVC para las interfaces.

Como podemos ver, Inverse ARP ha detectado los DLCIs. Como se muestra en la salida anterior ha detectado 3 DLCIs en funcionamiento. Estas DLCIs son las que tenemos en nuestra topologia. Para verificar el funcionamiento de Frame Relay podemos también utilizar los siguientes comandos.
Las Estadisticas de los LMI.
R1#show frame-relay lmi
LMI Statistics for interface Serial1/0 (Frame Relay DTE) LMI TYPE = CISCO
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 140              Num Status msgs Rcvd 115
  Num Update Status Rcvd 0              Num Status Timeouts 25
  Last Full Status Req 00:00:00         Last Full Status Rcvd 00:00:00

El mapeo de los DLCIs.
R1#show frame-relay map
Serial1/0 (up): ip 192.168.123.2 dlci 102(0x66,0x1860), dynamic,
              broadcast,, status defined, active
Serial1/0 (up): ip 192.168.123.3 dlci 103(0x67,0x1870), dynamic,
              broadcast,, status defined, active
Serial1/0 (up): ip 192.168.123.4 dlci 104(0x68,0x1880), dynamic,
              broadcast,, status defined, active0
Muestra las entradas de mapeo actuales.

En la salida anterior nos muestra los DLCIs y que han sido aprendidos de manera dinámica. Con el siguiente comando podemos verificar que estamos utilizando la encapsulación de frame-relay en la interface, los datos de LMI, los Keepalive y mas informacion sobre la interface.
R1#show interface serial1/0
Serial1/0 is up, line protocol is up
  Hardware is M4T
  Internet address is 192.168.123.1/24
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  CRC checking enabled
  LMI enq sent  105, LMI stat recvd 80, LMI upd recvd 0, DTE LMI up
  LMI enq recvd 0, LMI stat sent  0, LMI upd sent  0
  LMI DLCI 1023  LMI type is CISCO  frame relay DTE
  FR SVC disabled, LAPF state down
  Broadcast queue 0/64, broadcasts sent/dropped 5/0, interface broadcasts 0
  Last input 00:00:06, output 00:00:06, output hang never
  Last clearing of "show interface" counters 00:18:53
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     85 packets input, 1618 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     114 packets output, 1671 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
Encapsulacion Frame Relay en la Interface Serial.

Verificamos la conectividad dando un ping a cada router.
R1#ping 192.168.123.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/142/332 ms
R1#ping 192.168.123.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/120/192 ms
R1#ping 192.168.123.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/127/240 ms


Proceso de Conexión al Servidor DHCP

El protocolo DHCP es connectionless, lo que significa que utiliza el protocolo UDP (User Datagram Protocol) en la capa de transporte, tambien conocido como la capa de host-to-host. La siguiente figura muestra el proceso de Cliente/Servidor utilizando una conexión DHCP.

Mensajes DHCP para obtener una Dirección IP.
Un Host en la red para obtener una direccion IP mediante un servidor DHCP, lo que realiza es enviar un mensaje broadcast en capa 2 y capa 3. Un mensaje de tipo DHCP Discover para detectar servidores de DHCP en la red. La direccion broadcast de capa 2 son puros Fs en hexadecimal algo como esto  FF:FF:FF:FF:FF:FF. La direccion broadcast de capa 3 es la direccion 255.255.255.255, lo que significa que todas las redes y todos hosts.
Ethernet II, Src: c2:00:07:68:00:00 (c2:00:07:68:00:00), Dst: Broadcast (ff:ff:ff:ff:ff:ff)
Internet Protocol Version 4, Src: 0.0.0.0 (0.0.0.0), Dst: 255.255.255.255 (255.255.255.255)
El cliente DHCP envia un mensaje DHCP Discover en busca de un servidor DHCP.
El servidor DHCP recibe el mensaje DHCP Discover, revisa si hay una ip disponible en su configuracion para ofrecerla, crea una tabla ARP que incluye la direccion MAC del host solicitante y la direccion IP a ofrecer, envía un mensaje de respuesta DHCP Offer. El mensaje DHCP Offer se envia como unicast mediante la dirección MAC del Servidor DHCP (R2) como direccion de origen y la direccion del cliente (R1) como destino.

El servidor envia la siguiente informacion al cliente (R2) que esta solicitando una direccion IP.
  • Direccion IP
  • Mascare de Subred
  • El tiempo para utilizar la direccion IP
  • La direccion IP del Servidor
  • El servidor DNS
  • Windows Internet Naming Service (WINS)
Esta informacion es lo mas comun que puede ofrecer un servidor DHCP.
Información del Servidor DHCP.
En resumen:
Paso 1. El cliente DHCP envia un mensaje DHCP Discover en busca de un servidor DHCP.
Paso 2. El servidor DHCP que recibio el mensaje DHCP Discover reponde con un mensaje Unicast DHCP Offer.
paso 3. El cliente entonces trasmite al servidor un mensaje DHCP Request para solicitar una direccion IP y posiblemente otra informacion.
Paso 4. El servidor DHCP finalazara el intercambio de informacion con un mensaje unicast DHCP Acknowledgment como confirmacion .

Configuración de un Router Cisco como un Servidor DHCP

  • Configuramos una IP a la interface del Servidor
  • Definimos el nombre del Servidor
  • Establecemos el rango de direcciones IPs de la red
  • Definimos la puerta de enlace
  • Define el servidor de nombres DNS
  • Establecemos la dirección(es) dentro del rango que no se debe de asignar
Topologia en GNS3
Servidor DHCP
Server_DHCP#conf t
Server_DHCP(config)#int f0/0
Server_DHCP(config-if)#ip add 192.168.1.1 255.255.255.0
Server_DHCP(config-if)#no shut
Server_DHCP(config-if)#exit
Server_DHCP(config)#ip dhcp pool delfirosales
Server_DHCP(dhcp-config)#network 192.168.1.0 255.255.255.0
Server_DHCP(dhcp-config)#default-route 192.168.1.1
Server_DHCP(dhcp-config)#dns-server 192.168.1.1
Server_DHCP(dhcp-config)#exit
Server_DHCP(config)#ip dhcp excluded-address 192.168.1.1
Configuración en SW, R1, R2
RX#conf t
RX(config)#int f0/0
RX(config-if)#no shut
RX(config-if)#ip address dhcp
RX(config-if)#

*Mar  1 00:00:51.203: %DHCP-6-ADDRESS_ASSIGN: Interface FastEthernet0/0 assigned DHCP address 192.168.1.3, mask 255.255.255.0, hostname R2

Qemu Host (Microcore) utiliza la utilidad udhcpc como cliente dhcp.
Para verificar que se esta ejecutando udhcpc, utilizar el siguiente comando.

ps | grep udhcpc

1649  root  /sbin/udhcpc -b -i eth0 -h box -p /var/run/udhcpc.eth0.pid
1663  root  greep udhcpc

Qemu Host (Microcore) automáticamente detecta la IP.
Por ultimo verificamos.
Server_DHCP#show ip dhcp binding      
Bindings from all pools not associated with VRF:
IP address          Client-ID/              Lease expiration        Type
               Hardware address/
               User name
192.168.1.2         0063.6973.636f.2d63.    Mar 02 2002 12:05 AM    Automatic
               3230.362e.3232.3134.
               2e30.3030.302d.4661.
               302f.30
192.168.1.3         0063.6973.636f.2d63.    Mar 02 2002 12:09 AM    Automatic
               3230.372e.3232.3134.
               2e30.3030.302d.4661.
               302f.30
192.168.1.4         0063.6973.636f.2d63.    Mar 02 2002 12:09 AM    Automatic
               3230.332e.3232.3134.
               2e30.3030.302d.566c.
               31
192.168.1.5         0100.aa00.fa9f.00       Mar 02 2002 12:12 AM    Automatic
Server_DHCP#show ip dhcp pool         

Pool delfirosales :
Utilization mark (high/low)    : 100 / 0
Subnet size (first/next)       : 0 / 0
Total addresses                : 254
Leased addresses               : 4
Pending event                  : none
1 subnet is currently in the pool :
Current index        IP address range                    Leased addresses
192.168.1.6          192.168.1.1      - 192.168.1.254     4
Server_DHCP#

Server_DHCP#show run

!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool delfirosales
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 192.168.1.1
!

Modos de Switch Frame Transmission


Cuando un switch recibe un frame, el switch decide que hace con el frame. Para tener un mejor rendimiento en la red es importante mantener una latencia baja como sea posible. La latencia es el tiempo en entre el envió y la recepción de un frame. Los Switches de una LAN pueden realizar una de las tres modos de operación para trasmitir un frame. Los tres modos son los siguiente.
  • Cut-through
  • Store and Forward
  • Fragment-Free
En los Switches Cisco Catalyst 1900, el valor por defecto es fragment free, mientras que la seria de Cisco Catalyst 2950 utiliza el modo Store & Forward como configuración predeterminada.

Cut-Through
El switch comenzará a enviar datos después de que éste reciba la DD (dirección de destino) del Frame. La diferencia entre éste y store-and-forward es que store-and-forward recibe el Frame completo antes de enviarlo. Así, Frames con Errores no pueden ser detectados leyendo sólo la DD, por lo que el método de switching cut-through puede impactar en el rendimiento de una red, al enviar Frames corruptos o truncados. Estos "Bad" Frames pueden originar Tormentas de Broadcasts (Broadcasts Storms) en que muchos de los dispositivos de la red responderán a los Frames corruptos simultáneamente.

Store and Forward
El Switch esperará hasta que todo el Frame haya arribado, antes de enviarlo. Este proceso asegura que la red de destino no se verá afectada por Frames corruptos o truncados, pero con la desventaja que tiene mayor latencia que cut-through.

Fragment Free (Modificacion de Cut-Through)
El punto medio entre cut-through y store-and-forward, es el método fragment free cut-through el cuál sólo envía paquetes cuyo largo mínimo es de 64 bytes, y filtra aquellos paquetes cuya longitud es menor que 64 bytes, tales como paquetes corruptos o runt. La diferencia entre éste método y store-and-forward es que de todas formas puede enviar paquetes corruptos aún cuando ellos sean mayores que 64 bytes.

Como utilizar un Switch en GNS3

En GNS3 no podemos simular la serie de Switches Cisco 2900 y 3500. Solo podemos practicar un 40% de la parte de Switching utilizando un IOS de un router 3700, específicamente el ios c3725-adventerprisek9-mz124-15.bin y agregando el modulo NM-16ESW. Así podemos practicar una parte de los temas de Switching, como VTP, VLANs, InterVLAN Routing, modos de puertos trunk, access y la encapsulación de datos (ISL & IEEE 802.1Q).
  • En nuestro primer paso, abriremos GNS3, después nos vamos al menú Editar - Administrador de Símbolos.

  • Añadimos ethernet_switching, agreamos un nombre y en la parte de Tipo seleccionamos el router 3700, al final damos clic en aceptar.
  • Ahora podemos ver el SW en la parte de abajo.

  • Ahora arrastramos el Switch en el campo de trabajo de GNS3, hacemos clic derecho y añadimos el modulo NM-16ESW desde el menu Slots.
Laboratorio de Switching en GNS3

Bueno ahora que tenemos el modulo instalado, toca realizar las conexiones con los equipos o simplemente iniciar el Switch para realizar las diferentes configuración.

  • Cambiamos el nombre del equipo, creamos dos VLANs y verificamos.
R2>
R2>en
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#hostname Switch
Switch(config)#
Switch(config)#do show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet0/1            unassigned      YES unset  administratively down down
FastEthernet1/0            unassigned      YES unset  up                    up
FastEthernet1/1            unassigned      YES unset  up                    down
FastEthernet1/2            unassigned      YES unset  up                    down
FastEthernet1/3            unassigned      YES unset  up                    down
FastEthernet1/4            unassigned      YES unset  up                    down
FastEthernet1/5            unassigned      YES unset  up                    down
FastEthernet1/6            unassigned      YES unset  up                    down
FastEthernet1/7            unassigned      YES unset  up                    down
FastEthernet1/8            unassigned      YES unset  up                    down
FastEthernet1/9            unassigned      YES unset  up                    down
FastEthernet1/10           unassigned      YES unset  up                    down
FastEthernet1/11           unassigned      YES unset  up                    down
FastEthernet1/12           unassigned      YES unset  up                    down
FastEthernet1/13           unassigned      YES unset  up                    down
FastEthernet1/14           unassigned      YES unset  up                    down
FastEthernet1/15           unassigned      YES unset  up                    down
Vlan1                      unassigned      YES unset  up                    up
Switch(config)#int vlan1
Switch(config-if)#ip add 192.168.1.1 255.255.255.0
Switch(config-if)#no shut
Switch(config-if)#exit
Switch(config)#
Switch(config)#vlan 10
Switch(config-vlan)#name delfirosales
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#name RH
Switch(config-vlan)#exit
Switch(config)#end
Switch#show
*Mar  1 00:08:02.799: %SYS-5-CONFIG_I: Configured from console by console
Switch#show vlan-sw

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0, Fa1/1, Fa1/2, Fa1/3
                             Fa1/4, Fa1/5, Fa1/6, Fa1/7
                             Fa1/8, Fa1/9, Fa1/10, Fa1/11
                             Fa1/12, Fa1/13, Fa1/14, Fa1/15
10   delfirosales                     active
20   RH                               active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
10   enet  100010     1500  -      -      -        -    -        0      0
20   enet  100020     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0
1005 trnet 101005     1500  -      -      1        ibm  -        0      0
Switch#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet0/1            unassigned      YES unset  administratively down down
FastEthernet1/0            unassigned      YES unset  up                    up
FastEthernet1/1            unassigned      YES unset  up                    down
FastEthernet1/2            unassigned      YES unset  up                    down
FastEthernet1/3            unassigned      YES unset  up                    down
FastEthernet1/4            unassigned      YES unset  up                    down
FastEthernet1/5            unassigned      YES unset  up                    down
FastEthernet1/6            unassigned      YES unset  up                    down
FastEthernet1/7            unassigned      YES unset  up                    down
FastEthernet1/8            unassigned      YES unset  up                    down
FastEthernet1/9            unassigned      YES unset  up                    down
FastEthernet1/10           unassigned      YES unset  up                    down
FastEthernet1/11           unassigned      YES unset  up                    down
FastEthernet1/12           unassigned      YES unset  up                    down
FastEthernet1/13           unassigned      YES unset  up                    down
FastEthernet1/14           unassigned      YES unset  up                    down
FastEthernet1/15           unassigned      YES unset  up                    down
Vlan1                      192.168.1.1     YES manual up                    up
Switch#ping 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
Switch#ping 192.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 12/50/116 ms
Switch#

Topologia Full Mesh en Frame Relay

Lo primero es configurar el Switch Frame Relay

Desde configuración global agregamos el comando.

FrameRelaySwitch(config)#frame-relay switching

Después a configurar las interfaces con las DLCIs

Configuración Frame Relay Switch
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
frame-relay intf-type dce
frame-relay route 102 interface Serial1/1 201
frame-relay route 103 interface Serial1/2 301
frame-relay route 104 interface Serial1/3 401
!
interface Serial1/1
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
frame-relay intf-type dce
frame-relay route 201 interface Serial1/0 102
frame-relay route 203 interface Serial1/2 302
frame-relay route 204 interface Serial1/3 402
!
interface Serial1/2
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
frame-relay intf-type dce
frame-relay route 301 interface Serial1/0 103
frame-relay route 302 interface Serial1/1 203
frame-relay route 304 interface Serial1/3 403
!
interface Serial1/3
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
frame-relay intf-type dce
frame-relay route 401 interface Serial1/0 104
frame-relay route 402 interface Serial1/1 204
frame-relay route 403 interface Serial1/2 304
!
Configuración R1
!
interface Serial1/0
ip address 192.168.123.1 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay lmi-type cisco
!
Configuración R2
!
interface Serial1/0
ip address 192.168.123.2 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay lmi-type cisco
!
Configuración R3
!
interface Serial1/0
ip address 192.168.123.3 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay lmi-type cisco
!
Configuración R4
!
interface Serial1/0
ip address 192.168.123.4 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay lmi-type cisco
!

Configuración de PPP y CHAP

En este post veremos como configurar PPP (Point-to-Point Protocol) y CHAP (Challenge Handshake Authentication Protocol), en primer lugar debemos de comprender que tipo de conexión estamos haciendo. Un diagrama de red nos podría ayudar, tal como se muestra en la siguiente imagen donde se muestra una conexión básica de PPP y CHAP.

Configuración de PPP y CHAP en el Router2
Router#configure terminal
Router(config)#hostname Router1
Router1(config)#username Router2 password cisco
Router1(config)#interface serial1/0
Router1(config-if)#clockrate 64000
Router1(config-if)#ip address 192.168.1.130 255.255.255.252
Router1(config-if)#encapsulation ppp
Router1(config-if)#ppp authentication chap
Router1(config-if)#no shut
Router1(config-if)#end
Router1#ping 192.168.1.129

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.129, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/72/156 ms
Configuración de PPP y CHAP en el Router2
Router#configure terminal
Router(config)#hostname Router2
Router2(config)#username Router1 password cisco
Router2(config)#interface serial1/0
Router2(config-if)#ip address 192.168.1.129 255.255.255.252
Router2(config-if)#encapsulation ppp
Router2(config-if)#ppp authentication chap
Router2(config-if)#no shut
Router2(config-if)#end
Router2#ping 192.168.1.130

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.130, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/46/92 ms

Troubleshooting PPP y CHAP

Ahora que tenemos configurado PPP + CHAP, verificaremos la configuración de PPP en las interfaces configurada con el comando show interface, como se muestra a continuación.

Verificacion de la interface serial1/0 en el Router1
Router1#show interface serial1/0
Serial1/0 is up, line protocol is up
Hardware is M4T
Internet address is 192.168.1.130/30
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, LCP Open
Open: IPCP, CDPCP, crc 16, loopback not set
Keepalive set (10 sec)
Restart-Delay is 0 secs
Last input 00:00:25, output 00:00:00, output hang never
Last clearing of "show interface" counters 00:04:19
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations  0/1/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 1158 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
31 packets input, 1988 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
33 packets output, 1419 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 output buffer failures, 0 output buffers swapped out
1 carrier transitions     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
Verificación de la interface serial1/0 en el Router2
Router2#show interface serial1/0
Serial1/0 is up, line protocol is up
Hardware is M4T
Internet address is 192.168.1.129/30
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, LCP Open
Open: IPCP, CDPCP, crc 16, loopback not set
Keepalive set (10 sec)
Restart-Delay is 0 secs
Last input 00:00:07, output 00:00:00, output hang never
Last clearing of "show interface" counters 00:03:09
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations  0/1/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 1158 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
34 packets input, 1727 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
35 packets output, 2052 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 output buffer failures, 0 output buffers swapped out
1 carrier transitions     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Comandos debug de PPP

Estos comandos nos puedes ser utilices para mostrar el proceso de PPP en las interfaces. También sirven de gran ayuda para administrar la red y así resolver problemas de enlace. Los comandos mas útiles son los siguientes.

Debugging PPP Authentication

El comando debug ppp authentication nos mostrara el proceso de autenticación de CHAP. Si la encapsulacion PPP y la autención estan configurados correctamente en los routers, asi como los nombres de usuario con sus respectivas contraseñas, se mostrara en la salida algo similar a lo siguiente.
Router1#debug ppp authentication
PPP authentication debugging is on
Router1#
*Mar  1 00:16:42.699: Se1/0 PPP: Authorization required
*Mar  1 00:16:42.707: Se1/0 CHAP: O CHALLENGE id 3 len 28 from "Router1"
*Mar  1 00:16:42.707: Se1/0 CHAP: I CHALLENGE id 3 len 28 from "Router2"
*Mar  1 00:16:42.711: Se1/0 CHAP: I RESPONSE id 3 len 28 from "Router2"
*Mar  1 00:16:42.723: Se1/0 PPP: Sent CHAP LOGIN Request
*Mar  1 00:16:42.723: Se1/0 CHAP: Using hostname from unknown source
*Mar  1 00:16:42.727: Se1/0 CHAP: Using password from AAA
*Mar  1 00:16:42.727: Se1/0 CHAP: O RESPONSE id 3 len 28 from "Router1"
*Mar  1 00:16:42.731: Se1/0 PPP: Received LOGIN Response PASS
*Mar  1 00:16:42.735: Se1/0 PPP: Sent LCP AUTHOR Request
*Mar  1 00:16:42.739: Se1/0 PPP: Sent IPCP AUTHOR Request
*Mar  1 00:16:42.743: Se1/0 LCP: Received AAA AUTHOR Response PASS
*Mar  1 00:16:42.747: Se1/0 IPCP: Received AAA AUTHOR Response PASS
*Mar  1 00:16:42.747: Se1/0 CHAP: O SUCCESS id 3 len 4
*Mar  1 00:16:42.935: Se1/0 CHAP: I SUCCESS id 3 len 4
*Mar  1 00:16:42.939: Se1/0 PPP: Sent CDPCP AUTHOR Request
*Mar  1 00:16:42.943: Se1/0 PPP: Sent IPCP AUTHOR Request
*Mar  1 00:16:42.955: Se1/0 CDPCP: Received AAA AUTHOR Response PASS
Router1#
Debug PPP Negotiation

Este comando nos muestra los procesos de negociacion de PPP, aqui un ejemplo.
Router1#debug ppp negotiation
PPP protocol negotiation debugging is on
Router1#
*Mar  1 00:20:47.199: Se1/0 LCP: I CONFREQ [Open] id 5 len 15
*Mar  1 00:20:47.199: Se1/0 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 00:20:47.199: Se1/0 LCP:    MagicNumber 0x011C567B (0x0506011C567B)
*Mar  1 00:20:47.203: Se1/0 CDPCP: State is Closed
*Mar  1 00:20:47.203: Se1/0 IPCP: State is Closed
*Mar  1 00:20:47.207: Se1/0 PPP: Phase is TERMINATING
*Mar  1 00:20:47.211: Se1/0 PPP: Phase is ESTABLISHING
*Mar  1 00:20:47.211: Se1/0 LCP: O CONFREQ [Open] id 8 len 15
*Mar  1 00:20:47.211: Se1/0 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 00:20:47.215: Se1/0 LCP:    MagicNumber 0x001D100F (0x0506001D100F)
*Mar  1 00:20:47.215: Se1/0 LCP: O CONFACK [Open] id 5 len 15
*Mar  1 00:20:47.215: Se1/0 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 00:20:47.215: Se1/0 LCP:    MagicNumber 0x011C567B (0x0506011C567B)
*Mar  1 00:20:47.219: Se1/0 IPCP: Remove route to 192.168.1.129
*Mar  1 00:20:47.223: Se1/0 LCP: I CONFACK [ACKsent] id 8 len 15
*Mar  1 00:20:47.227: Se1/0 LCP: AuthProto CHAP (0x0305C22305)
*Mar  1 00:20:47.227: Se1/0 LCP:  MagicNumber 0x001D100F (0x0506001D100F)
*Mar  1 00:20:47.227: Se1/0 LCP: State is Open
*Mar  1 00:20:47.227: Se1/0 PPP: Phase is AUTHENTICATING, by both
*Mar  1 00:20:47.231: Se1/0 CHAP: O CHALLENGE id 5 len 28 from "Router1"
*Mar  1 00:20:47.231: Se1/0 CHAP: I CHALLENGE id 5 len 28 from "Router2"
*Mar  1 00:20:47.235: Se1/0 CHAP: I RESPONSE id 5 len 28 from "Router2"
*Mar  1 00:20:47.235: Se1/0 PPP: Phase is FORWARDING, Attempting Forward
*Mar  1 00:20:47.243: Se1/0 PPP: Phase is AUTHENTICATING, Unauthenticated User
*Mar  1 00:20:47.247: Se1/0 CHAP: Using hostname from unknown source
*Mar  1 00:20:47.247: Se1/0 CHAP: Using password from AAA
*Mar  1 00:20:47.247: Se1/0 CHAP: O RESPONSE id 5 len 28 from "Router1"
*Mar  1 00:20:47.251: Se1/0 PPP: Phase is FORWARDING, Attempting Forward
*Mar  1 00:20:47.255: Se1/0 PPP: Phase is AUTHENTICATING, Authenticated User
*Mar  1 00:20:47.263: Se1/0 CHAP: O SUCCESS id 5 len 4
*Mar  1 00:20:47.455: Se1/0 CHAP: I SUCCESS id 5 len 4
*Mar  1 00:20:47.459: Se1/0 PPP: Phase is UP
*Mar  1 00:20:47.459: Se1/0 IPCP: O CONFREQ [Closed] id 1 len 10
*Mar  1 00:20:47.459: Se1/0 IPCP:    Address 192.168.1.130 (0x0306C0A80182)
*Mar  1 00:20:47.463: Se1/0 PPP: Process pending ncp packets
*Mar  1 00:20:47.463: Se1/0 IPCP: I CONFREQ [REQsent] id 1 len 10
*Mar  1 00:20:47.467: Se1/0 IPCP:    Address 192.168.1.129 (0x0306C0A80181)
*Mar  1 00:20:47.467: Se1/0 AAA/AUTHOR/IPCP: Start.  Her address 192.168.1.129, we want 0.0.0.0
*Mar  1 00:20:47.471: Se1/0 CDPCP: I CONFREQ [Closed] id 1 len 4
*Mar  1 00:20:47.479: Se1/0 AAA/AUTHOR/IPCP: Reject 192.168.1.129, using 0.0.0.0
*Mar  1 00:20:47.479: Se1/0 AAA/AUTHOR/IPCP: Done.  Her address 192.168.1.129, we want 0.0.0.0
*Mar  1 00:20:47.483: Se1/0 IPCP: O CONFACK [REQsent] id 1 len 10
*Mar  1 00:20:47.483: Se1/0 IPCP:    Address 192.168.1.129 (0x0306C0A80181)
*Mar  1 00:20:47.483: Se1/0 IPCP: I CONFACK [ACKsent] id 1 len 10
*Mar  1 00:20:47.483: Se1/0 IPCP:    Address 192.168.1.130 (0x0306C0A80182)
*Mar  1 00:20:47.487: Se1/0 IPCP: State is Open
*Mar  1 00:20:47.487: Se1/0 CDPCP: O CONFREQ [Closed] id 1 len 4
*Mar  1 00:20:47.499: Se1/0 IPCP: Install route to 192.168.1.129
*Mar  1 00:20:47.547: Se1/0 CDPCP: I CONFACK [REQsent] id 1 len 4
*Mar  1 00:20:49.463: Se1/0 CDPCP: Timeout: State ACKrcvd
*Mar  1 00:20:49.463: Se1/0 CDPCP: O CONFREQ [ACKrcvd] id 2 len 4
*Mar  1 00:20:49.503: Se1/0 CDPCP: I CONFACK [REQsent] id 2 len 4
*Mar  1 00:20:49.527: Se1/0 CDPCP: I CONFREQ [ACKrcvd] id 2 len 4
*Mar  1 00:20:49.527: Se1/0 CDPCP: O CONFACK [ACKrcvd] id 2 len 4
*Mar  1 00:20:49.527: Se1/0 CDPCP: State is Open
Los otros comandos utiles son los siguientes:
debug ppp packet
debug ppp error
debug ppp chap

Rutas Conectadas y Rutas Estáticas

Los Routers necesitan tener rutas en sus tablas de enrutamiento IP para poder enviar los paquetes a la direcciónes correctas. Dos formas por el cual un router agrega rutas en su tabla de enrutamiento es aprendiendo o se da cuenta que redes tiene conectadas en sus interfaces y otra forma es mediante la configuración de las rutas desde la configuración global. La siguiente imagen muestra una topologia básica para configurar rutas estáticas.

Topologia Básica de la Red.

En GNS3, la topologia de rede se vería mas o menos de la siguiente manera.

Topologia de Red en GNS3.

Rutas Conectadas.


Configuración de las interfaces en el Router1
!
interface FastEthernet0/0
ip address 10.1.128.251 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.130.251 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 10.1.1.251 255.255.255.0
duplex auto
speed auto
!
El comando siguiente muestras el estado de las interfaces en el Router1, como se puede ver las tres interfaces están en estado "up & up" y cada interface tiene configurado una dirección IP.
Router1#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.1.128.251    YES manual up                    up
FastEthernet0/1            10.1.130.251    YES manual up                    up
FastEthernet1/0            10.1.1.251      YES manual up                    up
Router1#
El siguiente comando nos muestra las rutas conocidas por el Router1, todas las rutas conectadas (C).
Router1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 3 subnets
C       10.1.1.0 is directly connected, FastEthernet1/0
C       10.1.130.0 is directly connected, FastEthernet0/1
C       10.1.128.0 is directly connected, FastEthernet0/0
Router1#
El Router1 agrego las rutas de las tres subredes que se encuentran conectadas a su tabla de enrutamiento. La letra "C" significa "Conectado".

Rutas Estáticas

Las rutas conectadas son importantes, pero los routers suelen necesitar de otras rutas para enviar la información a todas las subredes de una red. Por ejemplo el Router1 puede fácilmente realizar un Ping a las subredes que tiene conectadas, por ejemplo a la subred conectada 10.1.1.0/24. Sin embargo si se realiza un Ping a la subred 10.1.2.0/24 no la conocerá y no podrá llegar a esa subred. Tal como se muestra a continuación.

Ping a la subred conectada, interface Fa0/0 del Router2.
Router1#ping 10.1.128.252

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.128.252, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/60/116 ms
Router1#
Ping a la Subred 10.1.2.0/24.
Router1#ping 10.1.2.252

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.252, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Router1#
El comando Ping envía un paquete de solicitud ICMP (echo request) a la dirección destino. El host destino responde al ping solicitado con un paquete llamada ICMP de respuesta o echo reply. El comando Ping envía el primer paquete y espera la respuesta. Si se recibe una respuesta, el comando muestra un "!". Si no se recibe una respuesta en el tiempo de espera predeterminado de 2 segundos, el comando ping nos muestra un ".". En el IOS de cisco, el comando Ping envía cinco de estos paquetes de forma predeterminada. En el ejemplo anterior el primer Ping dado a la IP 10.1.128.252 funciona correctamente, ya que nos muestra todos los "!!!!!". Sin embargo, el Ping dado a la dirección IP 10.1.2.252 no funciona, ya que nos muestra todo los ".....", esto es porque el Router1 no tiene una ruta para la subred 10.1.2.0/24 donde se encuentra la IP 10.1.2.252.

La solución mas sencilla y típica para este problema es configurar un protocolo de enrutamiento en los tres Routers. Sin embargo, en lugar de protocolos de enrutamientos, podemos configurar rutas estáticas. Para configurar rutas estáticas se realiza de la siguiente manera.

Configurando Rutas Estáticas en el Router1.
Router1#configure terminal
Router1(config)#ip route 10.1.2.0 255.255.255.0 10.1.128.252
Router1(config)#ip route 10.1.3.0 255.255.255.0 10.1.130.252
Router1(config)#^Z
Router1#
*Mar  1 00:11:14.279: %SYS-5-CONFIG_I: Configured from console by console
Router1#show ip route static
10.0.0.0/24 is subnetted, 5 subnets
S       10.1.3.0 [1/0] via 10.1.130.252
S       10.1.2.0 [1/0] via 10.1.128.252
Router1#
Desde configuración global le indicamos cual sera la subred con su respectiva mascara y la dirección IP del siguiente salto. Ahora el Router1 sabe como enviar las rutas a los demás Routers de la Red. También se muestra el comando show ip route static, con el podemos visualizar que rutas estáticas tenemos configuradas en el Router1. El Signo de "S" significa que la ruta fue configurada estaticamente.

Ping a las demás Subredes.
Router1#ping 10.1.2.252
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.252, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/56/132 ms

Router1#ping 10.1.3.253
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.3.253, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/44/136 ms
Router1#
Visualizar todas las rutas en el Router1.
Router1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 5 subnets
S       10.1.3.0 [1/0] via 10.1.130.252
S       10.1.2.0 [1/0] via 10.1.128.252
C       10.1.1.0 is directly connected, FastEthernet1/0
C       10.1.130.0 is directly connected, FastEthernet0/1
C       10.1.128.0 is directly connected, FastEthernet0/0
Router1#
Como se puede observar tenemos comunicación con las subredes configuradas, esto solo desde el Router1. En los demás Routers se tiene que hacer el mismo proceso para configurar las rutas estáticas y así tener comunicación con las demás subredes.

Configuración de Frame Relay

Frame Relay es un protocolo WAN muy popular porque facilita la construcción de redes confiables y de bajo costo. Uno de sus principales ventajas es de poder configurar enlaces seriales punto a punto con la capacidad de conectar un sitio a muchos sitios remotos a través de un circuito físico. En este post se mostrara la configuración de Frame Relay utilizando la siguiente topologia.
Empecemos configurando el primer Router
Router1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#int s1/0
Router1(config-if)#ip address 192.168.1.1 255.255.255.248
Router1(config-if)#encapsulation frame-relay
Router1(config-if)#no frame-relay inverse-arp
Router1(config-if)#frame-relay map ip 192.168.1.2 102 broadcast
Router1(config-if)#frame-relay map ip 192.168.1.3 103 broadcast
Router1(config-if)#no shut
Router1(config-if)#
*Mar  1 00:11:15.775: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up
Router1(config-if)#
*Mar  1 00:11:26.775: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up
Router1(config-if)#end
Router1#
Hacemos lo mismo con el Router2
Router2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router2(config)#int s1/0
Router2(config-if)#ip address 192.168.1.2 255.255.255.248
Router2(config-if)#encapsulation frame-relay
Router2(config-if)#no frame-relay inverse-arp
Router2(config-if)#frame-relay map ip 192.168.1.1 201 broadcast
Router2(config-if)#frame-relay map ip 192.168.1.3 201    
Router2(config-if)#no shut
Router2(config-if)#
*Mar  1 00:11:01.831: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up
Router2(config-if)#
*Mar  1 00:11:12.831: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up
Router2(config-if)#end
Router2#
Finalmente la configuracion del Router3
Router3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router3(config)#int s1/0
Router3(config-if)#ip address 192.168.1.3 255.255.255.248
Router3(config-if)#encapsulation frame-relay
Router3(config-if)#no frame-relay inverse-arp
Router3(config-if)#frame-relay map ip 192.168.1.1 301 broadcast
Router3(config-if)#frame-relay map ip 192.168.1.2 301   
Router3(config-if)#no shut
Router3(config-if)#
*Mar  1 00:11:33.187: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up
Router3(config-if)#
*Mar  1 00:11:44.187: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up
Router3(config-if)#
Router3(config-if)#end
Router3#
Mostrar el estado de la interface serial1/0 en el Router3
Router3#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet0/1            unassigned      YES unset  administratively down down
Serial1/0                  192.168.1.3     YES manual up                    up
Serial1/1                  unassigned      YES unset  administratively down down
Serial1/2                  unassigned      YES unset  administratively down down
Serial1/3                  unassigned      YES unset  administratively down down
Realizar una prueba de conectividad.
Router3#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/73/132 ms
Router3#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/105/344 ms
Router3#
Mostrar el estado de la interface serial1/0 en el Router2
Router2#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet0/1            unassigned      YES unset  administratively down down
Serial1/0                  192.168.1.2     YES manual up                    up
Serial1/1                  unassigned      YES unset  administratively down down
Serial1/2                  unassigned      YES unset  administratively down down
Serial1/3                  unassigned      YES unset  administratively down down
Realizar una prueba de conectividad.
Router2#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/63/148 ms
Router2#ping 192.168.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/127/276 ms
Router2#
Verificacamos la misma informacion en el Router1
Router1#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet0/1            unassigned      YES unset  administratively down down
Serial1/0                  192.168.1.1     YES manual up                    up
Serial1/1                  unassigned      YES unset  administratively down down
Serial1/2                  unassigned      YES unset  administratively down down
Serial1/3                  unassigned      YES unset  administratively down down

Router1#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/56/140 ms
Router1#ping 192.168.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/60/140 ms
Router1#
Información de encapsulacion y otros datos de la interface serial1/0
Router1#show interfaces serial1/0
Serial1/0 is up, line protocol is up
 Hardware is M4T
 Internet address is 192.168.1.1/29
 MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation FRAME-RELAY, crc 16, loopback not set
 Keepalive set (10 sec)
 Restart-Delay is 0 secs
 LMI enq sent  44, LMI stat recvd 45, LMI upd recvd 0, DTE LMI up
 LMI enq recvd 0, LMI stat sent  0, LMI upd sent  0
 LMI DLCI 0  LMI type is ANSI Annex D  frame relay DTE
 Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 0
 Last input 00:00:00, output 00:00:00, output hang never
 Last clearing of "show interface" counters 00:08:52
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: weighted fair
 Output queue: 0/1000/64/0 (size/max total/threshold/drops)
    Conversations  0/1/256 (active/max active/max total)
    Reserved Conversations 0/0 (allocated/max allocated)
    Available Bandwidth 1158 kilobits/sec
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
    85 packets input, 4870 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    89 packets output, 4936 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 output buffer failures, 0 output buffers swapped out
    1 carrier transitions     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
Router1#
Estadísticas LMI
Router1#show frame-relay lmi

LMI Statistics for interface Serial1/0 (Frame Relay DTE) LMI TYPE = ANSI
Invalid Unnumbered info 0             Invalid Prot Disc 0
Invalid dummy Call Ref 0              Invalid Msg Type 0
Invalid Status Message 0              Invalid Lock Shift 0
Invalid Information ID 0              Invalid Report IE Len 0
Invalid Report Request 0              Invalid Keep IE Len 0
Num Status Enq. Sent 51               Num Status msgs Rcvd 52
Num Update Status Rcvd 0              Num Status Timeouts 0
Last Full Status Req 00:00:36         Last Full Status Rcvd 00:00:36
El siguiente comando muestra el estado y varias estadísticas útiles de cada uno de los PVC (Permanent Virtual Circuits).
Router1#show frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

       Active     Inactive      Deleted       Static
Local          2            0            0            0
Switched       0            0            0            0
Unused         0            0            0            0

DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 20            output pkts 21           in bytes 2080
out bytes 2140           dropped pkts 0           in pkts dropped 0  
out pkts dropped 0                out bytes dropped 0  
in FECN pkts 0           in BECN pkts 0           out FECN pkts 0  
out BECN pkts 0          in DE pkts 0             out DE pkts 0  
out bcast pkts 0         out bcast bytes 0  
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:09:11, last time pvc status changed 00:07:44

DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 20            output pkts 21           in bytes 2080
out bytes 2140           dropped pkts 0           in pkts dropped 0  
out pkts dropped 0                out bytes dropped 0  
in FECN pkts 0           in BECN pkts 0           out FECN pkts 0  
out BECN pkts 0          in DE pkts 0             out DE pkts 0  
out bcast pkts 0         out bcast bytes 0  
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:08:52, last time pvc status changed 00:07:45
Información de los mapas actuales
Router1#show frame-relay map
Serial1/0 (up): ip 192.168.1.2 dlci 102(0x66,0x1860), static,
       broadcast,
       CISCO, status defined, active
Serial1/0 (up): ip 192.168.1.3 dlci 103(0x67,0x1870), static,
       broadcast,
       CISCO, status defined, active
Estadisticas de trafico
Router1#show frame-relay traffic
Frame Relay statistics:
 ARP requests sent 0, ARP replies sent 0
 ARP request recvd 0, ARP replies recvd 0
Router1#