Seguridad y Redes

Tips & Video Tutoriales, Wifislax, VMware, GNS3, VirtualBox, CCNA, Cisco Routers & Switches, [ Programming ]

Configuración de OSPF en un Cisco 3725 (IOS) y Nexus 7000 (NX-OS)

A continuación, se muestra un ejemplo de configuración básica de OSPF entre un Switch Nexus y un Router 3725. Para habilitar OSPF en el Cisco Nexus se realiza desde la configuración de la interfaz.

Topologia en GNS3.

Habilitamos OSPF
N7K-2(config)# feature ospf
Habilitamos el proceso de OSPF
N7K-2(config)# router ospf 10
N7K-2(config-router)# router-id 10.10.10.1
Habilitamos OSPF en la interface en particular
N7K-2(config)# int ethernet 2/2
N7K-2(config-if)# ip address 10.10.10.1 255.255.255.0
N7K-2(config-if)# no shutdown
N7K-2(config-if)# ip router ospf 10 area 0
N7K-2(config-if)# end
N7K-2#
Configuración de OSPF en el Cisco 3725.
ESW1(config)#interface fastEthernet0/1
ESW1(config-if)#ip add 10.10.10.2 255.255.255.0
ESW1(config-if)#no shutdown

ESW1(config)#interface fastEthernet0/0
ESW1(config-if)#ip add 10.4.4.4 255.255.255.0
ESW1(config-if)#no shutdown
ESW1(config-if)#exit

ESW1(config)#interface loopback2
ESW1(config-if)#ip address 10.3.3.3 255.255.255.0
ESW1(config-if)#end

ESW1#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.4.4.4        YES manual up                    up      
FastEthernet0/1            10.10.10.2      YES manual up                    up      
FastEthernet1/0            unassigned      YES unset  up                    down    
FastEthernet1/14           unassigned      YES unset  up                    down    
FastEthernet1/15           unassigned      YES unset  up                    down    
Vlan1                      unassigned      YES unset  up                    down    
Loopback1                  10.2.2.2        YES manual up                    up      
Loopback2                  10.3.3.3        YES manual up                    up      

ESW1(config)#router ospf 10
ESW1(config-router)#network 10.10.10.0 0.0.0.255 area 0
*Mar  1 00:06:10.307: %OSPF-5-ADJCHG: Process 10, Nbr 10.10.10.1 on FastEthernet0/1 from LOADING to FULL, Loading Done
ESW1(config-router)#networ 10.4.4.0 0.0.0.255 area 0
ESW1(config-router)#

Verificación
ESW1#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.10.10.1        1   FULL/BDR        00:00:33    10.10.10.1      FastEthernet0/1
ESW1


ESW1#show cdp neighbors detail 
-------------------------
Device ID: N7K-2(Nexus-Switch)
Entry address(es): 
  IP address: 10.10.10.1
Platform: Nexus-Switch,  Capabilities: Router Switch IGMP 
Interface: FastEthernet0/1,  Port ID (outgoing port): Ethernet2/2
Holdtime : 165 sec

Version :
Cisco Nexus Operating System (NX-OS) Software, Version 5.1(2)

advertisement version: 2
Duplex: full

ESW1#
Verificación en el Cisco Nexus
N7K-2# show ip route
IP Route Table for VRF "default"
'*' denotes best ucast next-hop
'**' denotes best mcast next-hop
'[x/y]' denotes [preference/metric]

10.4.4.0/24, ubest/mbest: 1/0
    *via 10.10.10.2, Eth2/2, [110/50], 00:00:11, ospf-10, intra
10.10.10.0/24, ubest/mbest: 1/0, attached
    *via 10.10.10.1, Eth2/2, [0/0], 00:01:52, direct
10.10.10.1/32, ubest/mbest: 1/0, attached
    *via 10.10.10.1, Eth2/2, [0/0], 00:01:52, local
N7K-2#

N7K-2# show ip ospf neighbors
 OSPF Process ID 10 VRF default
 Total number of neighbors: 1
 Neighbor ID     Pri State            Up Time  Address         Interface
 10.3.3.3          1 FULL/DR          00:00:09 10.10.10.2      Eth2/2


N7K-2# ping 10.10.10.2
PING 10.10.10.2 (10.10.10.2): 56 data bytes
64 bytes from 10.10.10.2: icmp_seq=0 ttl=254 time=10 ms
64 bytes from 10.10.10.2: icmp_seq=1 ttl=254 time=10 ms
64 bytes from 10.10.10.2: icmp_seq=2 ttl=254 time=10 ms
64 bytes from 10.10.10.2: icmp_seq=3 ttl=254 time=10 ms
64 bytes from 10.10.10.2: icmp_seq=4 ttl=254 time=10 ms

--- 10.10.10.2 ping statistics ---
5 packets transmitted, 5 packets received, 0.00% packet loss
round-trip min/avg/max = 10/10/10 ms
N7K-2#

N7K-2# ping 10.4.4.4
PING 10.4.4.4 (10.4.4.4): 56 data bytes
64 bytes from 10.4.4.4: icmp_seq=0 ttl=254 time=10 ms
64 bytes from 10.4.4.4: icmp_seq=1 ttl=254 time=10 ms
64 bytes from 10.4.4.4: icmp_seq=2 ttl=254 time=0 ms
64 bytes from 10.4.4.4: icmp_seq=3 ttl=254 time=0 ms
64 bytes from 10.4.4.4: icmp_seq=4 ttl=254 time=10 ms

--- 10.4.4.4 ping statistics ---
5 packets transmitted, 5 packets received, 0.00% packet loss
round-trip min/avg/max = 0/6/10 ms
N7K-2#

Passive Interface

Otro caracteristica que le podemos configurar a EIGRP es lo que se llama interface pasiva (passive interface).

Una interface pasiva lo que hace es que no envía ningún tipo de paquete, ni hellos ni cualquier otro tipos de paquetes. Es decir que por esa interfaces no podremos tener neighbors o vecinos pero si anunciara las redes de dichas interfaces.

¿Cuándo se utiliza este tipo de interfaces?
  • Para suprimir tráfico de actualización innecesario, por ejemplo, cuando una interfaz es una interfaz LAN, sin otros routers conectados.
  • Para aumentar los controles de seguridad, por ejemplo, para evitar que dispositivos desconocidos de routing no autorizados reciban actualizaciones de EIGRP.

Observando la topología sería buena idea configurar como interfaces pasivas las áreas en color rojo, porque en esas interfaces no tendremos ningún neighbor pero si vamos anunciar las redes de dichas interfaces.

Configuración de Passive Interface.

R5#configure terminal
R5(config)#router eigrp 10
R5(config-router)#passive-interface ethernet 0/1

R2#configure terminal 
R2(config)#router eigrp 10
R2(config-router)#passive-interface fastEthernet 1/0

Hemos configurado las interfaces pasivas, desde R3 podremos seguir viendo las redes y seguiremos teniendo conectividad.

Configuración de EIGRP

Las mínimas opciones que podemos configurar para habilitar EIGRP son las siguientes.
  1. Proceso de EIGRP
  2. Sistema Autonomo
  3. Habilitar EIGRP en las interfaces
Topologia a configurar.

Configurar la parte del direccionamiento.

Configuración de R2
R2#configure terminal
R2(config)#interface fastEthernet1/0
R2(config-if)#ip address 192.168.2.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

R2(config)#interface serial2/1
R2(config-if)#ip address 192.168.0.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#end
R2#

Cofiguración de R3
R3#configure terminal 
R3(config)#interface serial1/3
R3(config-if)#ip address 192.168.0.1 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit

R3(config)#interface ethernet0/0
R3(config-if)#ip address 192.168.35.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#end
R3# 

Configuracón de R5
R5#configure terminal 
R5(config)#interface ethernet0/0
R5(config-if)#ip address 192.168.35.5 255.255.255.0
R5(config-if)#no shutdown
R5(config-if)#exit

R5(config)#interface ethernet0/1
R5(config-if)#ip address 192.168.5.5 255.255.255.0
R5(config-if)#no shutdown
R5(config-if)#end
R5#

Si ingresamos el comando show ip route en R2, podremos ver lo siguiente.


Si realizamos un ping a 192.168.35.3 no va responder ya que no tenemos una ruta hacia él. Podemos configurar rutas estáticas, pero en este caso vamos a configurar EIGRP.

R2#ping 192.168.35.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.35.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Pasos para configurar EIGRP

Entrar a configuración global.
R2#configure terminal

Ingresar el comando router eigrp sistema_autonomo. Podemos asignarle un número de AS que va del 1 al 65535.
R2(config)#router eigrp ?
  <1-65535>  Autonomous system number

R2(config)#router eigrp 10
R2(config-router)#no auto-summary

El siguiente paso es indicar en que interfaces va estar corriendo EIGRP. Esto se realiza con el comando network.

R2(config-router)#network 192.168.2.0 0.0.0.255
R2(config-router)#network 192.168.0.0 0.0.0.3

Con este estamos indicando que estamos corriendo EIGRP en ambas interfaces.

Configuración de EIGRP en las interfaces de R3.
R3#configure terminal
R3(config)#router eigrp 10
R3(config-router)#no auto-summary
R3(config-router)#network 192.168.0.0 0.0.0.3
R3(config-router)#network 192.168.35.0 0.0.0.255

*Mar  1 00:01:59.599: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 192.168.0.2 (Serial1/3) is up: new adjacency

Podemos observar que se ha creado una adyacencia.

Como ya tenemos corriendo EIGRP en R3 con R2 podemos ingresar el siguiente comando, el cual nos va listar los vecinos o neighbors que tenemos.

R3#show ip eigrp neighbors


R3#show ip route eigrp


Configuración de EIGRP en R5.

Si primero hacemos un show ip route en R5, veremos las redes que están solamente conectadas.

R5#configure terminal 
R5(config)#router eigrp 10
R3(config-router)#no auto-summary
R5(config-router)#network 192.168.35.0 0.0.0.255 
R5(config-router)#network 192.168.5.5 0.0.0.0 

Frame Relay con Inverse ARP

Con esta practica en GNS3, verificaremos y entenderemos el funcionamiento de Frame Relay. Esta tecnologia WAN (Wide Area Network) es muy popular porque facilita la construcción de redes confiables y de bajo costo. Uno de sus principales ventajas es de poder configurar enlaces seriales punto a punto con la capacidad de conectar un sitio a muchos sitios remotos a través de un circuito físico. En esta practica se mostrara el proceso de la configuración de Frame Relay utilizando la siguiente topologia.

Topologia de Frame Relay a Configurar en GNS3.

La imagen anterior muestra una topologia Full Mesh. Una red Mesh es una red múltiplemente conexa, en la cual los nodos tienen más de una conexión con más de un nodo diferente. No necesariamente deben conectarse todos contra todos, éste es un caso especial que se denomina Full-Mesh. Configuraremos esta topologia en GNS3, en el cual utilizaremos un Router central el cual le configuraremos cuatro interfaces seriales donde le indiciaremos los DLCIs para que puedan ser asignados dinamicamente con Inverse ARP. Al configurar la encapsulacion Frame Relay en cada Router, automaticamente detectara los DLCIs ya que Inverse ARP esta habilitado por defecto.

Frame Relay en GNS3 con topologia Full Mesh.

Para configurar esta toplogia primero realizaremos la configuracion del Switch de Frame Relay, donde le indicaremos los DLCIs. Lo primero es activar la conmutación Frame Relay en el Router con el siguiente comando.

FrameRelay(config)#frame-relay switching

Luego a configurar las interfaces seriales, la encapsulacion, el reloj, le indicaremos que la interface como dispositivo DCE y por ultimo definimos los DLCIs para cada interface.

FrameRelay#configure terminal
FrameRelay(config)#interface Serial1/0
FrameRelay(config-if)#no ip address
FrameRelay(config-if)#encapsulation frame-relay
FrameRelay(config-if)#clock rate 64000
FrameRelay(config-if)#frame-relay intf-type dce
FrameRelay(config-if)#frame-relay route 102 interface Serial1/1 201
FrameRelay(config-if)#frame-relay route 103 interface Serial1/2 301
FrameRelay(config-if)#frame-relay route 104 interface Serial1/3 401
FrameRelay(config-if)#no shutdown
FrameRelay(config-if)#exit
FrameRelay(config)#interface Serial1/1
FrameRelay(config-if)#no ip address
FrameRelay(config-if)#encapsulation frame-relay
FrameRelay(config-if)#clock rate 64000
FrameRelay(config-if)#frame-relay intf-type dce
FrameRelay(config-if)#frame-relay route 201 interface Serial1/0 102
FrameRelay(config-if)#frame-relay route 203 interface Serial1/2 302
FrameRelay(config-if)#frame-relay route 204 interface Serial1/3 402
FrameRelay(config-if)#no shutdown
FrameRelay(config-if)#exit
FrameRelay(config)#interface Serial1/2
FrameRelay(config-if)#no ip address
FrameRelay(config-if)#encapsulation frame-relay
FrameRelay(config-if)#clock rate 64000
FrameRelay(config-if)#frame-relay intf-type dce
FrameRelay(config-if)#frame-relay route 301 interface Serial1/0 103
FrameRelay(config-if)#frame-relay route 302 interface Serial1/1 203
FrameRelay(config-if)#frame-relay route 304 interface Serial1/3 403
FrameRelay(config-if)#no shutdown
FrameRelay(config-if)#exit
FrameRelay(config)#interface Serial1/3
FrameRelay(config-if)#no ip address
FrameRelay(config-if)#encapsulation frame-relay
FrameRelay(config-if)#clock rate 64000
FrameRelay(config-if)#frame-relay intf-type dce
FrameRelay(config-if)#frame-relay route 401 interface Serial1/0 104
FrameRelay(config-if)#frame-relay route 402 interface Serial1/1 204
FrameRelay(config-if)#frame-relay route 403 interface Serial1/2 304
FrameRelay(config-if)#no shutdown
FrameRelay(config-if)#exit
FrameRelay(config)#end
FrameRelay#
Ahora configuramos las interfaces de los Routers.
R1>enable
R1#configure terminal
R1(config)# interface serial1 /0
R1(config-if)#encapsulation frame-relay
R1(config-if)#frame-relay lmi-type cisco
R1(config-if)#ip address 192.168.123.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#end
R1#
R2>enable
R2#configure terminal
R2(config)#interface serial1/0
R2(config-if)#encapsulation frame-relay
R2(config-if)#frame-relay lmi-type cisco
R2(config-if)#ip address 192.168.123.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#end
R2#
R3>enable
R3#configure terminal
R3(config)#interface serial1/0
R3(config-if)#encapsulation frame-relay
R3(config-if)#frame-relay lmi-type cisco
R3(config-if)#ip address 192.168.123.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#end
R3#
R4>enable
R4#configure terminal
R4(config)#interface serial1/0
R4(config-if)#encapsulation frame-relay
R4(config-if)#frame-relay lmi-type cisco
R4(config-if)#ip address 192.168.123.4 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#end
R4#
Terminando de realizar lo anterior ya podemos verificar en cualquier router con el comando show frame-relay pvc que Inverse ARP ha realizado su trabajo.
R1#show frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          3            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 1             output pkts 1            in bytes 34      
  out bytes 34             dropped pkts 0           in pkts dropped 0        
  out pkts dropped 0                out bytes dropped 0        
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        
  out BECN pkts 0          in DE pkts 0             out DE pkts 0        
  out bcast pkts 1         out bcast bytes 34      
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:07:06, last time pvc status changed 00:06:46
         
DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 1             output pkts 2            in bytes 34      
  out bytes 68             dropped pkts 0           in pkts dropped 0        
  out pkts dropped 0                out bytes dropped 0        
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        
  out BECN pkts 0          in DE pkts 0             out DE pkts 0        
  out bcast pkts 2         out bcast bytes 68      
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:07:10, last time pvc status changed 00:06:50
         
DLCI = 104, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 1             output pkts 1            in bytes 34      
  out bytes 34             dropped pkts 0           in pkts dropped 0        
  out pkts dropped 0                out bytes dropped 0        
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        
  out BECN pkts 0          in DE pkts 0             out DE pkts 0        
  out bcast pkts 1         out bcast bytes 34      
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:07:11, last time pvc status changed 00:06:41
Muestra estadísticas acerca de los PVC para las interfaces.

Como podemos ver, Inverse ARP ha detectado los DLCIs. Como se muestra en la salida anterior ha detectado 3 DLCIs en funcionamiento. Estas DLCIs son las que tenemos en nuestra topologia. Para verificar el funcionamiento de Frame Relay podemos también utilizar los siguientes comandos.
Las Estadisticas de los LMI.
R1#show frame-relay lmi
LMI Statistics for interface Serial1/0 (Frame Relay DTE) LMI TYPE = CISCO
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 140              Num Status msgs Rcvd 115
  Num Update Status Rcvd 0              Num Status Timeouts 25
  Last Full Status Req 00:00:00         Last Full Status Rcvd 00:00:00

El mapeo de los DLCIs.
R1#show frame-relay map
Serial1/0 (up): ip 192.168.123.2 dlci 102(0x66,0x1860), dynamic,
              broadcast,, status defined, active
Serial1/0 (up): ip 192.168.123.3 dlci 103(0x67,0x1870), dynamic,
              broadcast,, status defined, active
Serial1/0 (up): ip 192.168.123.4 dlci 104(0x68,0x1880), dynamic,
              broadcast,, status defined, active0
Muestra las entradas de mapeo actuales.

En la salida anterior nos muestra los DLCIs y que han sido aprendidos de manera dinámica. Con el siguiente comando podemos verificar que estamos utilizando la encapsulación de frame-relay en la interface, los datos de LMI, los Keepalive y mas informacion sobre la interface.
R1#show interface serial1/0
Serial1/0 is up, line protocol is up
  Hardware is M4T
  Internet address is 192.168.123.1/24
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  CRC checking enabled
  LMI enq sent  105, LMI stat recvd 80, LMI upd recvd 0, DTE LMI up
  LMI enq recvd 0, LMI stat sent  0, LMI upd sent  0
  LMI DLCI 1023  LMI type is CISCO  frame relay DTE
  FR SVC disabled, LAPF state down
  Broadcast queue 0/64, broadcasts sent/dropped 5/0, interface broadcasts 0
  Last input 00:00:06, output 00:00:06, output hang never
  Last clearing of "show interface" counters 00:18:53
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     85 packets input, 1618 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     114 packets output, 1671 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
Encapsulacion Frame Relay en la Interface Serial.

Verificamos la conectividad dando un ping a cada router.
R1#ping 192.168.123.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/142/332 ms
R1#ping 192.168.123.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/120/192 ms
R1#ping 192.168.123.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/127/240 ms


Routing entre VLANs (InterVLAN Routing)

Configurar el siguiente escenario. Donde tenemos dos Switches, en cada uno de los switches configuraremos dos VLANs, uno con nombre de vlan10 y el segundo con nombre de vlan20. Cada uno de los switches tendra conectado un host, el primero switch tendra un host que estara en la vlan10 y el segundo switch tendra otro host que estara en la vlan20.
Inter-VLAN Routing
Para que halla comunicación entre vlans en diferentes segmentos de red necesitaremos un dispositivo de capa 3, un router con como se ve en la imagen. A este router le configuraremos dos subinterfaces el cual nos ayudara a que halla comunicion entre vlans.

Inter-VLAN Routing en GNS3
Lo primero que haremos es crear dos vlan en cada switch (sin el VTP).
SW1(config)#vlan 10
SW1(config-vlan)#name VLAN10
SW1(config-vlan)#vlan 20
SW1(config-vlan)#name VLAN20
SW1(config-vlan)#end

SW2(config)#vlan 10
SW2(config-vlan)#name VLAN10
SW2(config-vlan)#vlan 20
SW2(config-vlan)#name VLAN20
SW2(config-vlan)#end
Verificamos
SW1#show vlan-sw
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0, Fa1/1, Fa1/2, Fa1/3
                                                Fa1/4, Fa1/5, Fa1/6, Fa1/7
                                                Fa1/8, Fa1/9, Fa1/10, Fa1/11
                                                Fa1/12, Fa1/13, Fa1/14, Fa1/15
10   VLAN10                           active   
20   VLAN20                           active   
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
Una vez creada las VLANs, ahora las asignaremos a los puertos.
SW1(config)#int f1/3
SW1(config-if)#switchport access vlan 10
SW1(config-if)#end
SW1#show vlan-sw brief
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0, Fa1/1, Fa1/2, Fa1/4
                                                Fa1/5, Fa1/6, Fa1/7, Fa1/8
                                                Fa1/9, Fa1/10, Fa1/11, Fa1/12
                                                Fa1/13, Fa1/14, Fa1/15
10   VLAN10                           active    Fa1/3
20   VLAN20                           active   
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
SW2(config)#int f1/2
SW2(config-if)#switchport access vlan 20
SW2(config-if)#end
SW2#show vlan-sw brief
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0, Fa1/1, Fa1/3, Fa1/4
                                                Fa1/5, Fa1/6, Fa1/7, Fa1/8
                                                Fa1/9, Fa1/10, Fa1/11, Fa1/12
                                                Fa1/13, Fa1/14, Fa1/15
10   VLAN10                           active   
20   VLAN20                           active    Fa1/2
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
Configuramos los Puertos en modo Trunk.
SW1(config)#int f1/2
SW1(config-if)#switchport mode trunk
SW1(config)#int f1/1
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#switchport mode trunk
SW1(config-if)#end
SW1#show int trunk

Port      Mode         Encapsulation  Status        Native vlan
Fa1/1     on           802.1q         trunking      1
Fa1/2     on           802.1q         trunking      1

Port      Vlans allowed on trunk
Fa1/1     1-4094
Fa1/2     1-4094

Port      Vlans allowed and active in management domain
Fa1/1     1,10,20
Fa1/2     1,10,20

Port      Vlans in spanning tree forwarding state and not pruned
Fa1/1     none
Fa1/2     1,10,20
SW2(config)#int f1/1
SW2(config-if)#switchport mode trunk
SW2#show int trunk

Port      Mode         Encapsulation  Status        Native vlan
Fa1/1     on           802.1q         trunking      1

Port      Vlans allowed on trunk
Fa1/1     1-4094

Port      Vlans allowed and active in management domain
Fa1/1     1,10,20

Port      Vlans in spanning tree forwarding state and not pruned
Fa1/1     none
Configuramos el Router
R1(config)#int f0/0
R1(config-if)#no ip address
R1(config-if)#no shutdown
R1(config-if)#int f0/0.10
R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip address 172.17.10.1 255.255.255.0
R1(config-subif)#exit
R1(config)#int f0/0.20
R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip add 172.17.20.1 255.255.255.0
R1(config-subif)#end
R1#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES manual up                    up     
FastEthernet0/0.10         172.17.10.1     YES manual up                    up     
FastEthernet0/0.20         172.17.20.1     YES manual up                    up     
FastEthernet0/1            unassigned      YES unset  administratively down down   
R1#
Configuramos una IP y el Default Gateway a cada uno de los hosts (qemu host):
PC1:
ifconfig eth0 172.17.10.10 netmask 255.255.255.0 up
route add default gw 172.17.10.1
PC2:
ifconfig eth0 172.17.20.10 netmask 255.255.255.0 up
route add default gw 172.17.20.1
Verificamos con un ping desde cada PC.



Rutas Conectadas y Rutas Estáticas

Los Routers necesitan tener rutas en sus tablas de enrutamiento IP para poder enviar los paquetes a la direcciónes correctas. Dos formas por el cual un router agrega rutas en su tabla de enrutamiento es aprendiendo o se da cuenta que redes tiene conectadas en sus interfaces y otra forma es mediante la configuración de las rutas desde la configuración global. La siguiente imagen muestra una topologia básica para configurar rutas estáticas.

Topologia Básica de la Red.

En GNS3, la topologia de rede se vería mas o menos de la siguiente manera.

Topologia de Red en GNS3.

Rutas Conectadas.


Configuración de las interfaces en el Router1
!
interface FastEthernet0/0
ip address 10.1.128.251 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.130.251 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 10.1.1.251 255.255.255.0
duplex auto
speed auto
!
El comando siguiente muestras el estado de las interfaces en el Router1, como se puede ver las tres interfaces están en estado "up & up" y cada interface tiene configurado una dirección IP.
Router1#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.1.128.251    YES manual up                    up
FastEthernet0/1            10.1.130.251    YES manual up                    up
FastEthernet1/0            10.1.1.251      YES manual up                    up
Router1#
El siguiente comando nos muestra las rutas conocidas por el Router1, todas las rutas conectadas (C).
Router1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 3 subnets
C       10.1.1.0 is directly connected, FastEthernet1/0
C       10.1.130.0 is directly connected, FastEthernet0/1
C       10.1.128.0 is directly connected, FastEthernet0/0
Router1#
El Router1 agrego las rutas de las tres subredes que se encuentran conectadas a su tabla de enrutamiento. La letra "C" significa "Conectado".

Rutas Estáticas

Las rutas conectadas son importantes, pero los routers suelen necesitar de otras rutas para enviar la información a todas las subredes de una red. Por ejemplo el Router1 puede fácilmente realizar un Ping a las subredes que tiene conectadas, por ejemplo a la subred conectada 10.1.1.0/24. Sin embargo si se realiza un Ping a la subred 10.1.2.0/24 no la conocerá y no podrá llegar a esa subred. Tal como se muestra a continuación.

Ping a la subred conectada, interface Fa0/0 del Router2.
Router1#ping 10.1.128.252

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.128.252, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/60/116 ms
Router1#
Ping a la Subred 10.1.2.0/24.
Router1#ping 10.1.2.252

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.252, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Router1#
El comando Ping envía un paquete de solicitud ICMP (echo request) a la dirección destino. El host destino responde al ping solicitado con un paquete llamada ICMP de respuesta o echo reply. El comando Ping envía el primer paquete y espera la respuesta. Si se recibe una respuesta, el comando muestra un "!". Si no se recibe una respuesta en el tiempo de espera predeterminado de 2 segundos, el comando ping nos muestra un ".". En el IOS de cisco, el comando Ping envía cinco de estos paquetes de forma predeterminada. En el ejemplo anterior el primer Ping dado a la IP 10.1.128.252 funciona correctamente, ya que nos muestra todos los "!!!!!". Sin embargo, el Ping dado a la dirección IP 10.1.2.252 no funciona, ya que nos muestra todo los ".....", esto es porque el Router1 no tiene una ruta para la subred 10.1.2.0/24 donde se encuentra la IP 10.1.2.252.

La solución mas sencilla y típica para este problema es configurar un protocolo de enrutamiento en los tres Routers. Sin embargo, en lugar de protocolos de enrutamientos, podemos configurar rutas estáticas. Para configurar rutas estáticas se realiza de la siguiente manera.

Configurando Rutas Estáticas en el Router1.
Router1#configure terminal
Router1(config)#ip route 10.1.2.0 255.255.255.0 10.1.128.252
Router1(config)#ip route 10.1.3.0 255.255.255.0 10.1.130.252
Router1(config)#^Z
Router1#
*Mar  1 00:11:14.279: %SYS-5-CONFIG_I: Configured from console by console
Router1#show ip route static
10.0.0.0/24 is subnetted, 5 subnets
S       10.1.3.0 [1/0] via 10.1.130.252
S       10.1.2.0 [1/0] via 10.1.128.252
Router1#
Desde configuración global le indicamos cual sera la subred con su respectiva mascara y la dirección IP del siguiente salto. Ahora el Router1 sabe como enviar las rutas a los demás Routers de la Red. También se muestra el comando show ip route static, con el podemos visualizar que rutas estáticas tenemos configuradas en el Router1. El Signo de "S" significa que la ruta fue configurada estaticamente.

Ping a las demás Subredes.
Router1#ping 10.1.2.252
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.252, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/56/132 ms

Router1#ping 10.1.3.253
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.3.253, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/44/136 ms
Router1#
Visualizar todas las rutas en el Router1.
Router1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 5 subnets
S       10.1.3.0 [1/0] via 10.1.130.252
S       10.1.2.0 [1/0] via 10.1.128.252
C       10.1.1.0 is directly connected, FastEthernet1/0
C       10.1.130.0 is directly connected, FastEthernet0/1
C       10.1.128.0 is directly connected, FastEthernet0/0
Router1#
Como se puede observar tenemos comunicación con las subredes configuradas, esto solo desde el Router1. En los demás Routers se tiene que hacer el mismo proceso para configurar las rutas estáticas y así tener comunicación con las demás subredes.
En este vídeo muestro cómo solucionar un defecto de GNS3 cuando se crean proyectos y éste no guarda el archivo de configuración inicial o startup_config de un router Cisco.

Video On-line:
http://www.youtube.com/watch?v=LQ0W0oOLKhk

Commandos
R1#show run
R1#show ip interface brief
R1#configure terminal
R1(config)#hostname delfirosales
delfirosales(config)#interface f0/0
delfirosales(config-if)#no shutdown
delfirosales(config-if)#ip address 192.168.1.1 255.255.255.0
delfirosales(config-if)#end
delfirosales#show ip int brief
delfirosales#wr

Instalar GNS3 en Ubuntu 9.10

He pasado un buen rato tratando de instalar gsn3 en ubuntu, es por eso que he decidido crear este post para mostrar los pasos que realice para instalar GNS3 v0.7RC1 en ubuntu 9.10.

¿Cómo instalar GNS3 en Ubuntu 9.10 ?

Abrimos la consola y agregamos lo siguiente.

sudo aptitude install build-essential libelf1 libelf libpcap0.8 libpcap0.8-dev python-dev, python-Python apoyo configobj python-qt4 estiba



Descargamos GNS3 del siguiente enlace http://www.gns3.net/download (Descargamos GNS3-0.7RC1-src.tar.gz)

Una vez descargado el archivo anterior lo extraemos dando clic derecho y "Extraer aquí" o igual puedes hacerlo desde consola con el siguiente comando

tar zxf GNS3-0.7RC1-src.tar.gz

Esto creara una carpeta llamada GNS3-0.7RC1-src.

Ahora pasamos a descargar el Dynamips desde la siguiente pagina http://www.ipflow.utc.fr/blog/ Descargamos 0.2.8-RC2 binary for Linux x86 platforms

Una vez descargado Dynamips hacemos clic derecho en el archivo descargado "dynamips-0.2.8-RC2-x86.bin" y seleccionamos Propiedades, en la sección de permisos activamos la opción "Permitir ejecutar el archivo como un programa" tal como se muestra en la siguiente imagen.


imagen permisos de ejecución.

Ahora desde la consola nos vamos al directorio donde extraimos GSN3, en mi caso GNS3-0.7RC1-src y ejecutamos el siguiente comando.

sudo python setup.py install



Nos dirigimos a la carpeta donde extraimos GSN3, en mi caso GNS3-0.7RC1-src, ahí encontraremos un archivo llamado gsn3, solo hacemos doble clic en el archivo y nos saldrá un recuadro preguntando que hacer, seleccionamos "Ejecutar" esto iniciaría GSN3, también podemos hacerlo desde consola ejecutando "./gns3".



Toca configurar la direccion donde tenemos el Dynamips (dynamips-0.2.8-RC2-x86.bin), para esto podemos dar clic en el numero 1 (step 1) del Menu que se nos presento por primera vez al ejecutar GSN3 o desde el Edit - Preferencias - Dynamips de GSN3.

En la sección de Ruta del ejecutable seleccionamos donde tenemos el archivo descargado "dynamips-0.2.8-RC2-x86.bin", una vez hecho esto hacemos clic en "Prueba" o test, si toda va bien tiene que aparecer un mensaje en verde "Dynamips Successfully started" tal y como se muestra en la siguiente imagen.



Ahora toca agregar las imágenes IOS para esto hacemos clic en el paso 2 (step 2) del menu que se nos presento por primera vez, o desde el menu Edit - Imagenes IOS e Hypervisors.

En la sección Image file seleccionamos la ubicación de la imagen IOS que deseamos agregar y hacemos clic en Save, tal como se muestra en la siguiente imagen.



En esta sección podemos agregar mas imágenes IOS, en mi caso solo agregue una imagen de un router 7200. Una vez hecho esto ya tenemos listo para empezar a emular imágenes IOS.





Realice un vídeo en el que se muestra como instalar GNS3 en ubuntu 9.10, puedes verlo en los siguientes enlaces.

Video - Instalación de GNS3 v0.7 RC1 en Ubuntu 9.10
http://delfirosales.blogspot.com/2010/02/video-instalacion-de-gns3-en-ubuntu.html