Seguridad y Redes

Tips & Video Tutoriales, Wifislax, VMware, GNS3, VirtualBox, CCNA, Cisco Routers & Switches, [ Programming ]

Configuración de SVIs en un Switch de Capa 3

Las VLAN dividen dominios de transmisión en un entorno LAN. Siempre que los host de una VLAN necesitan comunicarse con algun otro host en otra VLAN, debe enrutarse el tráfico entre ellos. Esto se denomina ruteo interVLAN. En los switches Catalyst, se logra al crear interfaces de Capa 3 (Switch Virtual Interface - SVI).

Host1
IP: 10.1.1.5
Default Gateway: 10.1.1.1
Subnet: 255.255.255.0 

Host2
IP: 10.1.2.2
Default Gateway: 10.1.2.1
Subnet: 255.255.255.0
Topologia en GNS3 utilizando la imagen vIOS-L2 y Core Linux.

Configuracion en Core Linux 1.
labs login: delfi
Password:
                                   /\_/\
                                  ( o.o )
                                   > ^ <
                              delfirosales.com
delfi@labs:~$ 
delfi@labs:~$ sudo su
root@labs:/home/delfi# ifconfig eth0 10.1.1.5 netmask 255.255.255.0 up
root@labs:/home/delfi# route add default gw 10.1.1.1
Core Linux 2.
delfi@labs:~$ 
delfi@labs:~$ sudo su
root@labs:/home/delfi# ifconfig eth0 10.1.2.2 netmask 255.255.255.0 up
root@labs:/home/delfi# route add default gw 10.1.2.1
root@labs:/home/delfi# 
Habilitar ruteo en el Switch
vIOS-L2#configure terminal
vIOS-L2(config)#ip routing 
Configuracion y creacion de VLANs
vIOS-L2(config)#interface gigabitEthernet0/1
vIOS-L2(config-if)#switchport access vlan 2
% Access VLAN does not exist. Creating vlan 2
vIOS-L2(config-if)#switchport mode access 
vIOS-L2(config-if)#exit

vIOS-L2(config)#interface gigabitEthernet0/2
vIOS-L2(config-if)#switchport access vlan 3
% Access VLAN does not exist. Creating vlan 3
vIOS-L2(config-if)#switchport mode access 
vIOS-L2(config-if)#exit
Verificacion de las VLANs creadas anterior.
vIOS-L2#show vlan   

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi0/0, Gi0/3
2    VLAN0002                         active    Gi0/1
3    VLAN0003                         active    Gi0/2
100  VLAN100                          active    
200  VLAN0200                         active    
300  VLAN0300                         active    
1002 fddi-default                     act/unsup 
1003 trcrf-default                    act/unsup 
1004 fddinet-default                  act/unsup 
1005 trbrf-default                    act/unsup 

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0   
2    enet  100002     1500  -      -      -        -    -        0      0   
3    enet  100003     1500  -      -      -        -    -        0      0   
100  enet  100100     1500  -      -      -        -    -        0      0   
200  enet  100200     1500  -      -      -        -    -        0      0   
300  enet  100300     1500  -      -      -        -    -        0      0   
1002 fddi  101002     1500  -      -      -        -    -        0      0   
          
VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1003 trcrf 101003     4472  1005   3276   -        -    srb      0      0   
1004 fdnet 101004     1500  -      -      -        ieee -        0      0   
1005 trbrf 101005     4472  -      -      15       ibm  -        0      0   


VLAN AREHops STEHops Backup CRF
---- ------- ------- ----------
1003 7       7       off

Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------


Creacion de la SVI 2.
vIOS-L2(config)#interface vlan 2
vIOS-L2(config-if)#ip address 10.1.1.1 255.255.255.0
vIOS-L2(config-if)#no shutdown 
vIOS-L2(config-if)#exit
Creacion de la SVI 3.
vIOS-L2(config)#interface vlan 3
vIOS-L2(config-if)#ip address 10.1.2.1 255.255.255.0
vIOS-L2(config-if)#no shutdown 
vIOS-L2(config-if)#end
vIOS-L2#
Si ingresamos el siguiente comando podremos observar que las interfaces se encuentran arriba.
vIOS-L2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0     unassigned      YES unset  up                    up      
GigabitEthernet0/1     unassigned      YES unset  up                    up      
GigabitEthernet0/2     unassigned      YES unset  up                    up      
GigabitEthernet0/3     unassigned      YES unset  up                    up      
Vlan2                  10.1.1.1        YES manual up                    up      
Vlan3                  10.1.2.1        YES manual up                    up      
vIOS-L2#
Tambien podremos observar la tabla de ruteo con el comando show ip route.
vIOS-L2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C        10.1.1.0/24 is directly connected, Vlan2
L        10.1.1.1/32 is directly connected, Vlan2
C        10.1.2.0/24 is directly connected, Vlan3
L        10.1.2.1/32 is directly connected, Vlan3
vIOS-L2#

vIOS-L2#show interfaces vlan 2
Vlan2 is up, line protocol is up 
  Hardware is Ethernet SVI, address is 0000.ab5a.8002 (bia 0000.ab5a.8002)
  Internet address is 10.1.1.1/24
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not supported 
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:10, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     652 packets input, 98538 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     17 packets output, 1054 bytes, 0 underruns
     0 output errors, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
vIOS-L2#
Verificacion de Core Linux 1 a Core Linux 2.


Otros comandos de verificacion.
vIOS-L2#show interfaces vlan 3
vIOS-L2#show interface gigabitEthernet0/0
vIOS-L2#show interfaces gigabitEthernet0/0 switchport
vIOS-L2#show vlan brief
Descargar Core Linux: LinuxCore-6.4.1.img
Este error se produce cuando reinicias el router o cuando guardas la configuracion de tu lab y que en otro momento cuando decides volver a retomar tu laboratirio quieres borrar una VLAN se produce este error.
R3(config)#no vlan 50
% not enough space on flash to store vlan database. trying squeeze...
squeeze of flash complete
% not enough space on flash to store vlan database even after squeeze
Error exiting config-vlan mode 40: NV storage failure
R3(config)#

R3#show flash
System CompactFlash directory:
File  Length   Name/status
  1   660      vlan.dat [deleted]
[16777212 bytes used, 0 available, 16777212 total]
16384K bytes of ATA System CompactFlash (Read/Write)
La solución a este error es
R3#erase flash:
Erasing the flash filesystem will remove all files! Continue? [confirm]
Erasing device... eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee ...erased
Erase of flash: complete

R3#squeeze flash:
Squeeze operation may take a while. Continue? [confirm]
Squeeze of flash complete

R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#do sh vlan-sw
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/2, Fa1/3, Fa1/4, Fa1/5
                                                Fa1/6, Fa1/7, Fa1/8, Fa1/9
                                                Fa1/10, Fa1/11, Fa1/12, Fa1/13
                                                Fa1/14, Fa1/15
50   VLAN0050                         active    
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
50   enet  100050     1500  -      -      -        -    -        0      0 
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0 
1005 trnet 101005     1500  -      -      1        ibm  -        0      0 

R3(config)#no vlan 50
R3(config)#end
R3#show vlan-sw
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/2, Fa1/3, Fa1/4, Fa1/5
                                                Fa1/6, Fa1/7, Fa1/8, Fa1/9
                                                Fa1/10, Fa1/11, Fa1/12, Fa1/13
                                                Fa1/14, Fa1/15
1002 fddi-default                     act/unsup 
1003 token-ring-default               act/unsup 
1004 fddinet-default                  act/unsup 
1005 trnet-default                    act/unsup 

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
Y  tenemos espacio libre
R3#show flash  
System CompactFlash directory:
File  Length   Name/status
  1   600      vlan.dat
[664 bytes used, 16776548 available, 16777212 total]
16384K bytes of ATA System CompactFlash (Read/Write)
IOS version c3725-adventerprisek9-mz124-15.bin

Como utilizar un Switch en GNS3

En GNS3 no podemos simular la serie de Switches Cisco 2900 y 3500. Solo podemos practicar un 40% de la parte de Switching utilizando un IOS de un router 3700, específicamente el ios c3725-adventerprisek9-mz124-15.bin y agregando el modulo NM-16ESW. Así podemos practicar una parte de los temas de Switching, como VTP, VLANs, InterVLAN Routing, modos de puertos trunk, access y la encapsulación de datos (ISL & IEEE 802.1Q).
  • En nuestro primer paso, abriremos GNS3, después nos vamos al menú Editar - Administrador de Símbolos.

  • Añadimos ethernet_switching, agreamos un nombre y en la parte de Tipo seleccionamos el router 3700, al final damos clic en aceptar.
  • Ahora podemos ver el SW en la parte de abajo.

  • Ahora arrastramos el Switch en el campo de trabajo de GNS3, hacemos clic derecho y añadimos el modulo NM-16ESW desde el menu Slots.
Laboratorio de Switching en GNS3

Bueno ahora que tenemos el modulo instalado, toca realizar las conexiones con los equipos o simplemente iniciar el Switch para realizar las diferentes configuración.

  • Cambiamos el nombre del equipo, creamos dos VLANs y verificamos.
R2>
R2>en
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#hostname Switch
Switch(config)#
Switch(config)#do show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet0/1            unassigned      YES unset  administratively down down
FastEthernet1/0            unassigned      YES unset  up                    up
FastEthernet1/1            unassigned      YES unset  up                    down
FastEthernet1/2            unassigned      YES unset  up                    down
FastEthernet1/3            unassigned      YES unset  up                    down
FastEthernet1/4            unassigned      YES unset  up                    down
FastEthernet1/5            unassigned      YES unset  up                    down
FastEthernet1/6            unassigned      YES unset  up                    down
FastEthernet1/7            unassigned      YES unset  up                    down
FastEthernet1/8            unassigned      YES unset  up                    down
FastEthernet1/9            unassigned      YES unset  up                    down
FastEthernet1/10           unassigned      YES unset  up                    down
FastEthernet1/11           unassigned      YES unset  up                    down
FastEthernet1/12           unassigned      YES unset  up                    down
FastEthernet1/13           unassigned      YES unset  up                    down
FastEthernet1/14           unassigned      YES unset  up                    down
FastEthernet1/15           unassigned      YES unset  up                    down
Vlan1                      unassigned      YES unset  up                    up
Switch(config)#int vlan1
Switch(config-if)#ip add 192.168.1.1 255.255.255.0
Switch(config-if)#no shut
Switch(config-if)#exit
Switch(config)#
Switch(config)#vlan 10
Switch(config-vlan)#name delfirosales
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#name RH
Switch(config-vlan)#exit
Switch(config)#end
Switch#show
*Mar  1 00:08:02.799: %SYS-5-CONFIG_I: Configured from console by console
Switch#show vlan-sw

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0, Fa1/1, Fa1/2, Fa1/3
                             Fa1/4, Fa1/5, Fa1/6, Fa1/7
                             Fa1/8, Fa1/9, Fa1/10, Fa1/11
                             Fa1/12, Fa1/13, Fa1/14, Fa1/15
10   delfirosales                     active
20   RH                               active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
10   enet  100010     1500  -      -      -        -    -        0      0
20   enet  100020     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0
1005 trnet 101005     1500  -      -      1        ibm  -        0      0
Switch#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet0/1            unassigned      YES unset  administratively down down
FastEthernet1/0            unassigned      YES unset  up                    up
FastEthernet1/1            unassigned      YES unset  up                    down
FastEthernet1/2            unassigned      YES unset  up                    down
FastEthernet1/3            unassigned      YES unset  up                    down
FastEthernet1/4            unassigned      YES unset  up                    down
FastEthernet1/5            unassigned      YES unset  up                    down
FastEthernet1/6            unassigned      YES unset  up                    down
FastEthernet1/7            unassigned      YES unset  up                    down
FastEthernet1/8            unassigned      YES unset  up                    down
FastEthernet1/9            unassigned      YES unset  up                    down
FastEthernet1/10           unassigned      YES unset  up                    down
FastEthernet1/11           unassigned      YES unset  up                    down
FastEthernet1/12           unassigned      YES unset  up                    down
FastEthernet1/13           unassigned      YES unset  up                    down
FastEthernet1/14           unassigned      YES unset  up                    down
FastEthernet1/15           unassigned      YES unset  up                    down
Vlan1                      192.168.1.1     YES manual up                    up
Switch#ping 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
Switch#ping 192.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 12/50/116 ms
Switch#

Usando VTP: Configurando Servers y Clientes

Todos los Switches cisco están configurados por defecto como servidores VTP. Para configurar VTP (VLAN Trunking Protocol), primero necesitamos configurar el nombre de dominio, seguido por el modo de funcionamiento del Switch (Modo Server, Modo Cliente, Modo Transparente), establecer una contraseña a VTP (opcional pero si recomendado), todo esto desde configuración global.

En resumen los pasos para configurar VTP, son las siguientes:
Paso 1: Lo primero es configurar que los Switches estén en modo Trunk.
Paso 2: Configurar el Configurar el nombre de dominio
Paso 3: Configurar el modo de funcionamiento del Switch (mode server, mode client, mode tranparent)
Paso 4: Configurar una contraseña (Opcional)
Paso 5: Configurar VTP Pruning en el Servidor (Opcional)
Paso 6: Habilitar VTP versión 2 (Opcional)

En este ejemplo configuraremos tres Switches. El primero lo pondremos en Modo Server, el segundo en Modo Transparente y el tercero en Modo Cliente. Tal como se muestra en la siguiente imagen.


Modos VTP (VLAN Trunking Protocol).

Lo primero es configurar las interfaces donde tenemos conectados los Switches en modo Trunk.

Configurar la interface Fa0/1 en el Switch1.
Switch1#configure terminal
Switch1(config)#int fa0/1
Switch1(config-if)#switchport mode trunk
Switch1(config-if)#end
Switch1#show int trunk

Port        Mode         Encapsulation  Status        Native vlan
Fa0/1       on           802.1q         trunking      1

Port      Vlans allowed on trunk
Fa0/1       1-4094

Port        Vlans allowed and active in management domain
Fa0/1       1

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/1       1

Switch1#show run int fa0/1
Building configuration...

Current configuration : 56 bytes
!
interface FastEthernet0/1
switchport mode trunk
end
Configurar Interfaces Fa0/1 y Fa0/2 en el Switch2.
Switch2#configure terminal
Switch2(config)#int fa0/1
Switch2(config-if)#switchport mode trunk
Switch2(config-if)#exit
Switch2(config)#int fa0/2
Switch2(config-if)#switchport mode trunk
Switch2(config-if)#end
Switch2#show int trunk

Port        Mode         Encapsulation  Status        Native vlan
Fa0/1       on           802.1q         trunking      1
Fa0/2       on           802.1q         trunking      1

Port      Vlans allowed on trunk
Fa0/1       1-4094
Fa0/2       1-4094

Port        Vlans allowed and active in management domain
Fa0/1       1
Fa0/2       1

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/1       1
Fa0/2       1

Switch2#show run int fa0/1
Building configuration...

Current configuration : 56 bytes
!
interface FastEthernet0/1
switchport mode trunk
end

Switch2#show run int fa0/2
Building configuration...

Current configuration : 56 bytes
!
interface FastEthernet0/2
switchport mode trunk
end
Configurar Interface Fa0/1 en el Switch3.
Switch3#configure terminal
Switch3(config)#int f0/1
Switch3(config-if)#switchport mode trunk
Switch3(config-if)#end
Switch3#show int trunk

Port        Mode         Encapsulation  Status        Native vlan
Fa0/1       on           802.1q         trunking      1

Port      Vlans allowed on trunk
Fa0/1       1-4094

Port        Vlans allowed and active in management domain
Fa0/1       1

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/1       1
Switch3#show run int fa0/1
Building configuration...

Current configuration : 56 bytes
!
interface FastEthernet0/1
switchport mode trunk
end
Configurar el nombre de dominio, Modo Server, un password y el VTP Pruning en el Switch1.
Switch1#configure terminal
Switch1(config)#vtp domain delfirosales
Changing VTP domain name from NULL to delfirosales
Switch1(config)#vtp mode server
Device mode already VTP SERVER.
Switch1(config)#vtp password cisco
Setting device VLAN database password to cisco
Switch1(config)#vtp pruning
Pruning switched on
Switch1(config)#end
Switch1#
Verificamos la configuración de VTP en el Switch1
Switch1#show vtp status
VTP Version                     : 2
Configuration Revision          : 4
Maximum VLANs supported locally : 128
Number of existing VLANs        : 8
VTP Operating Mode              : Server
VTP Domain Name                 : delfirosales
VTP Pruning Mode                : Enabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x34 0xFC 0x71 0x0B 0x6F 0x86 0x1B 0x6D
Configuration last modified by 192.168.1.1 at 3-1-93 00:25:41
Local updater ID is 192.168.1.1 on interface Vl1 (lowest numbered VLAN interface found)
Switch1#
Configurar un nombre de dominio, VTP en modo Transparente y un password en el Switch2.
Switch2#configure terminal
Switch2(config)#vtp domain delfirosales
Domain name already set to delfirosales.
Switch2(config)#vtp mode transparent
Setting device to VTP TRANSPARENT mode.
Switch2(config)#vtp password cisco
Setting device VLAN database password to cisco
Switch2(config)#end
Switch2#
Verificamos la configuracion realizada en el Switch2.
Switch2#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 128
Number of existing VLANs        : 8
VTP Operating Mode              : Transparent
VTP Domain Name                 : delfirosales
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x6C 0x55 0x26 0x46 0x3B 0xBA 0xAD 0xA1
Configuration last modified by 192.168.1.1 at 3-1-93 00:16:19
Switch2#
Configurar un nombre de dominio, vtp en Modo Cliente y un password en el Switch3.
Switch3#configure terminal
Switch3(config)#vtp domain delfirosales
Domain name already set to delfirosales.
Switch3(config)#vtp mode client
Setting device to VTP CLIENT mode.
Switch3(config)#vtp password cisco
Setting device VLAN database password to cisco
Switch3(config)#end
Switch3#
Verificamos la configuración de VTP.
Switch3#show vtp status
VTP Version                     : 2
Configuration Revision          : 3
Maximum VLANs supported locally : 128
Number of existing VLANs        : 8
VTP Operating Mode              : Client
VTP Domain Name                 : delfirosales
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x84 0xA5 0x24 0x73 0x35 0x8C 0x3F 0x2C
Configuration last modified by 192.168.1.1 at 3-1-93 00:16:19
Switch3#
Hemos terminado de configurar los tres Switches, el primero en modo Server, el segundo en modo Tranparente y el tercero en modo Cliente. Ahora lo que aremos es verificar que VTP funcione correctamente, para esto debemos de saber que funciones realiza cada Switch.

Modo Server: El modo Server como lo mencione anteriormente, esta habilitado por defecto en los switches cisco, necesita al menos un servidor de dominio VTP para propagar la información de las VLANs a través de ese dominio. Un Switch en modo server puede crear, agregar y borrar VLANs. Cuando en un VTP Server se crean o borran las VLANs, esta información se envía a todos los switches conectados, asi que cualquier cambio realizado en un Switch en Modo Server se envia toda la información en todo el dominio VTP.

Modo Transparente: Un Switch en modo Transparente si recibe la información del dominio VTP, el detalle es que no ejecuta ninguna información recibida, mantiene su propia base de datos y solo envía la información de dominio VTP a todos los demas Switches.

Modo Cliente: Los Switches en Modo cliente si reciben la informacion de los servers de VTP, también envían información a los demás Switches, así que el comportamiento de este modo es parecido a los de modo Server. La diferencia es que en este modo no se pueden crear, modificar o borrar VLANs.

VTP Pruning: Habilitar VTP pruning nos da una forma de preservar el ancho de banda mediante la reduccion de paquetes broadcast, multicast y unicast. Lo que hace es darse cuenta que paquetes deben de avanzar hacia el siguiente Switch.

Crear una VLAN en el Switch1 (modo server), esto hará que el Switch2 reciba información de la creación de una VLAN pero no le hará caso, lo que hará es enviar la información al Switch3 (cliente) donde si se creara la VLAN. Vamos a verificar que VTP funcione correctamente.
Switch1#configure terminal
Switch1(config)#vlan 3
Switch1(config-vlan)#name users
Switch1(config-vlan)#end
Switch1#
Verficicamos el estado de VTP y las VLANs en el Switch1 (Modo Server)
Switch1#show vtp status
VTP Version                     : 2
Configuration Revision          : 5
Maximum VLANs supported locally : 128
Number of existing VLANs        : 9
VTP Operating Mode              : Server
VTP Domain Name                 : delfirosales
VTP Pruning Mode                : Enabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x68 0x34 0x28 0xF9 0xBC 0x11 0xFD 0x0D
Configuration last modified by 192.168.1.1 at 3-1-93 00:34:23
Local updater ID is 192.168.1.1 on interface Vl1 (lowest numbered VLAN interface found)
Switch1#
Switch1#show vlan  

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/5
                                      Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                      Fa0/10, Fa0/11, Fa0/12
2    VLAN2                            active
3    users                            active
101  VLAN101                          active
105  VLAN105                          active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
2    enet  100002     1500  -      -      -        -    -        0      0
3    enet  100003     1500  -      -      -        -    -        0      0
15   enet  100015     1500  -      -      -        -    -        0      0
101  enet  100101     1500  -      -      -        -    -        0      0

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
105  enet  100105     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs
------------------------------------------------------------------------------

Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------
Como podemos observar, hemos creado la VLAN 3 llamada users, ahora verificaremos el Switch2, no tiene que tener la VLAN 3 ya que esta en modo transparente.

Verficicar el estado de VTP y las VLANs en el Switch2 (Modo Transparente).
Switch2#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 128
Number of existing VLANs        : 8
VTP Operating Mode              : Transparent
VTP Domain Name                 : delfirosales
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x6C 0x55 0x26 0x46 0x3B 0xBA 0xAD 0xA1
Configuration last modified by 192.168.1.1 at 3-1-93 00:16:19
Switch2#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6
                                   Fa0/7, Fa0/8, Fa0/9, Fa0/10
                                   Fa0/11, Fa0/12
2    VLAN2                            active
101  VLAN101                          active
105  VLAN105                          active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
2    enet  100002     1500  -      -      -        -    -        0      0
101  enet  100101     1500  -      -      -        -    -        0      0
105  enet  100105     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    srb      0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs
------------------------------------------------------------------------------

Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------
Tal como se muestra no se creo ninguna VLAN, pero si debió de enviar la información al Switch3 donde tiene que haber creado la VLAN 3. Asi que vamos a ver que paso en el Switch3.

Verficicar el estado de VTP y las VLANs en el Switch3 (Modo Cliente).
Switch3#show vtp status
VTP Version                     : 2
Configuration Revision          : 5
Maximum VLANs supported locally : 128
Number of existing VLANs        : 9
VTP Operating Mode              : Client
VTP Domain Name                 : delfirosales
VTP Pruning Mode                : Enabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x68 0x34 0x28 0xF9 0xBC 0x11 0xFD 0x0D
Configuration last modified by 192.168.1.1 at 3-1-93 00:34:23
Switch3#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/5
                                   Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                   Fa0/10, Fa0/11, Fa0/12
2    VLAN2                            active
3    users                            active
101  VLAN101                          active
105  VLAN105                          active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
2    enet  100002     1500  -      -      -        -    -        0      0
3    enet  100003     1500  -      -      -        -    -        0      0
101  enet  100101     1500  -      -      -        -    -        0      0
105  enet  100105     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1003 tr    101003     1500  -      -      -        -    srb      0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs
------------------------------------------------------------------------------

Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------
Como podemos observar el Switch3 ha creado la VLAN 3 llamada users creada desde el Switch1 Modo Server. Tambien podemos observar que el vtp pruning esta habilita en el Switch3 aunque lo hallamos habilitado desde el Switch1.

Ahora en el Switch3 si tratamos de crear vlans en el switch3, no podremos crearlas ni borrarlas.
Switch3#configure terminal
Switch3(config)#vlan 10
VTP VLAN configuration not allowed when device is in CLIENT mode.
Switch3(config)#
En cambio en el Switch2 modo tranparente si podemos crear vlans, pero se quedan en su base de datos, no se envían la información a los demás Switches.
Switch2#configure terminal
Switch2(config)#vlan 20
Switch2(config-vlan)#name VLAN20
Switch2(config-vlan)#exit
Switch2(config)#end
Switch2#show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6
                                   Fa0/7, Fa0/8, Fa0/9, Fa0/10
                                   Fa0/11, Fa0/12
2    VLAN2                            active
20   VLAN20                           active
101  VLAN101                          active
105  VLAN105                          active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
Switch2#
En el Switch1 y el Switch3 no se crea ninguna VLAN, ya que el modo tranparente no participa en el dominio VTP pero si recibe y envia la informacion a los diferentes Switches.

Switch1
Switch1#show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/5
                                   Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                   Fa0/10, Fa0/11, Fa0/12
2    VLAN2                            active
3    users                            active
101  VLAN101                          active
105  VLAN105                          active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
Switch1#
Switch2
Switch3#show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/5
                                   Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                   Fa0/10, Fa0/11, Fa0/12
2    VLAN2                            active
3    users                            active
101  VLAN101                          active
105  VLAN105                          active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
Switch3#
Si se te ha olvidado el password de VTP
Switch3#show vtp password
VTP Password: cisco
Switch3#
Algo basico en la configuracion de VTP (VLAN Trunking Protocol).

Creando VLANs (Virtual LANs)

En este post se muestra las configuraciones básicas para crear VLANs (Virtual LANs). Los comandos los realice desde un Switch 2950. Para crear VLANs en el Switch Cisco Catalyst 2950 es de la siguiente manera. Primero creamos tres VLANs (de la vlan 2 a la 4) con el comando "vlan" siguiendo del numero de la vlan, también podemos agregarle un nombre tecleando name y el nombre de la VLAN.
Switch#vlan database
Switch(vlan)#vlan 2 name VLAN2
VLAN 2 added:
Name: VLAN2
Switch(vlan)#vlan 3 name VLAN3
VLAN 3 added:
Name: VLAN3
Switch(vlan)#vlan 4 name VLAN4
VLAN 4 added:
Name: VLAN4
Switch(vlan)#exit
APPLY completed.
Exiting....
Switch#
Ahora para verificar las VLANs creadas, tecleamos el comando "show vlan".
Switch#show vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4,
                       Fa0/5, Fa0/6, Fa0/7, Fa0/8,
                       Fa0/9, Fa0/10, Fa0/11, Fa0/12
2    VLAN2                            active
3    VLAN3                            active
4    VLAN4                            active
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
2    enet  100002     1500  -      -      -        -    -        0      0
3    enet  100003     1500  -      -      -        -    -        0      0
4    enet  100004     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0
1005 trnet 101005     1500  -      -      1        ibm  -        0      0
Switch#
Asignar el puerto FastEthernet0/2 (fa0/2) a la VLAN 2
Asignar el puerto FastEthernet0/3 (fa0/3) a la VLAN 3
Asignar el puerto FastEthernet0/4 (fa0/4) a la VLAN 4
Switch#config t
Switch(config)#interface f0/2
Switch(config-if)#switchport access vlan 2
Switch(config-if)#interface Fa0/3
Switch(config-if)#switchport access vlan 3
Switch(config-if)#interface Fa0/4
Switch(config-if)#switchport access vlan 4
Switch(config-if)#end
Switch#
Verificamos la configuración de las VLANs.
Switch#show vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/5, Fa0/6, Fa0/7,
                       Fa0/8, Fa0/9, Fa0/10, Fa0/11,
                       Fa0/12
2    VLAN2                            active    Fa0/2
3    VLAN3                            active    Fa0/3
4    VLAN4                            active    Fa0/4
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
2    enet  100002     1500  -      -      -        -    -        0      0
3    enet  100003     1500  -      -      -        -    -        0      0
4    enet  100004     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0
1005 trnet 101005     1500  -      -      1        ibm  -        0      0
Switch#
Al teclear el comando "show flash" veremos un fichero llamado "vlan.dat" donde se guarda la información de las vlans.